aboutsummaryrefslogtreecommitdiff
path: root/games/chessx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-23 17:08:57 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-23 17:08:57 +0000
commit1efcb55851309f58134aae7a1844ca1428a07afc (patch)
tree5fa049a3945080d82c35197a2cecd2e08401c81a /games/chessx
parent860c54a5e338de5f32be5d0257cc7087a19c6184 (diff)
downloadports-1efcb55851309f58134aae7a1844ca1428a07afc.tar.gz
ports-1efcb55851309f58134aae7a1844ca1428a07afc.zip
- Update to 1.0.0
- Add stage support - Convert to USES - Use options helpers - Patch qmake project file and remove do-install target from the port Makefile - Use pkg-plist PR: based on ports/184034 Submitted by: Yamagi Burmeister (maintainter)
Notes
Notes: svn path=/head/; revision=334686
Diffstat (limited to 'games/chessx')
-rw-r--r--games/chessx/Makefile45
-rw-r--r--games/chessx/distinfo4
-rw-r--r--games/chessx/files/patch-chessx.pro27
-rw-r--r--games/chessx/pkg-plist4
4 files changed, 45 insertions, 35 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 1e556e227bed..5f58755a8d0d 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -1,49 +1,28 @@
# $FreeBSD$
PORTNAME= chessx
-PORTVERSION= 0.9.6
+DISTVERSION= 1-0-0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+EXTRACT_SUFX= .tgz
MAINTAINER= yamagi@yamagi.org
-COMMENT= Qt4 chess database application
+COMMENT= Qt 4 chess database application
LICENSE= GPLv2 # (or later)
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_QT4= corelib gui svg xml network moc_build qmake_build rcc_build uic_build
-MAKE_JOBS_SAVE= yes
+USES= shared-mime-info qmake
+USE_QT4= corelib gui svg xml network linguist_build \
+ moc_build qmake_build rcc_build uic_build
+QMAKE_ARGS+= QMAKE_LRELEASE=${LRELEASE}
OPTIONS_DEFINE= STOCKFISH CRAFTY
-STOCKFISH_DESC= Build with Stockfish Chess Engine
-CRAFTY_DESC= Build with Crafty Chess Application
-OPTIONS_DEFAULT=STOCKFISH CRAFTY
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSTOCKFISH}
-RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
-.endif
-
-.if ${PORT_OPTIONS:MCRAFTY}
-RUN_DEPENDS+= crafty:${PORTSDIR}/games/crafty
-.endif
-
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-DESKTOP_ENTRIES="ChessX" "" "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "${PORTNAME}" "Game;BoardGame;" true
+OPTIONS_DEFAULT= STOCKFISH CRAFTY
-do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+STOCKFISH_DESC= Install Stockfish Chess Engine
+STOCKFISH_RUN_DEPENDS= stockfish:${PORTSDIR}/games/stockfish
-do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} release/${PORTNAME} ${PREFIX}/bin)
- (cd ${WRKSRC}/data/images && ${INSTALL_DATA} chessx.png \
- ${PREFIX}/share/pixmaps/${PORTNAME}.png)
+CRAFTY_DESC= Install Crafty Chess Application
+CRAFTY_RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
.include <bsd.port.mk>
diff --git a/games/chessx/distinfo b/games/chessx/distinfo
index 9b34af8cc28a..fc10210c6e69 100644
--- a/games/chessx/distinfo
+++ b/games/chessx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chessx-0-9-6.tar.gz) = 37ec638736b0e20fbdfb5db374bf971d76d81fe267ace3bde8b4e5c2d2e9c601
-SIZE (chessx-0-9-6.tar.gz) = 3213601
+SHA256 (chessx-1-0-0.tgz) = 822512e9142fd2aa7e9034ee84470d99f2c1df86d2b8cd97774e9e7bc97b7d72
+SIZE (chessx-1-0-0.tgz) = 3545265
diff --git a/games/chessx/files/patch-chessx.pro b/games/chessx/files/patch-chessx.pro
new file mode 100644
index 000000000000..24214621a768
--- /dev/null
+++ b/games/chessx/files/patch-chessx.pro
@@ -0,0 +1,27 @@
+--- ./chessx.pro.orig 2013-10-30 20:52:41.000000000 +0000
++++ ./chessx.pro 2013-11-18 16:36:14.764197702 +0000
+@@ -309,17 +309,14 @@
+ }
+
+ unix:!macx {
+- target.path = /usr/local/bin/chessx
+- pixmaps.path = /usr/share/pixmaps
++ target.path = $$PREFIX/bin
++ pixmaps.path = $$PREFIX/share/pixmaps
+ pixmaps.files = data/images/chessx.png
+- desktop.path = /usr/share/applications
+- desktop.files = chessx.desktop
+- desktop.extra += xdg-mime install --mode system chessx-x-chess-pgn.xml &&
+- desktop.extra += xdg-mime default chessx.desktop application/x-chess-pgn &&
+- desktop.extra += xdg-icon-resource install --context mimetypes --size 32 ./data/images/chessx-32.png application-x-chess-pgn &&
+- desktop.extra += xdg-icon-resource install --context mimetypes --size 64 ./data/images/chessx-64.png application-x-chess-pgn &&
+- desktop.extra += xdg-icon-resource install --context mimetypes --size 128 ./data/images/chessx.png application-x-chess-pgn
+- INSTALLS += target desktop pixmaps
++ desktop.path = $$PREFIX/share/applications
++ desktop.files = unix/chessx.desktop
++ mime.path = $$PREFIX/share/mime/packages
++ mime.files += unix/chessx-x-chess-pgn.xml
++ INSTALLS += target desktop pixmaps mime
+ }
+
+ RESOURCES = resources.qrc
diff --git a/games/chessx/pkg-plist b/games/chessx/pkg-plist
new file mode 100644
index 000000000000..f69abad7c7e3
--- /dev/null
+++ b/games/chessx/pkg-plist
@@ -0,0 +1,4 @@
+bin/chessx
+share/applications/chessx.desktop
+share/mime/packages/chessx-x-chess-pgn.xml
+share/pixmaps/chessx.png