aboutsummaryrefslogtreecommitdiff
path: root/games/chessx
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-10-05 13:11:28 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-10-05 13:11:28 +0000
commit39c2a2d563dc7672bb372af39103d1307f800fde (patch)
tree462b3c0bbaaf7b64c726996e9776c3b820e03faf /games/chessx
parent44d9cc4f4867b7013e026daa9c700d7223528a89 (diff)
downloadports-39c2a2d563dc7672bb372af39103d1307f800fde.tar.gz
ports-39c2a2d563dc7672bb372af39103d1307f800fde.zip
Update to 1.5.4
Notes
Notes: svn path=/head/; revision=551490
Diffstat (limited to 'games/chessx')
-rw-r--r--games/chessx/Makefile6
-rw-r--r--games/chessx/distinfo6
-rw-r--r--games/chessx/files/patch-chessx.pro36
3 files changed, 39 insertions, 9 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 127cb7d1e7b6..b868e1a753c9 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= chessx
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.4
CATEGORIES= games
MASTER_SITES= SF
@@ -11,10 +11,10 @@ COMMENT= Qt 5 chess database application
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lang desktop-file-utils gl qmake qt:5 tar:tgz
+USES= compiler:c++11-lang desktop-file-utils gl gmake qmake qt:5 tar:tgz
USE_GL= gl
USE_QT= concurrent core gui multimedia network opengl printsupport svg \
- widgets xml buildtools_build linguisttools_build
+ widgets xml buildtools_build linguisttools_build speech
PLIST_FILES= bin/chessx \
share/applications/chessx.desktop \
diff --git a/games/chessx/distinfo b/games/chessx/distinfo
index c90f3515b9d4..5728fd4105b1 100644
--- a/games/chessx/distinfo
+++ b/games/chessx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568648340
-SHA256 (chessx-1.5.0.tgz) = d130ad3220821da9ea19e7228222a5528fabca3ca06bc41b4d7f702454f63827
-SIZE (chessx-1.5.0.tgz) = 7251973
+TIMESTAMP = 1601899704
+SHA256 (chessx-1.5.4.tgz) = e2dbacff2a6c055cfbe4ce0344331f77262867e228a5fe2895e6c242772065a8
+SIZE (chessx-1.5.4.tgz) = 3663299
diff --git a/games/chessx/files/patch-chessx.pro b/games/chessx/files/patch-chessx.pro
index 8966d94c12a6..299d6fcc402e 100644
--- a/games/chessx/files/patch-chessx.pro
+++ b/games/chessx/files/patch-chessx.pro
@@ -1,7 +1,7 @@
---- chessx.pro.orig 2018-07-21 09:39:34 UTC
+--- chessx.pro.orig 2020-05-08 08:12:26 UTC
+++ chessx.pro
-@@ -445,6 +445,16 @@ macx {
- QMAKE_INFO_PLIST = mac_osx/Info.plist
+@@ -480,24 +480,31 @@ lc0 {
+ QMAKE_BUNDLE_DATA += LC0_ENGINE_LIB
}
+unix:!macx {
@@ -17,3 +17,33 @@
RESOURCES = \
resources.qrc
+-TRANSLATIONS = i18n/chessx_de.ts
+-
+-#\
+-# i18n/chessx_da.ts \
+-# i18n/chessx_fr.ts \
+-# i18n/chessx_it.ts \
+-# i18n/chessx_cz.ts \
+-# i18n/chessx_ru.ts \
+-# i18n/chessx_es.ts
+-
+-# i18n/chessx_nl.ts \
+-# i18n/chessx_pl.ts \
+-# i18n/chessx_pt_BR.ts \
+-# i18n/chessx_ro.ts \
+-# i18n/chessx_zh.ts
++TRANSLATIONS = i18n/chessx_de.ts \
++ i18n/chessx_da.ts \
++ i18n/chessx_fr.ts \
++ i18n/chessx_it.ts \
++ i18n/chessx_cz.ts \
++ i18n/chessx_ru.ts \
++ i18n/chessx_es.ts \
++ i18n/chessx_nl.ts \
++ i18n/chessx_pl.ts \
++ i18n/chessx_pt_BR.ts \
++ i18n/chessx_ro.ts \
++ i18n/chessx_zh.ts
+
+ isEmpty(QMAKE_LRELEASE) {
+ win32:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]\\lrelease.exe