aboutsummaryrefslogtreecommitdiff
path: root/games/chroma/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:38:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:38:48 +0000
commit38cae62a739f416036f6a7799d3afc477d98fae0 (patch)
tree39738b74f5b3b347f0797053d306be9d48c72eff /games/chroma/Makefile
parent86d74911c22965884d701fb412549eaba1cb0baf (diff)
downloadports-38cae62a739f416036f6a7799d3afc477d98fae0.tar.gz
ports-38cae62a739f416036f6a7799d3afc477d98fae0.zip
Notes
Diffstat (limited to 'games/chroma/Makefile')
-rw-r--r--games/chroma/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/games/chroma/Makefile b/games/chroma/Makefile
index d6f97eafb1c1..a46b08f99a94 100644
--- a/games/chroma/Makefile
+++ b/games/chroma/Makefile
@@ -19,35 +19,37 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= README
+PORTDATA= *
-OPTIONS_DEFINE= SDL CURSES DOCS
+OPTIONS_DEFINE= DOCS
+OPTIONS_MULTI= INTERFACES
+OPTIONS_MULTI_INTERFACES= SDL CURSES
OPTIONS_DEFAULT=SDL CURSES
+
SDL_DESC= Enable SDL interface
CURSES_DESC= Enable curses interface
-NO_STAGE= yes
+OPTIONS_SUB= yes
+CURSES_USES= ncurses
+CURSES_CONFIGURE_ENABLE=curses
+SDL_CONFIGURE_ENABLE= sdl
+SDL_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCURSES}
-PLIST_SUB+= CURSES=""
-.else
-CONFIGURE_ARGS+=--disable-curses
-PLIST_SUB+= CURSES="@comment "
+.if ${PORT_OPTIONS:MSDL}
+USE_SDL+= sdl image
+PLIST_FILES+= bin/${PORTNAME}
.endif
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= sdl image
-LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
-PLIST_SUB+= SDL=""
-.else
-CONFIGURE_ARGS+=--disable-sdl
-PLIST_SUB+= SDL="@comment "
+.if ${PORT_OPTIONS:MCURSES}
+PLIST_FILES+= bin/${PORTNAME}-curses
.endif
.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>