aboutsummaryrefslogtreecommitdiff
path: root/games/construo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-26 12:16:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-26 12:16:54 +0000
commit8a1e364ade603ba3756b01537c619d67e8c2a092 (patch)
treee7b923e92cb6e37c596ce7371fdcb334619519be /games/construo
parent6902b41a16a05fb95677ef8c66c230a246f9af57 (diff)
downloadports-8a1e364ade603ba3756b01537c619d67e8c2a092.tar.gz
ports-8a1e364ade603ba3756b01537c619d67e8c2a092.zip
- Update to 0.2.3
- Switch to new github home - Add LICENSE - Simplify
Notes
Notes: svn path=/head/; revision=382298
Diffstat (limited to 'games/construo')
-rw-r--r--games/construo/Makefile36
-rw-r--r--games/construo/distinfo4
-rw-r--r--games/construo/files/patch-config.hxx10
3 files changed, 22 insertions, 28 deletions
diff --git a/games/construo/Makefile b/games/construo/Makefile
index 683962af3852..8c3e9693a4bf 100644
--- a/games/construo/Makefile
+++ b/games/construo/Makefile
@@ -2,24 +2,32 @@
# $FreeBSD$
PORTNAME= construo
-PORTVERSION= 0.2.2
-PORTREVISION= 7
+PORTVERSION= 0.2.3
CATEGORIES= games
-MASTER_SITES= SAVANNAH/construo
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Fun construction toy
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= Construo
+GH_TAGNAME= v${PORTVERSION}
+
GNU_CONFIGURE= yes
-USES= gmake
+USES= autoreconf gmake
USE_XORG= sm ice x11 xext xxf86vm
USE_GL= gl glu
+CONFIGURE_ARGS= --bindir="${PREFIX}/bin" \
+ --datadir="${DATADIR}"
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --bindir=${PREFIX}/bin --datadir=${DATADIR}
+LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}.x11
+PLIST_FILES= bin/${PORTNAME} \
+ bin/${PORTNAME}.x11
PORTDATA= *
DESKTOP_ENTRIES="Construo" \
@@ -41,16 +49,12 @@ PLIST_FILES+= bin/${PORTNAME}.glut
.endif
post-patch:
- @${REINPLACE_CMD} \
- -e 's|bindir = .*|bindir = @bindir@|' \
- -e '/^construo_glut_LDADD =/s/$$/ -lGLU -lGL/' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} 's|pkgdatadir = .*|pkgdatadir = @datadir@/examples|' ${WRKSRC}/examples/Makefile.in
- @${REINPLACE_CMD} '/stream/!s/std:://' ${WRKSRC}/vector.cxx
- @${REINPLACE_CMD} 's|^\(#define CONSTRUO_DATADIR DATADIR\).*|\1|' ${WRKSRC}/construo.hxx
- @${REINPLACE_CMD} 's|.*glut_1_3_glutMainLoop = yes.*|if false; then|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/bindir=/ d' ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} '/(freeglut-1.3/ s|glutMainLoop|disabled_&|' \
+ ${WRKSRC}/configure.ac
.if ! ${PORT_OPTIONS:MGLUT}
- @${REINPLACE_CMD} 's|.*glut_glutMainLoop = yes.*|if false; then|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/(glut/ s|glutMainLoop|disabled_&|' \
+ ${WRKSRC}/configure.ac
.endif
post-install:
diff --git a/games/construo/distinfo b/games/construo/distinfo
index 88342a3ea0e0..7ee7ce07124d 100644
--- a/games/construo/distinfo
+++ b/games/construo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (construo-0.2.2.tar.gz) = 93b1dc5c26aab42d886f102e501189982c28d390f8b573f8f4a42bad640ec630
-SIZE (construo-0.2.2.tar.gz) = 442626
+SHA256 (Construo-construo-0.2.3-v0.2.3_GH0.tar.gz) = bd41c5564440af2fcbdf6e3e6f9c7caf67a8f4fbf36307c46d1fe75b1e83fb32
+SIZE (Construo-construo-0.2.3-v0.2.3_GH0.tar.gz) = 423154
diff --git a/games/construo/files/patch-config.hxx b/games/construo/files/patch-config.hxx
deleted file mode 100644
index 11a967190169..000000000000
--- a/games/construo/files/patch-config.hxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- config.hxx.orig 2003-01-11 18:37:26.000000000 +0300
-+++ config.hxx 2013-09-13 20:20:18.512226481 +0400
-@@ -21,6 +21,7 @@
- #define CONFIG_HH
-
- #include <string>
-+#include <cstdlib> // for getenv()
-
- class Config
- {