aboutsummaryrefslogtreecommitdiff
path: root/games/construo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-21 17:35:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-21 17:35:54 +0000
commita26966c6076269e6f6729c102db38804f7a6cb6c (patch)
treef82574dd50528769384e221fb7a6c46007d370e2 /games/construo
parente17b01c5ac3bdf1cee62f2513ae7d4824e1b9838 (diff)
downloadports-a26966c6076269e6f6729c102db38804f7a6cb6c.tar.gz
ports-a26966c6076269e6f6729c102db38804f7a6cb6c.zip
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=394989
Diffstat (limited to 'games/construo')
-rw-r--r--games/construo/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/games/construo/Makefile b/games/construo/Makefile
index a43d3da64056..a06df5eea3dd 100644
--- a/games/construo/Makefile
+++ b/games/construo/Makefile
@@ -16,11 +16,10 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= Construo
-GNU_CONFIGURE= yes
USES= autoreconf gmake
USE_XORG= sm ice x11 xext xxf86vm
USE_GL= gl glu
-
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/bin" \
--datadir="${DATADIR}"
CPPFLAGS+= -I${LOCALBASE}/include
@@ -31,7 +30,7 @@ PLIST_FILES= bin/${PORTNAME} \
PORTDATA= *
DESKTOP_ENTRIES="Construo" \
- "${COMMENT}" \
+ "" \
"" \
"${PORTNAME}" \
"Game;Simulation;" \
@@ -39,29 +38,24 @@ DESKTOP_ENTRIES="Construo" \
OPTIONS_DEFINE= GLUT
OPTIONS_DEFAULT=GLUT
-GLUT_DESC= Use glut
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGLUT}
-USE_GL+= glut
-PLIST_FILES+= bin/${PORTNAME}.glut
-.endif
+GLUT_DESC= Use glut
+GLUT_USE= GL=glut
+GLUT_PLIST_FILES= bin/${PORTNAME}.glut
post-patch:
@${REINPLACE_CMD} -e '/bindir=/ d' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} '/(freeglut-1.3/ s|glutMainLoop|disabled_&|' \
${WRKSRC}/configure.ac
-.if ! ${PORT_OPTIONS:MGLUT}
+
+post-patch-GLUT-off:
@${REINPLACE_CMD} '/(glut/ s|glutMainLoop|disabled_&|' \
${WRKSRC}/configure.ac
-.endif
-post-install:
-.if ${PORT_OPTIONS:MGLUT}
+post-install-GLUT-on:
cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PORTNAME}.glut ${PORTNAME}
-.else
+
+post-install-GLUT-off:
cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PORTNAME}.x11 ${PORTNAME}
-.endif
.include <bsd.port.mk>