aboutsummaryrefslogtreecommitdiff
path: root/games/corsix-th
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-09-18 21:48:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-09-18 21:48:57 +0000
commit933f450aeb9440767ff1169cf92408f86d2802eb (patch)
tree045b75fe959eec760fce4b58cc026c35631ca955 /games/corsix-th
parente2483bbe70f8ab6070a03f864b14ed4965d106dc (diff)
downloadports-933f450aeb9440767ff1169cf92408f86d2802eb.tar.gz
ports-933f450aeb9440767ff1169cf92408f86d2802eb.zip
- Update to 0.50
- Now depends on SDL2 - Remove LUAJIT option due to it causing crashes on startup - Disable newly added version check code, it causes errors and crashes - Allow any version of lua - Regenerate one patch file
Notes
Notes: svn path=/head/; revision=397299
Diffstat (limited to 'games/corsix-th')
-rw-r--r--games/corsix-th/Makefile18
-rw-r--r--games/corsix-th/distinfo4
-rw-r--r--games/corsix-th/files/patch-CMake_FindLua.cmake13
-rw-r--r--games/corsix-th/files/patch-CorsixTH-CMakeLists.txt46
-rw-r--r--games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp6
-rw-r--r--games/corsix-th/files/patch-CorsixTH_Lua_app.lua11
-rw-r--r--games/corsix-th/files/patch-CorsixTH_Lua_config__finder.lua11
-rw-r--r--games/corsix-th/pkg-plist1
8 files changed, 49 insertions, 61 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 5bf048624884..bb57a85d8351 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= corsixth
-PORTVERSION= 0.40
+PORTVERSION= 0.50
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -12,29 +12,27 @@ COMMENT= Open source clone of Theme Hospital
LICENSE= MIT
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:${PORTSDIR}/devel/luafilesystem \
+ ${LUA_MODLIBDIR}/lpeg.so:${PORTSDIR}/devel/lua-lpeg
-USES= cmake compiler:c++11-lang dos2unix pkgconfig
-USE_SDL= mixer
+USES= cmake compiler:c++11-lang dos2unix iconv lua pkgconfig
+USE_SDL= mixer2
DOS2UNIX_FILES= CMake/FindFFmpeg.cmake \
CorsixTH/CMakeLists.txt \
CorsixTH/Src/iso_fs.cpp
+CMAKE_ARGS= -DWITH_LUAJIT=OFF
USE_GITHUB= yes
GH_ACCOUNT= CorsixTH
GH_PROJECT= CorsixTH
-OPTIONS_DEFINE= LUAJIT MOVIES
-OPTIONS_DEFAULT= LUAJIT MOVIES
-LUAJIT_DESC= Use LUAJIT compiler
+OPTIONS_DEFINE= MOVIES
+OPTIONS_DEFAULT= MOVIES
MOVIES_DESC= Play in-game movies
MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
MOVIES_LIB_DEPENDS= libswresample.so:${PORTSDIR}/multimedia/ffmpeg
-LUAJIT_CMAKE_ON= -DWITH_LUAJIT=ON
-LUAJIT_CMAKE_OFF= -DWITH_LUAJIT=OFF
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
-LUAJIT_USES_OFF= lua:51
post-patch:
# Allow the game to find its resources without wrapper scripts
diff --git a/games/corsix-th/distinfo b/games/corsix-th/distinfo
index 90b879699442..2be2cff6a4b6 100644
--- a/games/corsix-th/distinfo
+++ b/games/corsix-th/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CorsixTH-CorsixTH-v0.40_GH0.tar.gz) = 0d6466b3bb63235b1e438087b59250a85d53488845399726b00d1804444b328c
-SIZE (CorsixTH-CorsixTH-v0.40_GH0.tar.gz) = 4425926
+SHA256 (CorsixTH-CorsixTH-v0.50_GH0.tar.gz) = 822cb5b4a4ec863ba410b6a37e456b360516b2362337532689070e4555c037ee
+SIZE (CorsixTH-CorsixTH-v0.50_GH0.tar.gz) = 4334892
diff --git a/games/corsix-th/files/patch-CMake_FindLua.cmake b/games/corsix-th/files/patch-CMake_FindLua.cmake
new file mode 100644
index 000000000000..d6866d08fbb5
--- /dev/null
+++ b/games/corsix-th/files/patch-CMake_FindLua.cmake
@@ -0,0 +1,13 @@
+--- CMake/FindLua.cmake.orig 2015-08-30 20:29:45 UTC
++++ CMake/FindLua.cmake
+@@ -26,8 +26,8 @@ IF (WITH_LUAJIT)
+ SET (LUA_INCLUDE_DIRS include/luajit-2.0 include)
+ ELSE (WITH_LUAJIT)
+ SET (LUA_INTERPRETER_TYPE "Lua")
+- SET (LUA_LIBRARY_NAME lua53 lua52 lua5.1 lua51 lua lua-5.1 liblua)
+- SET (LUA_INCLUDE_DIRS include include/lua include/lua5.1 include/lua51 include/lua-5.1)
++ SET (LUA_LIBRARY_NAME lua-5.1 lua-5.2 lua-5.3)
++ SET (LUA_INCLUDE_DIRS include include/lua include/lua51 include/lua52 include/lua53)
+ ENDIF(WITH_LUAJIT)
+
+ FIND_PATH (LUA_INCLUDE_DIR lua.h
diff --git a/games/corsix-th/files/patch-CorsixTH-CMakeLists.txt b/games/corsix-th/files/patch-CorsixTH-CMakeLists.txt
deleted file mode 100644
index ac4957410900..000000000000
--- a/games/corsix-th/files/patch-CorsixTH-CMakeLists.txt
+++ /dev/null
@@ -1,46 +0,0 @@
---- CorsixTH/CMakeLists.txt.orig 2013-03-24 19:01:59.745454897 +0100
-+++ CorsixTH/CMakeLists.txt 2013-03-24 19:03:14.618396915 +0100
-@@ -88,6 +88,21 @@
-
- # Finding libraries
-
-+# Find FFMPEG
-+IF(CORSIX_TH_USE_FFMPEG)
-+ FIND_PACKAGE(FFmpeg COMPONENTS AVFORMAT AVCODEC AVUTIL SWSCALE SWRESAMPLE REQUIRED)
-+ IF(FFMPEG_FOUND)
-+ TARGET_LINK_LIBRARIES(CorsixTH ${FFMPEG_LIBRARIES})
-+ INCLUDE_DIRECTORIES(${FFMPEG_INCLUDE_DIRS})
-+ IF(APPLE)
-+ TARGET_LINK_LIBRARIES(CorsixTH libz.dylib)
-+ ENDIF()
-+ message(" FFmpeg found")
-+ ELSE(FFMPEG_FOUND)
-+ message("Error: FFmpeg library not found, even though it was selected to be included")
-+ ENDIF(FFMPEG_FOUND)
-+ENDIF(CORSIX_TH_USE_FFMPEG)
-+
- # Find SDL
- FIND_PACKAGE(SDL REQUIRED)
- IF(SDL_FOUND)
-@@ -131,21 +146,6 @@
-
- message( STATUS "CMAKE_MODULE_PATH=${CMAKE_MODULE_PATH}" )
-
--# Find FFMPEG
--IF(CORSIX_TH_USE_FFMPEG)
-- FIND_PACKAGE(FFmpeg COMPONENTS AVFORMAT AVCODEC AVUTIL SWSCALE SWRESAMPLE REQUIRED)
-- IF(FFMPEG_FOUND)
-- TARGET_LINK_LIBRARIES(CorsixTH ${FFMPEG_LIBRARIES})
-- INCLUDE_DIRECTORIES(${FFMPEG_INCLUDE_DIRS})
-- IF(APPLE)
-- TARGET_LINK_LIBRARIES(CorsixTH libz.dylib)
-- ENDIF()
-- message(" FFmpeg found")
-- ELSE(FFMPEG_FOUND)
-- message("Error: FFmpeg library not found, even though it was selected to be included")
-- ENDIF(FFMPEG_FOUND)
--ENDIF(CORSIX_TH_USE_FFMPEG)
--
- # Find Freetype2
- IF(CORSIX_TH_USE_FREETYPE2)
- FIND_PACKAGE(Freetype REQUIRED)
diff --git a/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp b/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
index 486c33b6f042..b5ad16abc65c 100644
--- a/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
+++ b/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
@@ -1,6 +1,6 @@
---- CorsixTH/Src/iso_fs.cpp.orig 2013-09-17 17:59:28.434946572 +0200
-+++ CorsixTH/Src/iso_fs.cpp 2013-09-17 18:00:15.533944173 +0200
-@@ -30,6 +30,7 @@
+--- CorsixTH/Src/iso_fs.cpp.orig 2015-09-18 21:09:59 UTC
++++ CorsixTH/Src/iso_fs.cpp
+@@ -31,6 +31,7 @@ SOFTWARE.
#ifdef CORSIX_TH_HAS_ALLOCA_H
#include <alloca.h>
#endif
diff --git a/games/corsix-th/files/patch-CorsixTH_Lua_app.lua b/games/corsix-th/files/patch-CorsixTH_Lua_app.lua
new file mode 100644
index 000000000000..34fdc4cdf061
--- /dev/null
+++ b/games/corsix-th/files/patch-CorsixTH_Lua_app.lua
@@ -0,0 +1,11 @@
+--- CorsixTH/Lua/app.lua.orig 2015-08-30 20:29:45 UTC
++++ CorsixTH/Lua/app.lua
+@@ -63,7 +63,7 @@ function App:App()
+ }
+ self.strings = {}
+ self.savegame_version = SAVEGAME_VERSION
+- self.check_for_updates = true
++ self.check_for_updates = false
+ end
+
+ --! Starts a Lua DBGp client & connects it to a DBGp server.
diff --git a/games/corsix-th/files/patch-CorsixTH_Lua_config__finder.lua b/games/corsix-th/files/patch-CorsixTH_Lua_config__finder.lua
new file mode 100644
index 000000000000..cf23c3e6e976
--- /dev/null
+++ b/games/corsix-th/files/patch-CorsixTH_Lua_config__finder.lua
@@ -0,0 +1,11 @@
+--- CorsixTH/Lua/config_finder.lua.orig 2015-08-30 20:29:45 UTC
++++ CorsixTH/Lua/config_finder.lua
+@@ -133,7 +133,7 @@ local config_defaults = {
+ shift_scroll_speed = 4,
+ new_graphics_folder = nil,
+ use_new_graphics = false,
+- check_for_updates = true
++ check_for_updates = false
+ }
+ local fi = io.open(config_filename, "r")
+ local config_values = {}
diff --git a/games/corsix-th/pkg-plist b/games/corsix-th/pkg-plist
index 20b6217f4557..4331ef8818a6 100644
--- a/games/corsix-th/pkg-plist
+++ b/games/corsix-th/pkg-plist
@@ -336,6 +336,7 @@ bin/CorsixTH
%%DATADIR%%/Lua/rooms/ultrascan.lua
%%DATADIR%%/Lua/rooms/ward.lua
%%DATADIR%%/Lua/rooms/x_ray_room.lua
+%%DATADIR%%/Lua/run_debugger.lua
%%DATADIR%%/Lua/sprite_viewer.lua
%%DATADIR%%/Lua/staff_profile.lua
%%DATADIR%%/Lua/strict.lua