aboutsummaryrefslogtreecommitdiff
path: root/games/crack-attack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 15:02:27 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 18:01:11 +0000
commite5fe6519eefd256c4b9ff728277b5d7a1e257e79 (patch)
tree5160e66c4986ef94df2434dce723f0ab1281193e /games/crack-attack
parent5f574490e2628c2c6f9996f277f81d8675067f6f (diff)
downloadports-e5fe6519eefd256c4b9ff728277b5d7a1e257e79.tar.gz
ports-e5fe6519eefd256c4b9ff728277b5d7a1e257e79.zip
games/crack-attack: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'games/crack-attack')
-rw-r--r--games/crack-attack/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/crack-attack/Makefile b/games/crack-attack/Makefile
index 775ec5686b07..1dc936a3f796 100644
--- a/games/crack-attack/Makefile
+++ b/games/crack-attack/Makefile
@@ -8,12 +8,13 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OpenGL game based on Super Nintendo classic Tetris Attack
WWW= https://www.nongnu.org/crack-attack/
-USES= compiler:c++11-lang gl gnome pkgconfig xorg
-USE_XORG= x11 xi xmu sm ice
+USES= compiler:c++11-lang gl gnome localbase pkgconfig xorg
+USE_CXXSTD= c++14
USE_GL= glut
USE_GNOME= gtk20
+USE_XORG= x11 xi xmu sm ice
+
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= bin/${PORTNAME} \
man/man6/${PORTNAME}.6.gz \