aboutsummaryrefslogtreecommitdiff
path: root/games/craft
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-27 11:15:53 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-27 11:15:53 +0000
commit2bca10c8e73ca39e69e85dff1acfcc77cb146ebf (patch)
tree1c713b9ee265d6e1d3d4fe20357d25e91743a56c /games/craft
parentf680dcc72dece32710505ceabe750e01cb8906c7 (diff)
downloadports-2bca10c8e73ca39e69e85dff1acfcc77cb146ebf.tar.gz
ports-2bca10c8e73ca39e69e85dff1acfcc77cb146ebf.zip
- Remove SERVER option. It requires python 2 support
- Remove python 2 dependency
Notes
Notes: svn path=/head/; revision=533124
Diffstat (limited to 'games/craft')
-rw-r--r--games/craft/Makefile30
-rw-r--r--games/craft/pkg-plist3
2 files changed, 4 insertions, 29 deletions
diff --git a/games/craft/Makefile b/games/craft/Makefile
index 796276b9baed..c1a4f5a2e69a 100644
--- a/games/craft/Makefile
+++ b/games/craft/Makefile
@@ -5,43 +5,21 @@ PORTNAME= craft
PORTVERSION= 1.0
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= fbsd
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MAINTAINER= danilo@FreeBSD.org
COMMENT= Simple Minecraft clone written in C using modern OpenGL
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-08-15
-
LIB_DEPENDS= libcurl.so:ftp/curl
+USES= cmake:insource compiler:c11 gl xorg
+
USE_GITHUB= yes
GH_ACCOUNT= daniloegea
GH_PROJECT= Craft
-OPTIONS_DEFINE= SERVER
-SERVER_DESC= Install the craft server
-OPTIONS_DEFAULT= SERVER
-OPTIONS_SUB= yes
-
-USES= cmake:insource compiler:c11 gl xorg
-USE_XORG= x11 xi xrandr
+USE_XORG= x11 xi xrandr xxf86vm
USE_GL= gl glu
-SERVER_USES= python:2.7
-SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
-SERVER_CMAKE_ON= -DSERVER:BOOL=ON
-
-.include <bsd.port.options.mk>
-
-post-install:
-.if ${PORT_OPTIONS:MSERVER}
- @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/world.py ${STAGEDIR}${PYTHON_SITELIBDIR}/craft_world.py
- ${INSTALL_SCRIPT} ${WRKSRC}/server.py ${STAGEDIR}${PREFIX}/bin/craft-server
- ${INSTALL_LIB} ${WRKSRC}/libworld.so ${STAGEDIR}${PREFIX}/lib/libcraft-world.so
-.endif
-
.include <bsd.port.mk>
diff --git a/games/craft/pkg-plist b/games/craft/pkg-plist
index a5b6676ae2d0..be9ce5c29ac8 100644
--- a/games/craft/pkg-plist
+++ b/games/craft/pkg-plist
@@ -1,7 +1,4 @@
bin/craft
-%%SERVER%%bin/craft-server
-%%SERVER%%lib/libcraft-world.so
-%%SERVER%%%%PYTHON_SITELIBDIR%%/craft_world.py
%%DATADIR%%/shaders/block_fragment.glsl
%%DATADIR%%/shaders/block_vertex.glsl
%%DATADIR%%/shaders/line_fragment.glsl