aboutsummaryrefslogtreecommitdiff
path: root/games/cre/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:03:27 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:03:27 +0000
commit60df7f192397be3104d79569b1fc46d4562ffa8c (patch)
tree5738fc2f418df837a28bcfe1206339489beb36fa /games/cre/Makefile
parentb5c2829921c6b28721b5d6050dddb963a1af1162 (diff)
downloadports-60df7f192397be3104d79569b1fc46d4562ffa8c.tar.gz
ports-60df7f192397be3104d79569b1fc46d4562ffa8c.zip
Notes
Diffstat (limited to 'games/cre/Makefile')
-rw-r--r--games/cre/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/cre/Makefile b/games/cre/Makefile
new file mode 100644
index 000000000000..2e28bb70cd50
--- /dev/null
+++ b/games/cre/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: cre
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= cre
+DISTVERSION= 1.2beta_r2
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${DISTVERSION}_src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Corewars Redcode Evolver
+
+USE_DOS2UNIX= ../*.txt
+WRKSRC= ${WRKDIR}/src
+
+post-extract:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+
+post-patch:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e '/memwatch\.h/d' \
+ asm.c pspace.c sim.c
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e \
+ 's|random[[:blank:]]*(|myrandom(|' \
+ battler.c generator.c globals.h Main.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>