aboutsummaryrefslogtreecommitdiff
path: root/games/cryptoslam
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-04 20:01:22 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-04 20:01:22 +0000
commit3408227d5a2447af1626f365bf7f23849c9b1eb8 (patch)
treea6302f4d19abc00b42b5407e9b8269c6f0012a37 /games/cryptoslam
parentfddc3c3983fa4985c8f443d46e4c987770bc7d15 (diff)
downloadports-3408227d5a2447af1626f365bf7f23849c9b1eb8.tar.gz
ports-3408227d5a2447af1626f365bf7f23849c9b1eb8.zip
games/cryptoslam: USES+=ncurses, USES+=tar, respect LDFLAGS
Notes
Notes: svn path=/head/; revision=408089
Diffstat (limited to 'games/cryptoslam')
-rw-r--r--games/cryptoslam/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/cryptoslam/Makefile b/games/cryptoslam/Makefile
index 3270b94ee625..d89f8f205f16 100644
--- a/games/cryptoslam/Makefile
+++ b/games/cryptoslam/Makefile
@@ -5,16 +5,16 @@ PORTNAME= cryptoslam
PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses-based tool for creating and solving the cryptograms
+USES= ncurses tar:tgz
PLIST_FILES= bin/cryptoslam
do-build:
cd ${WRKSRC} && ${CXX} ${CXXFLAGS} cryptogram.cpp cryptoslam.cpp \
- -o ${PORTNAME} -lcurses
+ -o ${PORTNAME} ${LDFLAGS} -lncurses
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin