aboutsummaryrefslogtreecommitdiff
path: root/games/cuyo
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-03-17 08:56:05 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-03-17 08:56:05 +0000
commitcab3d73c53fecf712fc62d445ce5a3ce85048dcb (patch)
treed0b7757d51406bbca297a8a4a43dbd92b8a13e94 /games/cuyo
parentd1f6cc72413ec1d094f138a41fa4a9a008f42921 (diff)
downloadports-cab3d73c53fecf712fc62d445ce5a3ce85048dcb.tar.gz
ports-cab3d73c53fecf712fc62d445ce5a3ce85048dcb.zip
games/cuyo: update 2.0.0 -> 2.1.0
- Add NLS knobs for gettext handling PR: 197430 Submitted by: Kato Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=381473
Diffstat (limited to 'games/cuyo')
-rw-r--r--games/cuyo/Makefile46
-rw-r--r--games/cuyo/distinfo4
-rw-r--r--games/cuyo/files/patch-configure17
-rw-r--r--games/cuyo/files/patch-po__Makefile.in20
-rw-r--r--games/cuyo/files/patch-src__cuyointl.cpp11
-rw-r--r--games/cuyo/pkg-plist123
6 files changed, 178 insertions, 43 deletions
diff --git a/games/cuyo/Makefile b/games/cuyo/Makefile
index 08aa6ae84f77..588a62389c8b 100644
--- a/games/cuyo/Makefile
+++ b/games/cuyo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cuyo
-PORTVERSION= 2.0.0
-PORTREVISION= 4
+PORTVERSION= 2.1.0
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SAVANNAH
@@ -11,44 +10,31 @@ MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice, innovative, challenging Tetris-like game
-LICENSE= GPLv2 # or later
+LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libaa.so:${PORTSDIR}/graphics/aalib \
- libmikmod.so:${PORTSDIR}/audio/libmikmod
-
-USES= iconv
-GNU_CONFIGURE= yes
+USES= gmake iconv
USE_SDL= mixer image
-USE_XORG= xdmcp xau x11
+USE_XORG= x11 xau xdmcp
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-PORTDOCS= AUTHORS NEWS
-
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
-
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext-runtime:run
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
# Do not use older versions
-PORTSCOUT= skipv:2.~-1.2~beta1
-
-.include <bsd.port.options.mk>
+PORTSCOUT= limit:[0-9]\.[0-9]\.
-post-install:
-.if ${PORT_OPTIONS:MNLS}
-. for f in de
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES ; \
- ${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo \
- ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
-. endfor
-.endif
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
- ${LN} -sf ${PREFIX}/share/icons/hicolor/64x64/apps/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+NLS_CONFIGURE_ENABLE= nls
+NLS_BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
+NLS_USES= gettext
+NLS_LDFLAGS= -lintl
+post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} NEWS README ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/games/cuyo/distinfo b/games/cuyo/distinfo
index a92a9673759e..419ea989fa5a 100644
--- a/games/cuyo/distinfo
+++ b/games/cuyo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cuyo-2.0.0.tar.gz) = 531cfb989087199f643ac4b18ff9cc50793cc3fa07ee06f394f73d153c09ae34
-SIZE (cuyo-2.0.0.tar.gz) = 3821330
+SHA256 (cuyo-2.1.0.tar.gz) = 6c0809a59a2d236f15d8fbd68d61fb1465e51f6c327d7f7ae4db9f4e44dad89f
+SIZE (cuyo-2.1.0.tar.gz) = 4251290
diff --git a/games/cuyo/files/patch-configure b/games/cuyo/files/patch-configure
new file mode 100644
index 000000000000..8765ef681096
--- /dev/null
+++ b/games/cuyo/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig
++++ configure
+@@ -3470,13 +3470,11 @@
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <libintl.h>
+-extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ int
+ main ()
+ {
+ bindtextdomain ("", "");
+-return * gettext ("") + _nl_msg_cat_cntr + *_nl_domain_bindings
++return * gettext ("");
+ ;
+ return 0;
+ }
diff --git a/games/cuyo/files/patch-po__Makefile.in b/games/cuyo/files/patch-po__Makefile.in
new file mode 100644
index 000000000000..77b87bf53c4c
--- /dev/null
+++ b/games/cuyo/files/patch-po__Makefile.in
@@ -0,0 +1,20 @@
+--- po/Makefile.in.orig
++++ po/Makefile.in
+@@ -410,7 +410,7 @@
+ $(DOMAIN).pot: $(pot_sources) pot.sed
+ rm -rf data
+ mkdir data
+- cd ../data && make used_levels
++ cd ../data && $(MAKE) used_levels
+ for ldfile in $$(cat ../data/used_levels) ; do \
+ ./cual2fakec ../data/$$ldfile > data/$$ldfile ; \
+ done
+@@ -426,7 +426,7 @@
+ --msgid-bugs-address=cuyo-devel@nongnu.org \
+ -o - \
+ src/* data/* \
+- | sed -f pot.sed > cuyo.pot
++ | gsed -f pot.sed > cuyo.pot
+
+ %.mo: %.po
+ $(MSGFMT) -c -o t-$*.mo $*.po && mv t-$*.mo $*.mo
diff --git a/games/cuyo/files/patch-src__cuyointl.cpp b/games/cuyo/files/patch-src__cuyointl.cpp
new file mode 100644
index 000000000000..9302f90edc19
--- /dev/null
+++ b/games/cuyo/files/patch-src__cuyointl.cpp
@@ -0,0 +1,11 @@
+--- src/cuyointl.cpp.orig
++++ src/cuyointl.cpp
+@@ -93,7 +93,7 @@
+ return convert_error(ret,s,"Character conversion not possible.");
+
+ while (*inpos) {
+- size_t res = iconv(handle,&inpos,&inleft,&outpos,&outleft);
++ size_t res = iconv(handle,(const char **)&inpos,&inleft,&outpos,&outleft);
+ if (res == (size_t) -1)
+ /* An error occured */
+ switch (errno) {
diff --git a/games/cuyo/pkg-plist b/games/cuyo/pkg-plist
index a65094578c25..80d97693d92a 100644
--- a/games/cuyo/pkg-plist
+++ b/games/cuyo/pkg-plist
@@ -2,8 +2,66 @@ bin/cuyo
man/man6/cual.6.gz
man/man6/cuyo.6.gz
share/applications/cuyo.desktop
+%%DATADIR%%/3d.ld
+%%DATADIR%%/aehnlich.ld
+%%DATADIR%%/aliens.ld
+%%DATADIR%%/angst.ld
+%%DATADIR%%/antarctic.ld
+%%DATADIR%%/ascii.ld
+%%DATADIR%%/augen.ld
+%%DATADIR%%/baelle.ld
+%%DATADIR%%/baender.ld
+%%DATADIR%%/baggis.ld
+%%DATADIR%%/bonimali.ld
+%%DATADIR%%/bonus.ld
+%%DATADIR%%/bunt.ld
+%%DATADIR%%/colorshape.ld
+%%DATADIR%%/darken.ld
+%%DATADIR%%/disco.ld
+%%DATADIR%%/doors.ld
+%%DATADIR%%/dungeon.ld
+%%DATADIR%%/ebene.ld
+%%DATADIR%%/elemente.ld
+%%DATADIR%%/embroidery.ld
%%DATADIR%%/example.ld
+%%DATADIR%%/explosive.ld
+%%DATADIR%%/farming.ld
+%%DATADIR%%/fische.ld
+%%DATADIR%%/flechtwerk.ld
+%%DATADIR%%/fractals.ld
%%DATADIR%%/globals.ld
+%%DATADIR%%/go2.ld
+%%DATADIR%%/gold.ld
+%%DATADIR%%/hecken.ld
+%%DATADIR%%/hexkugeln.ld
+%%DATADIR%%/himmel.ld
+%%DATADIR%%/hormone.ld
+%%DATADIR%%/jahreszeiten.ld
+%%DATADIR%%/jump.ld
+%%DATADIR%%/kacheln4.ld
+%%DATADIR%%/kacheln5.ld
+%%DATADIR%%/kacheln6.ld
+%%DATADIR%%/kachelnR.ld
+%%DATADIR%%/kolben.ld
+%%DATADIR%%/kunst.ld
+%%DATADIR%%/labskaus.ld
+%%DATADIR%%/letters.ld
+%%DATADIR%%/maennchen.ld
+%%DATADIR%%/maze.ld
+%%DATADIR%%/memory.ld
+%%DATADIR%%/mfs.ld
+%%DATADIR%%/nasenkugeln.ld
+%%DATADIR%%/novips.ld
+%%DATADIR%%/octopi.ld
+%%DATADIR%%/pacman.ld
+%%DATADIR%%/paratroopers.ld
+%%DATADIR%%/pfeile.ld
+%%DATADIR%%/pics/aBoxFractal.xpm.gz
+%%DATADIR%%/pics/aCantorSet.xpm.gz
+%%DATADIR%%/pics/aDragon.xpm.gz
+%%DATADIR%%/pics/aMandelbrotTree.xpm.gz
+%%DATADIR%%/pics/aRepTile.xpm.gz
+%%DATADIR%%/pics/aSierpSieve.xpm.gz
%%DATADIR%%/pics/baAliens.xpm.gz
%%DATADIR%%/pics/baAnzeige.xpm.gz
%%DATADIR%%/pics/baBlue.xpm.gz
@@ -170,21 +228,17 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/explosion.xpm.gz
%%DATADIR%%/pics/font-big.xpm.gz
%%DATADIR%%/pics/highlight.xpm.gz
-%%DATADIR%%/pics/i3Boden.xpm.gz
%%DATADIR%%/pics/i3Dreieck.xpm.gz
-%%DATADIR%%/pics/i3Feder.xpm.gz
%%DATADIR%%/pics/i3Gitter.xpm.gz
+%%DATADIR%%/pics/i3Grau.xpm.gz
%%DATADIR%%/pics/i3Kreis.xpm.gz
-%%DATADIR%%/pics/i3Kugel.xpm.gz
-%%DATADIR%%/pics/i3Nix.xpm.gz
+%%DATADIR%%/pics/i3Plus.xpm.gz
%%DATADIR%%/pics/i3Quadrat.xpm.gz
-%%DATADIR%%/pics/i3Sirpinski.xpm.gz
-%%DATADIR%%/pics/i3SirpinskiB.xpm.gz
-%%DATADIR%%/pics/i3Stange.xpm.gz
%%DATADIR%%/pics/i3Stern.xpm.gz
%%DATADIR%%/pics/i6Blau.xpm.gz
%%DATADIR%%/pics/i6Gelb.xpm.gz
%%DATADIR%%/pics/i6Grau.xpm.gz
+%%DATADIR%%/pics/i6Gross.xpm.gz
%%DATADIR%%/pics/i6Gross1.xpm.gz
%%DATADIR%%/pics/i6Gross2.xpm.gz
%%DATADIR%%/pics/i6Gross3.xpm.gz
@@ -305,8 +359,8 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/itGras.xpm.gz
%%DATADIR%%/pics/itGrau.xpm.gz
%%DATADIR%%/pics/itGruen.xpm.gz
-%%DATADIR%%/pics/itHintergrund.xpm.gz
%%DATADIR%%/pics/itLeer.xpm.gz
+%%DATADIR%%/pics/itTop.xpm.gz
%%DATADIR%%/pics/ithBlau.xpm.gz
%%DATADIR%%/pics/ithBlauBlah.xpm.gz
%%DATADIR%%/pics/ithBlauH.xpm.gz
@@ -485,7 +539,6 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/maLidB.xpm.gz
%%DATADIR%%/pics/maLidC.xpm.gz
%%DATADIR%%/pics/maLidD.xpm.gz
-%%DATADIR%%/pics/maUnten.xpm
%%DATADIR%%/pics/maeSchema.xpm.gz
%%DATADIR%%/pics/maeSorten.xpm.gz
%%DATADIR%%/pics/manGesichter1.xpm.gz
@@ -644,6 +697,7 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/mdFels09.xpm.gz
%%DATADIR%%/pics/mdFels10.xpm.gz
%%DATADIR%%/pics/mdFels11.xpm.gz
+%%DATADIR%%/pics/mdFog.xpm
%%DATADIR%%/pics/mdGold.xpm.gz
%%DATADIR%%/pics/mdGold00.xpm.gz
%%DATADIR%%/pics/mdGold01.xpm.gz
@@ -715,6 +769,15 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/mdZiegel10.xpm.gz
%%DATADIR%%/pics/mdZiegel11.xpm.gz
%%DATADIR%%/pics/menupics.xpm.gz
+%%DATADIR%%/pics/mfaBack.xpm
+%%DATADIR%%/pics/mfaCabbage.xpm
+%%DATADIR%%/pics/mfaCattle.xpm
+%%DATADIR%%/pics/mfaFence.xpm
+%%DATADIR%%/pics/mfaMaize.xpm
+%%DATADIR%%/pics/mfaPigs.xpm
+%%DATADIR%%/pics/mfaRoad.xpm
+%%DATADIR%%/pics/mfaWater.xpm
+%%DATADIR%%/pics/mfaWheat.xpm
%%DATADIR%%/pics/mffisch1.xpm.gz
%%DATADIR%%/pics/mffisch2.xpm.gz
%%DATADIR%%/pics/mffisch3.xpm.gz
@@ -753,9 +816,11 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/mkaFuenfeckHetz.xpm.gz
%%DATADIR%%/pics/mkaFuenfeckKacheln.xpm.gz
%%DATADIR%%/pics/mkaFuenfeckRahmen.xpm.gz
+%%DATADIR%%/pics/mkaFuenfeckVerbind.xpm
%%DATADIR%%/pics/mkaRhombusFall.xpm.gz
%%DATADIR%%/pics/mkaRhombusKacheln.xpm.gz
%%DATADIR%%/pics/mkaRhombusLeer.xpm.gz
+%%DATADIR%%/pics/mkaRhombusVerbind.xpm
%%DATADIR%%/pics/mkaSechseckKacheln.xpm.gz
%%DATADIR%%/pics/mkaSechseckRahmen.xpm.gz
%%DATADIR%%/pics/mkaViereckFall.xpm.gz
@@ -803,13 +868,21 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/msRed4.xpm.gz
%%DATADIR%%/pics/msRed5.xpm.gz
%%DATADIR%%/pics/msc1A.xpm
+%%DATADIR%%/pics/msc1AInfo.xpm
%%DATADIR%%/pics/msc1B.xpm
+%%DATADIR%%/pics/msc1BInfo.xpm
%%DATADIR%%/pics/msc1C.xpm
+%%DATADIR%%/pics/msc1CInfo.xpm
%%DATADIR%%/pics/msc2.xpm
+%%DATADIR%%/pics/msc2Info.xpm
%%DATADIR%%/pics/msc3.xpm
+%%DATADIR%%/pics/msc3Info.xpm
%%DATADIR%%/pics/msc4.xpm
+%%DATADIR%%/pics/msc4Info.xpm
%%DATADIR%%/pics/msc5.xpm
+%%DATADIR%%/pics/msc5Info.xpm
%%DATADIR%%/pics/mscGrasGrau.xpm
+%%DATADIR%%/pics/mscGrasGrauInfo.xpm
%%DATADIR%%/pics/mscHetz.xpm
%%DATADIR%%/pics/mscHinter.xpm.gz
%%DATADIR%%/pics/mscLeer.xpm.gz
@@ -875,7 +948,6 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/sbOfen.xpm.gz
%%DATADIR%%/pics/sbSunglas.xpm.gz
%%DATADIR%%/pics/scroll.xpm.gz
-%%DATADIR%%/pics/semiglobal
%%DATADIR%%/pics/spBlinky.xpm.gz
%%DATADIR%%/pics/spClyde.xpm.gz
%%DATADIR%%/pics/spEyes.xpm.gz
@@ -896,6 +968,17 @@ share/applications/cuyo.desktop
%%DATADIR%%/pics/spPfeil.xpm.gz
%%DATADIR%%/pics/spPinky.xpm.gz
%%DATADIR%%/pics/titel.xpm.gz
+%%DATADIR%%/pressure.ld
+%%DATADIR%%/puzzle.ld
+%%DATADIR%%/rechnen.ld
+%%DATADIR%%/reversi_brl.ld
+%%DATADIR%%/rohre.ld
+%%DATADIR%%/rollenspiel.ld
+%%DATADIR%%/schach.ld
+%%DATADIR%%/schemen.ld
+%%DATADIR%%/secret.ld
+%%DATADIR%%/silbergold.ld
+%%DATADIR%%/slime.ld
%%DATADIR%%/sounds/cuyo.it
%%DATADIR%%/sounds/down.wav
%%DATADIR%%/sounds/explode.wav
@@ -908,8 +991,26 @@ share/applications/cuyo.desktop
%%DATADIR%%/sounds/slime1.wav
%%DATADIR%%/sounds/slime2.wav
%%DATADIR%%/sounds/turn.wav
+%%DATADIR%%/springer.ld
%%DATADIR%%/summary.ld
+%%DATADIR%%/tennis.ld
+%%DATADIR%%/tetris.ld
+%%DATADIR%%/theater.ld
+%%DATADIR%%/tiere.ld
+%%DATADIR%%/trees.ld
+%%DATADIR%%/unmoeglich.ld
+%%DATADIR%%/unterwasser.ld
+%%DATADIR%%/viecher.ld
+%%DATADIR%%/wachsen.ld
+%%DATADIR%%/walls.ld
+%%DATADIR%%/wohnungen.ld
+%%DATADIR%%/wuerfel.ld
+%%DATADIR%%/xtradick.ld
+%%DATADIR%%/zahn.ld
+%%DATADIR%%/ziehlen.ld
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
share/icons/hicolor/32x32/apps/cuyo.png
share/icons/hicolor/64x64/apps/cuyo.png
%%NLS%%share/locale/de/LC_MESSAGES/cuyo.mo
-share/pixmaps/cuyo.png
+%%NLS%%share/locale/pt/LC_MESSAGES/cuyo.mo