aboutsummaryrefslogtreecommitdiff
path: root/games/darkplaces/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-25 16:46:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-25 16:46:11 +0000
commit8bf7974e1b566cc72ce735dfbc6e879289490a90 (patch)
tree6d587bfcb63d11ee5a34481dd5872f4ee26f8fd9 /games/darkplaces/Makefile
parent136d5cf3eceed51f93a37a691bc69ba43c22cc85 (diff)
downloadports-8bf7974e1b566cc72ce735dfbc6e879289490a90.tar.gz
ports-8bf7974e1b566cc72ce735dfbc6e879289490a90.zip
Notes
Diffstat (limited to 'games/darkplaces/Makefile')
-rw-r--r--games/darkplaces/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 0d8f91e78f4f..c58dfa6e2e32 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= darkplaces
-PORTVERSION= 20071120
-PORTREVISION= 5
+PORTVERSION= 20110628
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org:9090/twilight/darkplaces/files/
DISTNAME= ${PORTNAME}engine${PORTVERSION}
@@ -35,7 +34,7 @@ PORTDOCS= darkplaces.txt
.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITH_CLIENT) && !defined(WITH_DEDICATED) && !defined(WITH_SDL)
IGNORE= needs at least one of CLIENT, DEDICATED and SDL options
@@ -53,6 +52,8 @@ ALL_TARGET+= cl-release
EXE_TARGETS+= ${PORTNAME}-glx
PLIST_SUB+= CLIENT=""
PLIST_FILES+= bin/${PORTNAME}-glx
+DESKTOP_ENTRIES+="Darkplaces GLX Client" "" "" "darkplaces-glx" \
+ "Game;ActionGame;" "false"
.endif
.if defined(WITH_DEDICATED)
@@ -66,6 +67,8 @@ USE_SDL= sdl
ALL_TARGET+= sdl-release
EXE_TARGETS+= ${PORTNAME}-sdl
PLIST_FILES+= bin/${PORTNAME}-sdl
+DESKTOP_ENTRIES+="Darkplaces SDL Client" "" "" "darkplaces-sdl" \
+ "Game;ActionGame;" "false"
.endif
post-extract:
@@ -84,4 +87,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/darkplaces.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>