aboutsummaryrefslogtreecommitdiff
path: root/games/darkplaces
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-06-03 15:54:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-06-03 15:54:29 +0000
commit4bb8eb15eb90266fbda844e96752560e10f91f4f (patch)
treece2c52370d982c7455fe25700e51066fe4bdb94b /games/darkplaces
parent6c7bf2d5e2150f58993b4b8178f06d6ef892b5be (diff)
downloadports-4bb8eb15eb90266fbda844e96752560e10f91f4f.tar.gz
ports-4bb8eb15eb90266fbda844e96752560e10f91f4f.zip
- Convert unzip -a to USE_DOS2UNIX
PR: ports/146533 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua>
Notes
Notes: svn path=/head/; revision=255662
Diffstat (limited to 'games/darkplaces')
-rw-r--r--games/darkplaces/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 57a591e0727c..6d7929a6d82a 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -18,6 +18,7 @@ COMMENT= Quake engine modification
USE_ZIP= yes
USE_GMAKE= yes
USE_XORG= xxf86dga xpm
+USE_DOS2UNIX= darkplaces.txt
MAKE_ENV= DP_FS_BASEDIR="${Q1DIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -68,8 +69,8 @@ PLIST_FILES+= bin/${PORTNAME}-sdl
.endif
post-extract:
- @${UNZIP_CMD} -aq \
- -o ${WRKDIR}/${PORTNAME}enginesource${PORTVERSION}.zip \
+ @${UNZIP_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${WRKDIR}/${PORTNAME}enginesource${PORTVERSION}.zip \
-d ${WRKDIR}
do-install:
@@ -80,7 +81,7 @@ do-install:
@${TOUCH} ${DATADIR}/dummy
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/darkplaces.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/darkplaces.txt ${DOCSDIR}
.endif
.include <bsd.port.post.mk>