aboutsummaryrefslogtreecommitdiff
path: root/games/darkplaces
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:55:33 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:55:33 +0000
commitd56f55808fc2c93fd233533b1ce1eb64fb1cc95e (patch)
treeb73bf8f6d7ca45b3a06567005ce9e9f5f9d9ad2a /games/darkplaces
parentd6ebd6c6f8b30f4465b2a5e699261668d63f9000 (diff)
downloadports-d56f55808fc2c93fd233533b1ce1eb64fb1cc95e.tar.gz
ports-d56f55808fc2c93fd233533b1ce1eb64fb1cc95e.zip
- Update to version 20070711.
Notes
Notes: svn path=/head/; revision=198875
Diffstat (limited to 'games/darkplaces')
-rw-r--r--games/darkplaces/Makefile14
-rw-r--r--games/darkplaces/distinfo6
-rw-r--r--games/darkplaces/files/patch-makefile.inc36
3 files changed, 17 insertions, 39 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 188a9a72a678..9d099f779d6e 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= darkplaces
-PORTVERSION= 20060725
-PORTREVISION= 3
+PORTVERSION= 20070711
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org/twilight/darkplaces/files/
DISTNAME= ${PORTNAME}engine${PORTVERSION}
@@ -17,6 +16,7 @@ COMMENT= Quake engine modification
USE_ZIP= yes
USE_GMAKE= yes
+MAKE_ENV= DP_FS_BASEDIR="${Q1DIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
@@ -24,11 +24,11 @@ ALL_TARGET= #
OPTIONS= CLIENT "Build GLX client" on \
DEDICATED "Build dedicated server" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
SDL "Build SDL client" on
PLIST_FILES= %%DATADIR%%/dummy
PLIST_DIRS= %%DATADIR%%
+PORTDOCS= darkplaces.txt
.include "${.CURDIR}/../quake-data/Makefile.include"
@@ -58,10 +58,6 @@ EXE_TARGETS+= ${PORTNAME}-dedicated
PLIST_FILES+= bin/${PORTNAME}-dedicated
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
-MAKE_ENV+= WITH_OPTIMIZED_CFLAGS=YES
-.endif
-
.if defined(WITH_SDL)
USE_SDL= sdl
ALL_TARGET+= sdl-release
@@ -80,5 +76,9 @@ do-install:
.endfor
@${MKDIR} ${DATADIR}
@${TOUCH} ${DATADIR}/dummy
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/darkplaces.txt ${DOCSDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/games/darkplaces/distinfo b/games/darkplaces/distinfo
index 659560f19afb..f17653f45dbf 100644
--- a/games/darkplaces/distinfo
+++ b/games/darkplaces/distinfo
@@ -1,3 +1,3 @@
-MD5 (darkplacesengine20060725.zip) = 7bfda4eb0f252a0084b669938b8a7d1a
-SHA256 (darkplacesengine20060725.zip) = a892ac480b8c006f55390dddd7ef07a42b18c29ffff93f0d39b7e2038cb411b4
-SIZE (darkplacesengine20060725.zip) = 7307282
+MD5 (darkplacesengine20070711.zip) = f4144d3dfa1fa085b1d676d4e7d7fb5a
+SHA256 (darkplacesengine20070711.zip) = 00f43ef88916abb7711ce4ded48b99d7db0a38c41f5b1bd74d9f8e4c44d65327
+SIZE (darkplacesengine20070711.zip) = 9951037
diff --git a/games/darkplaces/files/patch-makefile.inc b/games/darkplaces/files/patch-makefile.inc
index 88b4891ace46..701bedd4015c 100644
--- a/games/darkplaces/files/patch-makefile.inc
+++ b/games/darkplaces/files/patch-makefile.inc
@@ -1,5 +1,5 @@
---- ./makefile.inc.orig Tue Jul 4 17:01:40 2006
-+++ ./makefile.inc Mon Aug 21 18:10:16 2006
+--- ./makefile.inc.orig Sun May 20 13:02:27 2007
++++ ./makefile.inc Wed Sep 5 17:27:31 2007
@@ -1,5 +1,5 @@
# Choose the compiler you want to use
-CC=gcc
@@ -7,38 +7,16 @@
# athlon optimizations
#CPUOPTIMIZATIONS=-march=athlon
-@@ -138,14 +138,19 @@
-
-
- # Compilation
--CFLAGS_COMMON=$(CFLAGS_MAKEDEP) $(CFLAGS_FS) -Wall -Wsign-compare
-+CFLAGS_COMMON=$(CFLAGS_MAKEDEP) $(CFLAGS_FS) -Wall -Wsign-compare -DDP_FS_BASEDIR='\"$(Q1DIR)\"'
- CFLAGS_DEBUG=-ggdb
- CFLAGS_PROFILE=-g -pg -ggdb
- CFLAGS_RELEASE=
- CFLAGS_SDL=`$(SDL_CONFIG) --cflags`
-
-+ifeq ($(WITH_OPTIMIZED_CFLAGS),YES)
- OPTIM_DEBUG=$(CPUOPTIMIZATIONS)
--OPTIM_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops $(CPUOPTIMIZATIONS)
-+OPTIM_RELEASE=-O2 -fno-strict-aliasing -funroll-loops $(CPUOPTIMIZATIONS)
-+ ifneq ($(ARCH),alpha)
-+OPTIM_RELEASE+=-ffast-math
-+ endif
-+endif
-
- DO_CC=$(CC) $(CFLAGS) -c $< -o $@
-
-@@ -161,7 +166,7 @@
+@@ -164,7 +164,7 @@
OBJ_GLX= builddate.c sys_linux.o vid_glx.o $(OBJ_SOUND) $(OBJ_CD) $(OBJ_COMMON)
LDFLAGS_UNIXCOMMON=-lm
-LDFLAGS_UNIXCL=-L$(UNIX_X11LIBPATH) -lX11 -lXext -lXxf86dga -lXxf86vm $(LIB_SOUND)
+LDFLAGS_UNIXCL=-L$(X11BASE)/lib -lX11 -lXext -lXxf86dga -lXxf86vm $(LIB_SOUND)
-
- LDFLAGS_UNIXSDL=`$(SDL_CONFIG) --libs`
- EXE_UNIXCL=darkplaces-glx
-@@ -359,28 +364,28 @@
+ LDFLAGS_UNIXCL_PRELOAD=-lz -ljpeg -lpng -lvorbis -lvorbisfile -lcurl
+ LDFLAGS_UNIXSV_PRELOAD=-lz -lcurl
+ LDFLAGS_UNIXSDL_PRELOAD=-lz -ljpeg -lpng -lvorbis -lvorbisfile -lcurl
+@@ -366,28 +366,28 @@
@echo "========== $(EXE) (debug) =========="
$(MAKE) $(EXE) \
DP_MAKE_TARGET=$(DP_MAKE_TARGET) DP_SOUND_API=$(DP_SOUND_API) \