aboutsummaryrefslogtreecommitdiff
path: root/games/digger-vgl
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-05-22 15:00:13 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-05-22 15:00:13 +0000
commit6abf94abba6211c0cfeb85902611935b817445f6 (patch)
treecb5304b0b1df872bbdf1b5fd6bb1d7668491d4f7 /games/digger-vgl
parent09b6e1b4b7ac16d93d322727510f06a1426392c7 (diff)
downloadports-6abf94abba6211c0cfeb85902611935b817445f6.tar.gz
ports-6abf94abba6211c0cfeb85902611935b817445f6.zip
New port of Digger - a VGL version of the famous Digger game. AFAIK it is the
fist full-blown game with VGL support ;). Very suitable it you have nothing to do while your computer assembling bits of 'make buildworld' (the game uses only about 5% CPU on my P133 laptop). PR: 18112 Submitted by: me
Notes
Notes: svn path=/head/; revision=28679
Diffstat (limited to 'games/digger-vgl')
-rw-r--r--games/digger-vgl/Makefile47
-rw-r--r--games/digger-vgl/distinfo1
-rw-r--r--games/digger-vgl/files/patch-aa11
-rw-r--r--games/digger-vgl/pkg-comment1
-rw-r--r--games/digger-vgl/pkg-descr16
-rw-r--r--games/digger-vgl/pkg-plist3
6 files changed, 79 insertions, 0 deletions
diff --git a/games/digger-vgl/Makefile b/games/digger-vgl/Makefile
new file mode 100644
index 000000000000..7e21d879490c
--- /dev/null
+++ b/games/digger-vgl/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Digger
+# Date created: 14 April 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= digger
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.digger.org/
+DISTNAME= ${PORTNAME}-${DIGREL}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+.if defined(WITH_SOUND)
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl
+MAKE_FLAGS+= -DSOUND
+.endif
+
+DIGREL= 20000407
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DIGREL}
+MAKEFILE= Makefile.fbsd
+
+.if !defined(WITH_SOUND)
+post-extract:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Please use \"make -DWITH_SOUND\" if you want to build the game with sound support."
+ @${ECHO_MSG}
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/digger ${PREFIX}/bin
+ @${MKDIR} /var/games/digger
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/digger
+ @${INSTALL_MAN} ${WRKSRC}/digger.txt ${PREFIX}/share/doc/digger
+.endif
+
+.if defined(WITH_SOUND)
+post-install:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Use \"digger /A\" command to run Digger with sound enabled."
+ @${ECHO_MSG}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/digger-vgl/distinfo b/games/digger-vgl/distinfo
new file mode 100644
index 000000000000..0959ef44aa04
--- /dev/null
+++ b/games/digger-vgl/distinfo
@@ -0,0 +1 @@
+MD5 (digger-20000407.tar.gz) = 6b91314193ebdefcc22337b46458e950
diff --git a/games/digger-vgl/files/patch-aa b/games/digger-vgl/files/patch-aa
new file mode 100644
index 000000000000..0d829ea48f01
--- /dev/null
+++ b/games/digger-vgl/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.fbsd.orig Fri Apr 14 10:29:24 2000
++++ Makefile.fbsd Fri Apr 14 10:29:57 2000
+@@ -4,7 +4,7 @@
+ newsnd.c ini.c input.c monster.c bags.c alpha.c vgagrafx.c \
+ title_gz.c
+
+-CFLAGS= -g -O -Wall -pedantic -DFREEBSD
++CFLAGS+= -DFREEBSD
+
+ LDADD+= -lz
+
diff --git a/games/digger-vgl/pkg-comment b/games/digger-vgl/pkg-comment
new file mode 100644
index 000000000000..bafe6d3813bc
--- /dev/null
+++ b/games/digger-vgl/pkg-comment
@@ -0,0 +1 @@
+FreeBSD graphics console (VGL) version of the famous Digger game
diff --git a/games/digger-vgl/pkg-descr b/games/digger-vgl/pkg-descr
new file mode 100644
index 000000000000..dd73ae5a61b2
--- /dev/null
+++ b/games/digger-vgl/pkg-descr
@@ -0,0 +1,16 @@
+FreeBSD graphics console (VGL) version of the famous Digger game.
+
+HISTORY
+-------
+Digger was originally created by Windmill software in 1983 and released as
+a copy-protected, bootable 5.25" floppy disk for the IBM PC/XT. As it
+requires a genuine CGA card, it didn't work on modern PCs. In 1998 a new
+version was created by Andrew Jenner which runs on all PCs with CGA or
+better and, whilst retaining all the atmosphere and playability of the
+original, has many new features.
+
+In 2000 it was ported to several Unix-like architectures by Maxim Sobolev.
+Currently it supports FreeBSD, using either VGL or SDL library, and Linux using
+SDL library.
+
+WWW: http://www.digger.org/
diff --git a/games/digger-vgl/pkg-plist b/games/digger-vgl/pkg-plist
new file mode 100644
index 000000000000..acc7a47f49df
--- /dev/null
+++ b/games/digger-vgl/pkg-plist
@@ -0,0 +1,3 @@
+bin/digger
+share/doc/digger/digger.txt
+@dirrm share/doc/digger