aboutsummaryrefslogtreecommitdiff
path: root/games/domination
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-31 05:40:09 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-31 05:40:09 +0000
commit1bdff9ced503933e2d661044f3e9305b6441c24b (patch)
tree55d0856b2888e270572a940c050a345f63751edc /games/domination
parent09039d88f7755c12e439b6922e6369628d6a29fb (diff)
downloadports-1bdff9ced503933e2d661044f3e9305b6441c24b.tar.gz
ports-1bdff9ced503933e2d661044f3e9305b6441c24b.zip
- fix fetch
Submitted by: maintainer, nemysis@gmx.ch (private mail) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306732
Diffstat (limited to 'games/domination')
-rw-r--r--games/domination/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/games/domination/Makefile b/games/domination/Makefile
index cfbf5180d9b0..512b6087c1af 100644
--- a/games/domination/Makefile
+++ b/games/domination/Makefile
@@ -3,10 +3,10 @@
PORTNAME= domination
PORTVERSION= 1.1.1.1
CATEGORIES= games java
-MASTER_SITES= http://domination.sourceforge.net/maps/ \
- SF/${PORTNAME}/${PORTNAME:S/d/D/}/${PORTVERSION}/
-DISTFILES= ${PORTNAME:S/d/D/}_${DISTVERSION}${EXTRACT_SUFX} \
- ${MAPS:S/$/.zip/}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/d/D/}/${PORTVERSION}/:game \
+ http://domination.sourceforge.net/maps/:maps
+DISTFILES= ${PORTNAME:S/d/D/}_${DISTVERSION}${EXTRACT_SUFX}:game \
+ ${MAPS:S/$/.zip/}:maps
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= nemysis@gmx.ch
@@ -14,6 +14,7 @@ COMMENT= Board game that is a bit like the well known game Risk
LICENSE= GPLv3
+FETCH_ARGS?= -Fpr
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.5+
@@ -62,20 +63,15 @@ post-extract-script:
.endfor
do-install:
-# Scripts
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-* ${PREFIX}/bin
-# Data
${MKDIR} ${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "help lib maps resources saves *.jar *.cmd *.htm *.txt *.ini" ${DATADIR})
@(cd ${WRKSRC} && ${INSTALL_SCRIPT} *.sh ${DATADIR})
-# Fix Permission that user can write in saves
@(cd ${DATADIR} && ${CHMOD} 774 saves)
-# Pixmaps
${LN} -sf ${DATADIR}/resources/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}