aboutsummaryrefslogtreecommitdiff
path: root/games/domination
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-12 21:44:13 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-12 21:44:13 +0000
commit7a7fdb2aeb413bc2ff7c1b2ed444f3e06a37ff89 (patch)
tree3036885717997f34a7668c9c64081287f99c184f /games/domination
parent2bbe67e0a200601d8ce2950ea57686e967845545 (diff)
downloadports-7a7fdb2aeb413bc2ff7c1b2ed444f3e06a37ff89.tar.gz
ports-7a7fdb2aeb413bc2ff7c1b2ed444f3e06a37ff89.zip
- Change Desktop entry file
- Support STAGEDIR - Break lines around 80 characters - Use only one WWW
Notes
Notes: svn path=/head/; revision=339551
Diffstat (limited to 'games/domination')
-rw-r--r--games/domination/Makefile31
-rw-r--r--games/domination/pkg-descr1
2 files changed, 16 insertions, 16 deletions
diff --git a/games/domination/Makefile b/games/domination/Makefile
index bcd08338c965..ddf74ed1021b 100644
--- a/games/domination/Makefile
+++ b/games/domination/Makefile
@@ -40,6 +40,9 @@ MAPS= solar bigeurope google europass europe artic sudamerica \
simpsons_world simpsons germany2
PORTDOCS= ChangeLog.txt ReadMe.txt commands.txt todo.txt
+
+OPTIONS_DEFINE= DOCS
+
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= ${PORTNAME}-FlashGUI \
@@ -47,12 +50,9 @@ SUB_FILES= ${PORTNAME}-FlashGUI \
${PORTNAME}-SimpleGUI \
${PORTNAME}-SwingGUI
-DESKTOP_ENTRIES="Domination" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}-SwingGUI" "Game;StrategyGame;" false
+DESKTOP_ENTRIES="Domination" "" "${PORTNAME}" \
+ "${PORTNAME}-SwingGUI" "Game;StrategyGame;" ""
-OPTIONS_DEFINE= DOCS
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-extract-script:
@@ -61,15 +61,16 @@ post-extract-script:
.endfor
do-install:
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "help lib maps resources saves *.jar *.cmd *.htm *.txt *.ini" ${DATADIR})
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-* ${PREFIX}/bin
- @(cd ${WRKSRC} && ${INSTALL_SCRIPT} *.sh ${DATADIR})
- @(cd ${DATADIR} && ${CHMOD} 774 saves)
- ${LN} -sf ${DATADIR}/resources/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "help lib maps resources saves *.jar *.cmd *.htm *.txt *.ini" \
+ ${STAGEDIR}${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-* ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${INSTALL_SCRIPT} *.sh ${STAGEDIR}${DATADIR})
+ @(cd ${STAGEDIR}${DATADIR} && ${CHMOD} 774 saves)
+ ${LN} -sf ${DATADIR}/resources/icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/domination/pkg-descr b/games/domination/pkg-descr
index 86fd1f995d66..30adc60cd71f 100644
--- a/games/domination/pkg-descr
+++ b/games/domination/pkg-descr
@@ -7,5 +7,4 @@ Written in java it includes a map editor, a simple map format, multiplayer
network play, single player, hotseat, 5 user interfaces and many more features,
it works in all OSs that run java.
-WWW: http://domination.sourceforge.net/
WWW: http://yura.net/projects/domination/