aboutsummaryrefslogtreecommitdiff
path: root/games/doom
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2005-10-10 11:33:30 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2005-10-10 11:33:30 +0000
commit1f155c3f99b25e1a5c66873486154979e03bbe82 (patch)
tree9b5dcd44dd8ca54ceec749d0b725491ea24bf02c /games/doom
parent7394c65e3f00f0e67ab4d60808dec8de65222263 (diff)
downloadports-1f155c3f99b25e1a5c66873486154979e03bbe82.tar.gz
ports-1f155c3f99b25e1a5c66873486154979e03bbe82.zip
Sanitize the fetch target.
Update version number. Replace post-patch with real patch files. PR: ports/87111 Submitted by: edwin
Notes
Notes: svn path=/head/; revision=144795
Diffstat (limited to 'games/doom')
-rw-r--r--games/doom/Makefile32
-rw-r--r--games/doom/files/patch-ag7
-rw-r--r--games/doom/files/patch-sndserv__soundsrv.c11
-rw-r--r--games/doom/files/patch-sndserv__wadread.c11
4 files changed, 38 insertions, 23 deletions
diff --git a/games/doom/Makefile b/games/doom/Makefile
index 00238706d0e1..c79e82d8b82e 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -6,44 +6,34 @@
#
PORTNAME= doom
-PORTVERSION= 1.8
-PORTREVISION= 1
+PORTVERSION= 1.10
CATEGORIES= games
-MASTER_SITES?= ftp://ftp.idsoftware.com/idstuff/source/ \
- ftp://ftp.stomped.com/pub/idmirror/idstuff/source/ \
- ftp://ftp.cdrom.com/pub/idgames/idstuff/source/
-DISTNAME= doomsrc
+MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/:src \
+ ftp://ftp.stomped.com/pub/idmirror/idstuff/source/:src \
+ ftp://ftp.cdrom.com/pub/idgames/idstuff/source/:src \
+ ${MASTER_SITE_SUNSITE:S/$/:wad/g}
+MASTER_SITE_SUBDIR= games/doom/:wad
+DISTFILES= ${SRCFILE}:src ${WADFILE}:wad
+EXTRACT_ONLY= ${SRCFILE}
MAINTAINER= jmz@FreeBSD.org
COMMENT= DOOM: the game and the sound server
NO_CDROM= requested by IDsoftware
-MASTER_SITES2= ftp://sunsite.unc.edu/pub/Linux/games/doom/ \
- ftp://ftp.infomagic.com/pub/mirrors/linux/sunsite/games/doom/ \
- ftp://ftp.funet.fi/pub/mirrors/sunsite.unc.edu/pub/Linux/games/doom/
-DISTFILES2= doom1v18.wad.gz
+WADFILE= doom1v18.wad.gz
+SRCFILE= doomsrc${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386
-USE_PERL5_BUILD=yes
USE_XLIB= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
USE_GMAKE= yes
-.if !defined(__REAL_FETCH__)
-do-fetch:
- @${MAKE} ${.MAKEFLAGS} do-fetch __REAL_FETCH__=YES
- @${MAKE} ${.MAKEFLAGS} do-fetch __REAL_FETCH__=YES \
- DISTFILES="${DISTFILES2}" MASTER_SITES="${MASTER_SITES2}"
-.endif
post-extract:
@cd ${WRKDIR} && ${TAR} xzf linuxdoom-1.10.src.tgz && ${TAR} xzf sndserv.tgz
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e "s@#include +<malloc.h>@#include <stdlib.h>@g"
-
do-build:
@cd ${WRKDIR}/linuxdoom-1.10 && ${GMAKE}
@cd ${WRKDIR}/sndserv && ${GMAKE}
@@ -55,6 +45,6 @@ do-install:
@(${ECHO_CMD} "#!/bin/sh"; ${ECHO_CMD} "cd ${PREFIX}/libexec/doom"; \
${ECHO_CMD} 'export PATH=.:$$PATH';${ECHO_CMD} "export DOOMWADDIR=${PREFIX}/share/doom"; ${ECHO_CMD} "./xdoom $$*") > ${PREFIX}/bin/doom
@${CHMOD} ugo+x ${PREFIX}/bin/doom
- @${GZCAT} ${DISTDIR}/${DISTFILES2} > ${PREFIX}/share/doom/doom1.wad
+ @${GZCAT} ${DISTDIR}/${WADFILE} > ${PREFIX}/share/doom/doom1.wad
.include <bsd.port.mk>
diff --git a/games/doom/files/patch-ag b/games/doom/files/patch-ag
index 872a38f425ce..a4e598ff2df6 100644
--- a/games/doom/files/patch-ag
+++ b/games/doom/files/patch-ag
@@ -1,7 +1,10 @@
--- linuxdoom-1.10/w_wad.c~ Mon Dec 22 22:05:36 1997
+++ linuxdoom-1.10/w_wad.c Mon Dec 14 03:29:18 1998
-@@ -34,7 +34,7 @@
- #include <malloc.h>
+@@ -32,9 +32,9 @@
+ #include <string.h>
+ #include <unistd.h>
+-#include <malloc.h>
++#include <stdlib.h>
#include <fcntl.h>
#include <sys/stat.h>
-#include <alloca.h>
diff --git a/games/doom/files/patch-sndserv__soundsrv.c b/games/doom/files/patch-sndserv__soundsrv.c
new file mode 100644
index 000000000000..fb71d13561aa
--- /dev/null
+++ b/games/doom/files/patch-sndserv__soundsrv.c
@@ -0,0 +1,11 @@
+--- sndserv/soundsrv.c.orig Sat Oct 8 17:15:28 2005
++++ sndserv/soundsrv.c Sat Oct 8 17:15:33 2005
+@@ -47,7 +47,7 @@
+ #include <sys/ioctl.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+
diff --git a/games/doom/files/patch-sndserv__wadread.c b/games/doom/files/patch-sndserv__wadread.c
new file mode 100644
index 000000000000..e0533eca1469
--- /dev/null
+++ b/games/doom/files/patch-sndserv__wadread.c
@@ -0,0 +1,11 @@
+--- sndserv/wadread.c.orig Sat Oct 8 17:15:05 2005
++++ sndserv/wadread.c Sat Oct 8 17:15:09 2005
+@@ -39,7 +39,7 @@
+
+
+
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <stdio.h>