aboutsummaryrefslogtreecommitdiff
path: root/games/doomlegacy
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-03-05 23:17:30 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-03-05 23:17:30 +0000
commit47969a130c82160a863c66d0983d5773c47daa4a (patch)
treed828dd762420d844681f1d3588d62341c0dd88af /games/doomlegacy
parentc7996306051aa7151ef81a81ec99c59f148ab2db (diff)
downloadports-47969a130c82160a863c66d0983d5773c47daa4a.tar.gz
ports-47969a130c82160a863c66d0983d5773c47daa4a.zip
- Add patch to fix sound for ALC650 AC97 Codec on ASUS A7V8X
Submitted by: glebius Obtained from: mplayer
Notes
Notes: svn path=/head/; revision=130433
Diffstat (limited to 'games/doomlegacy')
-rw-r--r--games/doomlegacy/Makefile1
-rw-r--r--games/doomlegacy/files/patch-i_sound.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index c6440a95e2d1..7b9fcd42ffd6 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -6,6 +6,7 @@
PORTNAME= doomlegacy
PORTVERSION= 142
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/doomlegacy/files/patch-i_sound.c b/games/doomlegacy/files/patch-i_sound.c
new file mode 100644
index 000000000000..d847bb12cff8
--- /dev/null
+++ b/games/doomlegacy/files/patch-i_sound.c
@@ -0,0 +1,11 @@
+--- sdl/i_sound.c.orig Mon Apr 19 01:02:24 2004
++++ sdl/i_sound.c Sat Mar 5 23:04:27 2005
+@@ -118,7 +118,7 @@
+
+ #define SAMPLERATE 11025 // Hz
+
+-static int samplecount = 512;
++static int samplecount = 1024;
+
+ static int lengths[NUMSFX]; // The actual lengths of all sound effects.
+ static unsigned int channelstep[NUM_CHANNELS]; // The channel step amount...