aboutsummaryrefslogtreecommitdiff
path: root/games/easyrpg-player
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-03-07 19:27:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-03-07 19:27:31 +0000
commit4bab5f77b9a76be79210e131eb671ed0b20a8f1e (patch)
tree265dabdd90fe1f336674b706f1be1c09dc045bf7 /games/easyrpg-player
parent1fd51a1e895acf65a04b8941bff67549e32e95f9 (diff)
downloadports-4bab5f77b9a76be79210e131eb671ed0b20a8f1e.tar.gz
ports-4bab5f77b9a76be79210e131eb671ed0b20a8f1e.zip
- Update to 0.6.0
Notes
Notes: svn path=/head/; revision=494991
Diffstat (limited to 'games/easyrpg-player')
-rw-r--r--games/easyrpg-player/Makefile9
-rw-r--r--games/easyrpg-player/distinfo6
-rw-r--r--games/easyrpg-player/files/patch-CMakeLists.txt14
3 files changed, 8 insertions, 21 deletions
diff --git a/games/easyrpg-player/Makefile b/games/easyrpg-player/Makefile
index 06ce267de84f..043f954f3c34 100644
--- a/games/easyrpg-player/Makefile
+++ b/games/easyrpg-player/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= easyrpg-player
-PORTVERSION= 0.5.4
-PORTREVISION= 2
+PORTVERSION= 0.6.0
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -24,7 +23,9 @@ LIB_DEPENDS= liblcf.so:games/liblcf \
libopusfile.so:audio/opusfile \
libopus.so:audio/opus \
libWildMidi.so:audio/wildmidi \
- libxmp.so:audio/libxmp
+ libxmp.so:audio/libxmp \
+ libFLAC.so:audio/flac \
+ libmodplug.so:audio/libmodplug
# these come from liblcf
LIB_DEPENDS+= libicui18n.so:devel/icu \
libexpat.so:textproc/expat2
@@ -35,7 +36,7 @@ USE_GITHUB= yes
GH_ACCOUNT= EasyRPG
GH_PROJECT= Player
-USES= cmake:insource compiler:c++11-lib localbase:ldflags pkgconfig
+USES= cmake:insource compiler:c++11-lib localbase:ldflags pkgconfig sdl
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man \
-DPLAYER_AUDIO_BACKEND=SDL2_mixer
USE_XORG= pixman
diff --git a/games/easyrpg-player/distinfo b/games/easyrpg-player/distinfo
index 10847bfb5245..d27bd267006c 100644
--- a/games/easyrpg-player/distinfo
+++ b/games/easyrpg-player/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541171708
-SHA256 (EasyRPG-Player-0.5.4_GH0.tar.gz) = a504d873114706f01ff77145669938d41a977bbc3656c4a5aa431e7e6a1d21e4
-SIZE (EasyRPG-Player-0.5.4_GH0.tar.gz) = 5393488
+TIMESTAMP = 1551713584
+SHA256 (EasyRPG-Player-0.6.0_GH0.tar.gz) = 28be0b858f5dbd81ea39d7aabc1ebe068a07770213c1b22687e88811962a75ee
+SIZE (EasyRPG-Player-0.6.0_GH0.tar.gz) = 5433292
diff --git a/games/easyrpg-player/files/patch-CMakeLists.txt b/games/easyrpg-player/files/patch-CMakeLists.txt
deleted file mode 100644
index a84e253f2835..000000000000
--- a/games/easyrpg-player/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMakeLists.txt.orig 2018-10-27 09:58:54 UTC
-+++ CMakeLists.txt
-@@ -419,9 +419,9 @@ if(NOT A2X_EXECUTABLE STREQUAL "A2X_EXEC
- DEPENDS resources/${MAN_NAME}.adoc
- COMMENT "(Re-)building manpage ${MAN_NAME}"
- VERBATIM)
-- if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+ if(UNIX)
- add_custom_target(man ALL DEPENDS resources/${MAN_NAME})
-- install(FILES resources/${MAN_NAME} DESTINATION share/man/man6)
-+ install(FILES resources/${MAN_NAME} DESTINATION ${CMAKE_INSTALL_MANDIR}/man6)
- else()
- add_custom_target(man DEPENDS resources/${MAN_NAME})
- endif()