aboutsummaryrefslogtreecommitdiff
path: root/games/eboard
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-29 12:21:46 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-29 12:21:46 +0000
commit471f797ac6f9ef203821c5ed3a79417b8b41a82f (patch)
tree78721e3a5b634d969b5008e5c716ec77dde9519c /games/eboard
parentd8321e94730343004c140ca38a663d59c4ea09a4 (diff)
downloadports-471f797ac6f9ef203821c5ed3a79417b8b41a82f.tar.gz
ports-471f797ac6f9ef203821c5ed3a79417b8b41a82f.zip
Enable stage support
Notes
Notes: svn path=/head/; revision=337970
Diffstat (limited to 'games/eboard')
-rw-r--r--games/eboard/Makefile27
-rw-r--r--games/eboard/pkg-plist3
2 files changed, 14 insertions, 16 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 38f80ed24aa3..b41dc092b16c 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -16,7 +16,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= johans@FreeBSD.org
COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
EXTRAS= 1pl2 2
USES= shebangfix pkgconfig perl5
@@ -28,15 +28,10 @@ SHEBANG_FILES= configure
CONFIGURE_ARGS= --prefix=${PREFIX} \
--extra-inc=${LOCALBASE}/include \
- --extra-ld=${LOCALBASE}/lib \
- --data-dir=${DATADIR} \
- --disable-dgt
+ --extra-ld=${LOCALBASE}/lib
INSTALL_TARGET= install install-man
-MAN1= eboard-config.1 eboard-addtheme.1
-MAN6= eboard.6
-
OPTIONS_DEFINE= JOYSTICK
JOYSTICK_DESC= Enable joystick support
@@ -47,7 +42,6 @@ DESKTOP_ENTRIES="eboard" \
"Game;BoardGame;GTK;" \
true
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJOYSTICK}
@@ -72,20 +66,21 @@ post-configure:
.endif
post-install:
- ${LN} -sf ${LOCALBASE}/bin/timeseal ${DATADIR}/timeseal.FreeBSD
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${LN} -sf ${LOCALBASE}/bin/timeseal \
+ ${STAGEDIR}${DATADIR}/timeseal.FreeBSD
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.for file in Crafty.txt FICS-Timeseal.txt GNUChess4.txt GNUChess5.txt \
Scripts.txt Sjeng.txt Themes.txt
- ${INSTALL_DATA} ${WRKSRC}/Documentation/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
.for extra in ${EXTRAS}
- @cd ${WRKDIR}/eboard-extras-${extra} && EBOARDCONFIG=${PREFIX}/bin/eboard-config ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
- @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${PREFIX}/share/pixmaps/eboard.xpm
+ @${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/eboard.xpm
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/games/eboard/pkg-plist b/games/eboard/pkg-plist
index 93893f2d9aee..c2c12cff5595 100644
--- a/games/eboard/pkg-plist
+++ b/games/eboard/pkg-plist
@@ -1,6 +1,9 @@
bin/eboard
bin/eboard-addtheme
bin/eboard-config
+man/man1/eboard-config.1.gz
+man/man1/eboard-addtheme.1.gz
+man/man6/eboard.6.gz
%%PORTDOCS%%%%DOCSDIR%%/Crafty.txt
%%PORTDOCS%%%%DOCSDIR%%/FICS-Timeseal.txt
%%PORTDOCS%%%%DOCSDIR%%/GNUChess4.txt