aboutsummaryrefslogtreecommitdiff
path: root/games/ecwolf
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-03-19 15:26:00 +0000
committerSteve Wills <swills@FreeBSD.org>2019-03-19 15:26:00 +0000
commit85cbc660bacf7df23bf76f2565740327454fb3c3 (patch)
tree6945d86a4909a86efdf074f3685e15a7d9afed87 /games/ecwolf
parentfc648c220eb6a16a737c0fd85cdc2a534296638e (diff)
downloadports-85cbc660bacf7df23bf76f2565740327454fb3c3.tar.gz
ports-85cbc660bacf7df23bf76f2565740327454fb3c3.zip
games/ecwolf: create port
ECWolf is an advanced source port for Wolfenstein 3D, Spear of Destiny, and Super 3D Noah's Ark based off of the Wolf4SDL code base. ECWolf pulls a substantial amount of code from ZDoom and aims to provide a wide array of mod editing capabilities without the need to modify the source code. Most importantly you will no longer need to replace entire data sets. With ECWolf you could for example add a weapon without needing to distribute every sprite in the game along with it. Mods will be neatly packaged into a single file just like they are for Doom. WWW: https://maniacsvault.net/ecwolf PR: 230848 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=496267
Diffstat (limited to 'games/ecwolf')
-rw-r--r--games/ecwolf/Makefile35
-rw-r--r--games/ecwolf/distinfo3
-rw-r--r--games/ecwolf/files/ecwolf.in3
-rw-r--r--games/ecwolf/files/patch-src_CMakeLists.txt24
-rw-r--r--games/ecwolf/files/patch-src_wl__iwad__picker.cpp19
-rw-r--r--games/ecwolf/files/pkg-message.in5
-rw-r--r--games/ecwolf/pkg-descr10
7 files changed, 99 insertions, 0 deletions
diff --git a/games/ecwolf/Makefile b/games/ecwolf/Makefile
new file mode 100644
index 000000000000..9815cd64df21
--- /dev/null
+++ b/games/ecwolf/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= ecwolf
+PORTVERSION= 1.3.3
+DISTVERSIONSUFFIX= -src
+CATEGORIES= games
+MASTER_SITES= http://maniacsvault.net/ecwolf/files/ecwolf/1.x/
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= Source port for Wolfenstein 3D, Spear of Destiny
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= cmake jpeg localbase:ldflags gnome pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_SDL= mixer sdl
+
+SUB_FILES= ecwolf pkg-message
+SUB_LIST= PORTNAME=${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/${PORTNAME}/${PORTNAME} \
+ share/${PORTNAME}/${PORTNAME}.pk3
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/${PORTNAME}.pk3 \
+ ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/ecwolf/distinfo b/games/ecwolf/distinfo
new file mode 100644
index 000000000000..5b5043826d77
--- /dev/null
+++ b/games/ecwolf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534522946
+SHA256 (ecwolf-1.3.3-src.tar.xz) = 346b519745f399256463a7cf56d84c1315b1436c95e3a28aa287fc268ed96de9
+SIZE (ecwolf-1.3.3-src.tar.xz) = 7641476
diff --git a/games/ecwolf/files/ecwolf.in b/games/ecwolf/files/ecwolf.in
new file mode 100644
index 000000000000..537ee17acf38
--- /dev/null
+++ b/games/ecwolf/files/ecwolf.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%PREFIX%%/share/ecwolf && ./ecwolf
diff --git a/games/ecwolf/files/patch-src_CMakeLists.txt b/games/ecwolf/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..7c788ddb318e
--- /dev/null
+++ b/games/ecwolf/files/patch-src_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- src/CMakeLists.txt.orig 2019-01-29 16:31:24 UTC
++++ src/CMakeLists.txt
+@@ -40,9 +40,9 @@ else(GPL)
+ set(EXTRA_LIBRARIES)
+ endif(GPL)
+
+-find_package(SDL REQUIRED)
+-find_package(SDL_mixer REQUIRED)
+-include_directories(${SDLMIXER_INCLUDE_DIR} ${SDL_INCLUDE_DIR} ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
++pkg_search_module(SDL REQUIRED sdl sdl)
++pkg_search_module(SDLMIXER REQUIRED SDL_mixer)
++include_directories(${SDLMIXER_INCLUDE_DIRS} ${SDL_INCLUDE_DIRS}/SDL ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
+
+ check_function_exists(stricmp STRICMP_EXISTS)
+ check_function_exists(strnicmp STRNICMP_EXISTS)
+@@ -320,7 +320,7 @@ else(NOT ANDROID)
+ endif(NOT ANDROID)
+
+ add_dependencies(ecwolf lzma gdtoa revision_check)
+-target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARY} ${SDLMIXER_LIBRARY} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
++target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARIES} ${SDLMIXER_LIBRARIES} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
+ set_target_properties(ecwolf PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_DIR})
+
+ # Install
diff --git a/games/ecwolf/files/patch-src_wl__iwad__picker.cpp b/games/ecwolf/files/patch-src_wl__iwad__picker.cpp
new file mode 100644
index 000000000000..4feb03eab1be
--- /dev/null
+++ b/games/ecwolf/files/patch-src_wl__iwad__picker.cpp
@@ -0,0 +1,19 @@
+--- src/wl_iwad_picker.cpp.orig 2018-08-17 16:43:51 UTC
++++ src/wl_iwad_picker.cpp
+@@ -1,6 +1,7 @@
+ // From ZDoom!
+
+ #include <algorithm>
++#include <sys/wait.h>
+
+ #include "zdoomsupport.h"
+
+@@ -227,7 +228,7 @@ int I_PickIWad (WadStuff *wads, int numwads, bool show
+ const char *str;
+ if((str=getenv("KDE_FULL_SESSION")) && strcmp(str, "true") == 0)
+ {
+- FString cmd("kdialog --title \""GAMESIG" "DOTVERSIONSTR": Select an IWAD to use\""
++ FString cmd("kdialog --title \"" GAMESIG " " DOTVERSIONSTR ": Select an IWAD to use\""
+ " --menu \"" GAMENAME " found more than one IWAD\n"
+ "Select from the list below to determine which one to use:\"");
+
diff --git a/games/ecwolf/files/pkg-message.in b/games/ecwolf/files/pkg-message.in
new file mode 100644
index 000000000000..00e7483b557b
--- /dev/null
+++ b/games/ecwolf/files/pkg-message.in
@@ -0,0 +1,5 @@
+================================================================================
+
+To play this game, unpack original files to %%PREFIX%%/share/%%PORTNAME%%.
+
+================================================================================
diff --git a/games/ecwolf/pkg-descr b/games/ecwolf/pkg-descr
new file mode 100644
index 000000000000..4e3068998deb
--- /dev/null
+++ b/games/ecwolf/pkg-descr
@@ -0,0 +1,10 @@
+ECWolf is an advanced source port for Wolfenstein 3D, Spear of Destiny,
+and Super 3D Noah's Ark based off of the Wolf4SDL code base. ECWolf pulls
+a substantial amount of code from ZDoom and aims to provide a wide array of mod
+editing capabilities without the need to modify the source code.
+Most importantly you will no longer need to replace entire data sets.
+With ECWolf you could for example add a weapon without needing to distribute
+every sprite in the game along with it. Mods will be neatly packaged into
+a single file just like they are for Doom.
+
+WWW: https://maniacsvault.net/ecwolf