aboutsummaryrefslogtreecommitdiff
path: root/games/edge
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/edge
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/edge')
-rw-r--r--games/edge/Makefile4
-rw-r--r--games/edge/files/patch-epi__image_png.cc37
2 files changed, 39 insertions, 2 deletions
diff --git a/games/edge/Makefile b/games/edge/Makefile
index 5a4dfb87b650..5c1a4f0ccd09 100644
--- a/games/edge/Makefile
+++ b/games/edge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= edge
PORTVERSION= 1.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/EDGE%20Source%20Code/${PORTVERSION} \
SF/${PORTNAME}/EDGE%20Binaries/${PORTVERSION}:wad
@@ -24,7 +24,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
GLEW.1:${PORTSDIR}/graphics/glew \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/Edge-${PORTVERSION}-source
diff --git a/games/edge/files/patch-epi__image_png.cc b/games/edge/files/patch-epi__image_png.cc
new file mode 100644
index 000000000000..89672145e28c
--- /dev/null
+++ b/games/edge/files/patch-epi__image_png.cc
@@ -0,0 +1,37 @@
+--- epi/image_png.cc.orig 2010-06-08 15:36:37.000000000 +0200
++++ epi/image_png.cc 2012-04-27 13:02:14.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #undef _SETJMP_H // workaround for some weirdness in pngconf.h
+ #include <png.h>
++#include <zlib.h>
+
+ namespace epi
+ {
+@@ -96,7 +97,7 @@
+ /* set error handling since we are using the setjmp/longjmp method
+ * (this is the normal method of doing things with libpng).
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fprintf(stderr, "PNG_Load - Error loading PNG image !\n");
+ goto failed;
+@@ -238,7 +239,7 @@
+ /* set error handling since we are using the setjmp/longjmp method
+ * (this is the normal method of doing things with libpng).
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fprintf(stderr, "PNG: Error loading PNG image !\n");
+ goto failed;
+@@ -315,7 +318,7 @@
+ /* set error handling since we are using the setjmp/longjmp method
+ * (this is the normal method of doing things with libpng).
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fprintf(stderr, "PNG: Error saving PNG image !\n");
+ goto failed;