aboutsummaryrefslogtreecommitdiff
path: root/games/edge
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
commitc6a2501ef2a438d205325e3d382a031aa8486319 (patch)
treee2bedddab94c31b6b603a72007f201b1fd00c442 /games/edge
parentea074376d39570a02a19abe6cb0a09507466fa0a (diff)
downloadports-c6a2501ef2a438d205325e3d382a031aa8486319.tar.gz
ports-c6a2501ef2a438d205325e3d382a031aa8486319.zip
- Chase x11-toolkits/fltk update
Notes
Notes: svn path=/head/; revision=251412
Diffstat (limited to 'games/edge')
-rw-r--r--games/edge/Makefile3
-rw-r--r--games/edge/files/patch-SConstruct12
2 files changed, 12 insertions, 3 deletions
diff --git a/games/edge/Makefile b/games/edge/Makefile
index d02f9cccf5f7..9f4d65c02b5d 100644
--- a/games/edge/Makefile
+++ b/games/edge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= edge
PORTVERSION= 1.29
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/EDGE%20Source%20Code/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -28,6 +28,7 @@ SCONS_ARGS= release=true
post-patch:
@${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|;' ${WRKSRC}/src/e_main.cc
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|;' ${WRKSRC}/SConstruct
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gledge32 ${PREFIX}/bin/${PORTNAME}
diff --git a/games/edge/files/patch-SConstruct b/games/edge/files/patch-SConstruct
index 4bcf4a4e8498..d30a717887aa 100644
--- a/games/edge/files/patch-SConstruct
+++ b/games/edge/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- ./SConstruct.orig Wed Jun 6 10:07:47 2007
-+++ ./SConstruct Wed Dec 5 23:19:09 2007
+--- SConstruct.orig 2007-06-06 15:07:47.000000000 +0200
++++ SConstruct 2010-03-12 11:00:55.000000000 +0100
@@ -27,6 +27,14 @@
if build_info['cross']:
base_env.Tool('crossmingw', toolpath=['build'])
@@ -15,3 +15,11 @@
# warnings
base_env.Append(CCFLAGS = ['-Wall'])
+@@ -100,6 +108,7 @@
+ env.ParseConfig('#linux_lib/fltk-1.1.7/fltk-config --cflags')
+ env.Append(LIBPATH = ['#linux_lib/fltk-1.1.7/lib'])
+ env.Append(LIBS = ['fltk', 'fltk_images'])
++ env.Append(LINKFLAGS = ['%%PTHREAD_LIBS%%'])
+
+ # HawkNL
+ if 0: