aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-20 22:37:18 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-20 22:37:18 +0000
commit52f9d6a34153049cc27e2337cb1545fa82c3d8f0 (patch)
treeb90d13c635328e73959493a9f50abd3a74204c0d /games/eduke32
parentd4c8ea69b0c7f1ff7952bffe8176cb2fd2b5db07 (diff)
downloadports-52f9d6a34153049cc27e2337cb1545fa82c3d8f0.tar.gz
ports-52f9d6a34153049cc27e2337cb1545fa82c3d8f0.zip
games/eduke32: update to r6969, Voxel Pack to 1.21
PR: 230774 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> (maintainer)
Notes
Notes: svn path=/head/; revision=477686
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile10
-rw-r--r--games/eduke32/distinfo10
-rw-r--r--games/eduke32/files/patch-source_build_include_collections.h11
-rw-r--r--games/eduke32/files/patch-source_build_src_lz4.c11
4 files changed, 11 insertions, 31 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index cf27cf63427c..ac3f2f90e1fd 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -2,13 +2,14 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20180218
+PORTVERSION= 20180809
CATEGORIES= games
MASTER_SITES= http://dukeworld.duke4.net/eduke32/synthesis/${PORTVERSION}-${SVNREVISION}/:eduke32 \
http://www.duke4.org/files/nightfright/hrp/:hrp \
http://burnbit.com/download/447717/:hrp \
http://www.duke4.org/files/nightfright/related/:related \
- ftp://ftp.3drealms.com/share/:shareware
+ ftp://ftp.3drealms.com/share/:shareware \
+ https://anongoth.pl/:voxel
DISTFILES= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}:eduke32
EXTRACT_ONLY= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}
@@ -35,7 +36,7 @@ USE_GL= gl glu
USE_GNOME= gtk20
USE_SDL= sdl2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
-SVNREVISION= 6675
+SVNREVISION= 6969
DATADIR= ${PREFIX}/share/duke3d
SUB_FILES= pkg-message
MAKEFILE= GNUmakefile
@@ -47,6 +48,7 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES GCC HRP OFFENSIVE SHAREWARE VOXEL
OPTIONS_DEFINE_i386= ASM
OPTIONS_DEFAULT_i386= ASM
+OPTIONS_DEFAULT_amd64= GCC
OPTIONS_DEFAULT_powerpc= GCC
OPTIONS_DEFAULT_sparc64= GCC
@@ -66,7 +68,7 @@ SHAREWARE_EXTRACT_ONLY= 3dduke13.zip
SHAREWARE_DISTFILES= 3dduke13.zip:shareware
SHAREWARE_PLIST_FILES= ${DATADIR}/duke3d.grp ${DATADIR}/duke.rts
VOXEL_DESC= Install Voxel Pack
-VOXEL_DISTFILES= duke3d_voxels.zip:related
+VOXEL_DISTFILES= duke3d_voxels.zip:voxel
VOXEL_PLIST_FILES= ${DATADIR}/duke3d_voxels.zip
post-extract-SHAREWARE-on:
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index 65d59c7324f3..e87a68862b91 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1519048274
-SHA256 (eduke32_src_20180218-6675.tar.xz) = e647b293e9435297bd83f97cb0fc126b89b870bb3da8ba5be8efd09611b68ec1
-SIZE (eduke32_src_20180218-6675.tar.xz) = 14454576
+TIMESTAMP = 1534520418
+SHA256 (eduke32_src_20180809-6969.tar.xz) = 9f84e980a410b91cd759fd9ceb368b866b6e80ed7984d9ba45220ca60c4de3ba
+SIZE (eduke32_src_20180809-6969.tar.xz) = 14708992
SHA256 (duke3d_hrp.zip) = f217df456b4f11055041731033e35e4402fada99253e714e37c4a27e6fdc78a5
SIZE (duke3d_hrp.zip) = 933440151
SHA256 (duke3d_xxx.zip) = c31713e6400a175a1bfa3bd369d132f8a8abce8915c113549f98262b9a84b534
SIZE (duke3d_xxx.zip) = 26586453
SHA256 (3dduke13.zip) = c67efd179022bc6d9bde54f404c707cbcbdc15423c20be72e277bc2bdddf3d0e
SIZE (3dduke13.zip) = 5924374
-SHA256 (duke3d_voxels.zip) = b63deb1230554ecfd391699b85ae0be86ccb693657604378f0830ec0acec74e4
-SIZE (duke3d_voxels.zip) = 1743371
+SHA256 (duke3d_voxels.zip) = adaa7a1e3e2d94707ffcf8597f1352c159f7248db03293f6fa7351417599e050
+SIZE (duke3d_voxels.zip) = 2997999
diff --git a/games/eduke32/files/patch-source_build_include_collections.h b/games/eduke32/files/patch-source_build_include_collections.h
deleted file mode 100644
index 767ddde41304..000000000000
--- a/games/eduke32/files/patch-source_build_include_collections.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/build/include/collections.h.orig 2018-02-19 14:35:27 UTC
-+++ source/build/include/collections.h
-@@ -41,7 +41,7 @@ struct GrowArray
- void vacuum()
- {
- if (size_ < capacity_)
-- reallocate(size);
-+ reallocate(size());
- }
-
- void clear()
diff --git a/games/eduke32/files/patch-source_build_src_lz4.c b/games/eduke32/files/patch-source_build_src_lz4.c
deleted file mode 100644
index d024e911e836..000000000000
--- a/games/eduke32/files/patch-source_build_src_lz4.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/build/src/lz4.c.orig 2017-07-05 05:37:35 UTC
-+++ source/build/src/lz4.c
-@@ -89,7 +89,7 @@
- /*-************************************
- * Dependency
- **************************************/
--#include "lz4.h"
-+#include "../include/lz4.h"
- /* see also "memory routines" below */
-
-