aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-04-07 21:39:53 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-04-07 21:39:53 +0000
commita9e3e6141e2b70b4d3d37745cd81a4319a7d13c4 (patch)
tree9f357a72c502b0741ee4e4e790343046f3622a52 /games/eduke32
parent4fdbe3fe84e1002966ebdba404c33b7645b22b58 (diff)
downloadports-a9e3e6141e2b70b4d3d37745cd81a4319a7d13c4.tar.gz
ports-a9e3e6141e2b70b4d3d37745cd81a4319a7d13c4.zip
* Build fixes: add CC and CXX to MAKE_ARGS, pass NOASM via MAKE_ARGS
* Fetch fix: correct the URL for VOXEL and XXX packs * Add option VOXEL and remove obsolete MIDI options * Correct patching of game data path so the full path need not be specified * Install (SHAREWARE) or instruct (pkg-message) to copy both game data files PR: 217913 Approved by: pkubaj@anongoth.pl (maintainer), swills (mentor) Differential Revision: https://reviews.freebsd.org/D10107
Notes
Notes: svn path=/head/; revision=437958
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile54
-rw-r--r--games/eduke32/distinfo4
-rw-r--r--games/eduke32/files/pkg-message.in20
3 files changed, 40 insertions, 38 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index d9cbdc0f718c..6d9196fda794 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= http://dukeworld.duke4.net/eduke32/synthesis/${PORTVERSION}-${SVNREVISION}/:eduke32 \
http://www.duke4.org/files/nightfright/hrp/:hrp \
http://burnbit.com/download/447717/:hrp \
- http://www.duke4.org/files/nightfright/:xxx \
+ http://www.duke4.org/files/nightfright/related/:related \
ftp://ftp.3drealms.com/share/:shareware
DISTFILES= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}:eduke32
EXTRACT_ONLY= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}
@@ -17,11 +17,11 @@ MAINTAINER= pkubaj@anongoth.pl
COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
LICENSE= GPLv2 BUILDLIC
-LICENSE_FILE_GPLv2= ${WRKSRC}/source/duke3d/gpl-2.0.txt
LICENSE_COMB= multi
-LICENSE_PERMS_BUILDLIC= dist-mirror pkg-mirror auto-accept
-LICENSE_NAME_BUILDLIC= BUILD SOURCE CODE LICENSE
-LICENSE_FILE_BUILDLIC=${WRKSRC}/source/build/buildlic.txt
+LICENSE_NAME_BUILDLIC= BUILD SOURCE CODE LICENSE
+LICENSE_FILE_BUILDLIC= ${WRKSRC}/source/build/buildlic.txt
+LICENSE_FILE_GPLv2= ${WRKSRC}/source/duke3d/gpl-2.0.txt
+LICENSE_PERMS_BUILDLIC= dist-mirror pkg-mirror auto-accept
LIB_DEPENDS= libFLAC.so:audio/flac \
libogg.so:audio/libogg \
@@ -36,52 +36,43 @@ USE_GNOME= gtk20
USE_SDL= sdl2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
SVNREVISION= 6079
-DATADIR= ${LOCALBASE}/share/duke3d
+DATADIR= ${PREFIX}/share/duke3d
SUB_FILES= pkg-message
-SUB_LIST= DATADIR=${DATADIR}
MAKEFILE= GNUmakefile
+MAKE_ARGS= CC=${CC} CXX=${CXX}
PLIST_FILES= bin/eduke32 bin/mapster32
PORTEXAMPLES= *
BROKEN_sparc64= does not compile on sparc64
-OPTIONS_DEFINE= EXAMPLES HRP OFFENSIVE SHAREWARE
-OPTIONS_RADIO= MIDI
-OPTIONS_RADIO_MIDI= TIMIDITY TIMIDITYPLUS
-OPTIONS_DEFAULT=TIMIDITY
+OPTIONS_DEFINE= EXAMPLES HRP OFFENSIVE SHAREWARE VOXEL
OPTIONS_DEFINE_i386= ASM
OPTIONS_DEFAULT_i386= ASM
ASM_BUILD_DEPENDS= nasm:devel/nasm
-HRP_DESC= Install High Resolution Pack
-HRP_DISTFILES= duke3d_hrp.zip:hrp
+ASM_MAKE_ARGS_OFF= NOASM=1
+HRP_DESC= Install High Resolution Pack
+HRP_DISTFILES= duke3d_hrp.zip:hrp
HRP_PLIST_FILES= ${DATADIR}/duke3d_hrp.zip
-MIDI_DESC= MIDI music support
-OFFENSIVE_DESC= Install full XXX Pack
+OFFENSIVE_DESC= Install Full XXX Pack
OFFENSIVE_IMPLIES= HRP
-OFFENSIVE_DISTFILES= duke3d_xxx.zip:xxx
+OFFENSIVE_DISTFILES= duke3d_xxx.zip:related
OFFENSIVE_PLIST_FILES= ${DATADIR}/duke3d_xxx.zip
-SHAREWARE_DESC= Install shareware game data version 1.3
+SHAREWARE_DESC= Install shareware game data version 1.3
SHAREWARE_EXTRACT_ONLY= 3dduke13.zip
SHAREWARE_DISTFILES= 3dduke13.zip:shareware
-SHAREWARE_PLIST_FILES= ${DATADIR}/duke3d.grp
-TIMIDITY_DESC= Use Timidity for music support
-TIMIDITY_RUN_DEPENDS= timidity:audio/timidity
-TIMIDITYPLUS_DESC= Use Timidity++ for music support
-TIMIDITYPLUS_RUN_DEPENDS= timidity:audio/timidity++
+SHAREWARE_PLIST_FILES= ${DATADIR}/duke3d.grp ${DATADIR}/duke.rts
+VOXEL_DESC= Install Voxel Pack
+VOXEL_DISTFILES= duke3d_voxels.zip:related
+VOXEL_PLIST_FILES= ${DATADIR}/duke3d_voxels.zip
post-extract-SHAREWARE-on:
@cd ${WRKDIR} && ${UNZIP_NATIVE_CMD} -qo DN3DSW13.SHR
post-patch:
- @${REINPLACE_CMD} -e '/^CC=/s|gcc|${CC}|' -e '/^CXX=/s|g++|${CXX}|' \
- ${WRKSRC}/GNUmakefile
- @${REINPLACE_CMD} 's|/usr/share/games/eduke32|${DN3DDIR}|' \
- ${WRKSRC}/source/duke3d/src/game.cpp ${WRKSRC}/source/duke3d/src/astub.cpp
-
-post-patch-ASM-off:
- @${REINPLACE_CMD} '/^NOASM =/s/0/1/' ${WRKSRC}/GNUmakefile
+ @${REINPLACE_CMD} 's|/usr/share/games/eduke32|${DATADIR}|' \
+ ${WRKSRC}/source/duke3d/src/common.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/eduke32 ${STAGEDIR}${PREFIX}/bin
@@ -103,5 +94,10 @@ do-install-OFFENSIVE-on:
do-install-SHAREWARE-on:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKDIR}/DUKE3D.GRP ${STAGEDIR}${DATADIR}/duke3d.grp
+ ${INSTALL_DATA} ${WRKDIR}/DUKE.RTS ${STAGEDIR}${DATADIR}/duke.rts
+
+do-install-VOXEL-on:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/duke3d_voxels.zip ${STAGEDIR}${DATADIR}/duke3d_voxels.zip
.include <bsd.port.mk>
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index fe34f7cbf3e3..2de9aac20a39 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1488206145
+TIMESTAMP = 1489745171
SHA256 (eduke32_src_20170225-6079.tar.xz) = 23cecc904df1e1e528c499e775a4dce7417cc70b8d97e7dcef068ff197e6a0a7
SIZE (eduke32_src_20170225-6079.tar.xz) = 14759072
SHA256 (duke3d_hrp.zip) = f217df456b4f11055041731033e35e4402fada99253e714e37c4a27e6fdc78a5
@@ -7,3 +7,5 @@ SHA256 (duke3d_xxx.zip) = c31713e6400a175a1bfa3bd369d132f8a8abce8915c113549f9826
SIZE (duke3d_xxx.zip) = 26586453
SHA256 (3dduke13.zip) = c67efd179022bc6d9bde54f404c707cbcbdc15423c20be72e277bc2bdddf3d0e
SIZE (3dduke13.zip) = 5924374
+SHA256 (duke3d_voxels.zip) = b63deb1230554ecfd391699b85ae0be86ccb693657604378f0830ec0acec74e4
+SIZE (duke3d_voxels.zip) = 1743371
diff --git a/games/eduke32/files/pkg-message.in b/games/eduke32/files/pkg-message.in
index e021114ff1db..f776f23db33b 100644
--- a/games/eduke32/files/pkg-message.in
+++ b/games/eduke32/files/pkg-message.in
@@ -1,11 +1,15 @@
-==============================================================================
+================================================================================
-To complete the installation of this port you need to copy the file
-"DUKE3D.GRP" from the original Duke Nukem 3D distribution as "duke3d.grp" to
-%%DATADIR%%, if you want to install it globally, and then run with
--g %%DATADIR%%/duke3d.grp parameter. If you also installed any of the
-optional packs, you need to add the -g parameter in the same manner.
+To complete the installation of this port, you need to copy the files
+DUKE3D.GRP and DUKE.RTS from the original Duke Nukem 3D distribution to
+%%DATADIR%% with names "duke3d.grp" and "duke.rts"
-If you installed the XXX Pack, you need to include both HRP and XXX Packs.
+If you installed any of the optional packs, run the game with -g and the full
+path of the pack file e.g. eduke32 -g %%DATADIR%%/duke3d_voxels.zip
-==============================================================================
+To use the XXX Pack, you need to first include the HRP,
+i.e. eduke32 -g %%DATADIR%%/duke3d_hrp.zip -g %%DATADIR%%/duke3d_xxx.zip
+
+The Voxel pack is intended for use with classic textures, HRP has new models.
+
+================================================================================