aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-21 12:09:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-21 12:09:59 +0000
commitbf2bf5b74136b54096c6849444c58c9e55ea5931 (patch)
treeeaba69139cea85c3116e9f6aac39dbd838416dc1 /games/eduke32
parent18fab186d2bfd8f2447a2997b18d2d29d363036d (diff)
downloadports-bf2bf5b74136b54096c6849444c58c9e55ea5931.tar.gz
ports-bf2bf5b74136b54096c6849444c58c9e55ea5931.zip
- Update to r5775
PR: 209987 Submitted by: pkubaj@anongoth.pl (maintainer)
Notes
Notes: svn path=/head/; revision=417204
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile8
-rw-r--r--games/eduke32/distinfo4
-rw-r--r--games/eduke32/files/patch-Makefile.common13
-rw-r--r--games/eduke32/files/patch-build_src_baselayer.c12
4 files changed, 19 insertions, 18 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index 8cd047057452..fd36f4049449 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20160103
+PORTVERSION= 20160610
CATEGORIES= games
MASTER_SITES= http://dukeworld.duke4.net/eduke32/synthesis/${PORTVERSION}-${SVNREVISION}/:eduke32
DISTFILES= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}:eduke32
EXTRACT_ONLY= ${PORTNAME}_src_${PORTVERSION}-${SVNREVISION}${EXTRACT_SUFX}
-MAINTAINER= pkubaj@riseup.net
+MAINTAINER= pkubaj@anongoth.pl
COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
LICENSE= GPLv2
@@ -25,7 +25,7 @@ USE_GL= gl glu
USE_GNOME= gtk20
USE_SDL= sdl2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
-SVNREVISION= 5506
+SVNREVISION= 5775
DATADIR= ${LOCALBASE}/share/duke3d
SUB_FILES= pkg-message
SUB_LIST= DATADIR=${DATADIR}
@@ -54,6 +54,8 @@ TIMIDITY_RUN_DEPENDS= timidity:audio/timidity
TIMIDITYPLUS_DESC= Use Timidity++ for music support
TIMIDITYPLUS_RUN_DEPENDS= timidity:audio/timidity++
+CFLAGS+= -flax-vector-conversions
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHRP}
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index 9afb8d43944a..ac3c5c020a7c 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,5 +1,5 @@
-SHA256 (eduke32_src_20160103-5506.tar.xz) = bdd4ea7100c3913981f1be0fc26285a433659bf83528cb2a93f0bcabd95aa34a
-SIZE (eduke32_src_20160103-5506.tar.xz) = 14352508
+SHA256 (eduke32_src_20160610-5775.tar.xz) = ce75431ca0145f1c37934d5c934393982f27b6aa64619a4023ce54e4fd50c8f9
+SIZE (eduke32_src_20160610-5775.tar.xz) = 14532340
SHA256 (duke3d_hrp.zip) = f217df456b4f11055041731033e35e4402fada99253e714e37c4a27e6fdc78a5
SIZE (duke3d_hrp.zip) = 933440151
SHA256 (duke3d_xxx.zip) = c31713e6400a175a1bfa3bd369d132f8a8abce8915c113549f98262b9a84b534
diff --git a/games/eduke32/files/patch-Makefile.common b/games/eduke32/files/patch-Makefile.common
index d379ba1916e7..c68a8aca865d 100644
--- a/games/eduke32/files/patch-Makefile.common
+++ b/games/eduke32/files/patch-Makefile.common
@@ -1,6 +1,6 @@
---- Makefile.common.orig 2015-07-08 03:34:34 UTC
+--- Makefile.common.orig 2016-06-03 04:50:55 UTC
+++ Makefile.common
-@@ -258,7 +258,6 @@ ifndef LTO
+@@ -252,7 +252,6 @@ ifndef LTO
endif
endif
@@ -8,13 +8,12 @@
COMPILERFLAGS=
ifeq ($(PACKAGE_REPOSITORY),0)
-@@ -278,8 +277,8 @@ ifneq ($(RELEASE)$(DEBUGANYWAY),10)
- OPTIMIZATIONS += $(DEBUGFLAG)
+@@ -273,7 +272,7 @@ ifneq ($(RELEASE)$(DEBUGANYWAY),10)
endif
CONLYFLAGS=-std=gnu99 -Wimplicit -Werror-implicit-function-declaration
--CPPONLYFLAGS= -fno-exceptions -fno-rtti -Wno-write-strings
-+CPPONLYFLAGS= -fno-exceptions -fno-rtti -fpermissive -Wno-write-strings
- ASFORMAT=elf$(SYSBITS)
+-CXXONLYFLAGS= -fno-exceptions -fno-rtti
++CXXONLYFLAGS= -fno-exceptions -fno-rtti -fpermissive
+ ASFORMAT=elf$(BITS)
ASFLAGS=-s -f $(ASFORMAT) #-g
LINKERFLAGS=
diff --git a/games/eduke32/files/patch-build_src_baselayer.c b/games/eduke32/files/patch-build_src_baselayer.c
index 1961024a0988..e07c72d89d7c 100644
--- a/games/eduke32/files/patch-build_src_baselayer.c
+++ b/games/eduke32/files/patch-build_src_baselayer.c
@@ -1,11 +1,11 @@
---- build/src/baselayer.c.orig 2015-07-25 17:23:17 UTC
+--- build/src/baselayer.c.orig 2016-05-29 21:11:27 UTC
+++ build/src/baselayer.c
-@@ -219,7 +219,7 @@ void calc_ylookup(int32_t bpl, int32_t l
+@@ -227,7 +227,7 @@ void calc_ylookup(int32_t bpl, int32_t l
{
Baligned_free(ylookup);
- ylookup = (intptr_t *)Xaligned_alloc(16, lastyidx * sizeof(intptr_t));
-+ posix_memalign(&ylookup, 16, lastyidx * sizeof(intptr_t));
- #if !defined(NOASM) && !defined(GEKKO) && !defined(__ANDROID__)
- nx_unprotect((intptr_t)ylookup, (intptr_t)ylookup + (lastyidx * sizeof(intptr_t)));
- #endif
++ posix_memalign(&ylookup, 16, lastyidx * sizeof(intptr_t));
+ ylookupsiz = lastyidx;
+ }
+