aboutsummaryrefslogtreecommitdiff
path: root/games/egl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/egl
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/egl')
-rw-r--r--games/egl/Makefile6
-rw-r--r--games/egl/files/patch-renderer__rf_image.c21
2 files changed, 17 insertions, 10 deletions
diff --git a/games/egl/Makefile b/games/egl/Makefile
index 48728f379e2f..6a4b0d0f1520 100644
--- a/games/egl/Makefile
+++ b/games/egl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= egl
PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://egl.quakedev.com/files/:src \
ftp://ftp.alepulver.com.ar/distfiles/:data
@@ -41,8 +41,10 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.if defined(WITH_CLIENT)
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_GL= yes
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+MAKE_ENV*= CFLAGS="${CFLAGS}"
PLIST_SUB+= CLIENT=""
EGL_BIN+= egl
.else
diff --git a/games/egl/files/patch-renderer__rf_image.c b/games/egl/files/patch-renderer__rf_image.c
index 0205ae4daf96..1811e4922906 100644
--- a/games/egl/files/patch-renderer__rf_image.c
+++ b/games/egl/files/patch-renderer__rf_image.c
@@ -1,7 +1,14 @@
-
---- renderer/rf_image.c.orig 2010-07-08 22:47:22.720284451 +0200
-+++ renderer/rf_image.c 2010-07-08 22:53:00.496664288 +0200
-@@ -44,7 +44,7 @@
+--- renderer/rf_image.c.orig 2012-04-29 06:34:41.000000000 +0200
++++ renderer/rf_image.c 2012-04-29 06:35:42.000000000 +0200
+@@ -32,6 +32,7 @@
+ #else
+ # include <jpeglib.h>
+ # include <png.h>
++# include <pngpriv.h>
+ #endif
+
+ #define MAX_IMAGE_HASH (MAX_IMAGES/4)
+@@ -44,7 +45,7 @@
image_t *r_lmTextures[R_MAX_LIGHTMAPS];
static image_t r_imageList[MAX_IMAGES];
static image_t *r_imageHashTree[MAX_IMAGE_HASH];
@@ -10,7 +17,7 @@
static byte r_intensityTable[256];
static byte r_gammaTable[256];
-@@ -261,21 +261,6 @@
+@@ -261,21 +262,6 @@
cinfo->src->bytes_in_buffer -= (size_t) num_bytes;
}
@@ -32,7 +39,7 @@
/*
=============
R_LoadJPG
-@@ -610,7 +595,7 @@
+@@ -610,7 +596,7 @@
png_set_filler (png_ptr, 0xFF, PNG_FILLER_AFTER);
if (info_ptr->color_type == PNG_COLOR_TYPE_GRAY && info_ptr->bit_depth < 8)
@@ -41,5 +48,3 @@
if (png_get_valid (png_ptr, info_ptr, PNG_INFO_tRNS))
png_set_tRNS_to_alpha (png_ptr);
-
-