aboutsummaryrefslogtreecommitdiff
path: root/games/eights
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2002-02-22 02:59:32 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2002-02-22 02:59:32 +0000
commit6d079cec052286ff8e8a3b062ccacde8464ea167 (patch)
tree9160d5dd53dbaaa8f96c7b420970f5be10856852 /games/eights
parent2658ba9c3c0fbdd05e16ff1ea50d94f05b4c6da8 (diff)
downloadports-6d079cec052286ff8e8a3b062ccacde8464ea167.tar.gz
ports-6d079cec052286ff8e8a3b062ccacde8464ea167.zip
Add eights, a simple text-based games of eights
(and my brother's first port :) Submitted by: Bob Bomar <bob@fly.homeunix.org>
Notes
Notes: svn path=/head/; revision=55066
Diffstat (limited to 'games/eights')
-rw-r--r--games/eights/Makefile24
-rw-r--r--games/eights/distinfo1
-rw-r--r--games/eights/pkg-comment1
-rw-r--r--games/eights/pkg-descr7
-rw-r--r--games/eights/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/games/eights/Makefile b/games/eights/Makefile
new file mode 100644
index 000000000000..b35bc7d6b7df
--- /dev/null
+++ b/games/eights/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: eights
+# Date created: 21 Febuary 2002
+# Whom: Bob Bomar <bob@fly.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eights
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://dxkelly.freeshell.org/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= bob@fly.homeunix.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/eights/distinfo b/games/eights/distinfo
new file mode 100644
index 000000000000..0e9098174b81
--- /dev/null
+++ b/games/eights/distinfo
@@ -0,0 +1 @@
+MD5 (eights.tar.gz) = 66a2158343556d0adc26b7b038dcb58d
diff --git a/games/eights/pkg-comment b/games/eights/pkg-comment
new file mode 100644
index 000000000000..06ae2fdf83f0
--- /dev/null
+++ b/games/eights/pkg-comment
@@ -0,0 +1 @@
+Text based card game, the objective is to get rid of all your cards
diff --git a/games/eights/pkg-descr b/games/eights/pkg-descr
new file mode 100644
index 000000000000..6e1a22ad494e
--- /dev/null
+++ b/games/eights/pkg-descr
@@ -0,0 +1,7 @@
+Eights is a text based card game. The objective is to get rid of all your cards
+before the computer does. You must play the same number or suit as what is
+discarded. Eights are wild and are worth 50 points. You want the least amount
+of points.
+
+- Bob Bomar
+<bob@fly.homeunix.org>
diff --git a/games/eights/pkg-plist b/games/eights/pkg-plist
new file mode 100644
index 000000000000..cb40e42ffd88
--- /dev/null
+++ b/games/eights/pkg-plist
@@ -0,0 +1 @@
+bin/eights