aboutsummaryrefslogtreecommitdiff
path: root/games/eights
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /games/eights
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417166
Diffstat (limited to 'games/eights')
-rw-r--r--games/eights/Makefile2
-rw-r--r--games/eights/files/patch-eights.c20
2 files changed, 12 insertions, 10 deletions
diff --git a/games/eights/Makefile b/games/eights/Makefile
index 2946a768c601..79eb82d31858 100644
--- a/games/eights/Makefile
+++ b/games/eights/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Text based card game, the objective is to get rid of all your cards
+USES= dos2unix
+DOS2UNIX_FILES= eights.c
NO_WRKSUBDIR= yes
PLIST_FILES= bin/eights
diff --git a/games/eights/files/patch-eights.c b/games/eights/files/patch-eights.c
index 51aac5ea1aa7..2155d1e59ac4 100644
--- a/games/eights/files/patch-eights.c
+++ b/games/eights/files/patch-eights.c
@@ -1,11 +1,11 @@
---- eights.c Sun Nov 10 08:50:52 2002
-+++ eights.c Sat May 20 12:36:22 2000
+--- eights.c.orig 2016-06-20 14:33:50 UTC
++++ eights.c
@@ -5,6 +5,8 @@
- #include <unistd.h>
- #include <time.h>
-
-+#define debug
-+
- #ifdef DEBUG
- #undef debug
- #define debug printf
+ #include <unistd.h>
+ #include <time.h>
+
++#define debug
++
+ #ifdef DEBUG
+ #undef debug
+ #define debug printf