aboutsummaryrefslogtreecommitdiff
path: root/games/einstein
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
commitc1a541e10b6da4e977a1c56303ca18763254bc5e (patch)
treebd99c1f9fd4d9ff682c82dc5739770a4ca386b18 /games/einstein
parentf390ea6077c7f2203c80030dda537ba49703381a (diff)
downloadports-c1a541e10b6da4e977a1c56303ca18763254bc5e.tar.gz
ports-c1a541e10b6da4e977a1c56303ca18763254bc5e.zip
Conditionalize compiler flags that are specific to clang to fix errors
of the following forms on GCC-based architectures: cc1plus: error: unrecognized command line option "-Wno-c++11-narrowing" cc1plus: error: unrecognized command line option "-Wno-reserved-user-defined-literal" cc1plus: warning: unrecognized command line option '-Wno-error-narrowing' Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497858
Diffstat (limited to 'games/einstein')
-rw-r--r--games/einstein/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/einstein/Makefile b/games/einstein/Makefile
index a20d6df816fa..5127a6fe2183 100644
--- a/games/einstein/Makefile
+++ b/games/einstein/Makefile
@@ -16,10 +16,12 @@ LICENSE= GPLv2+ # (now dead) website mentions GPL
LIB_DEPENDS= libfreetype.so:print/freetype2
+USES= compiler
USE_SDL= sdl ttf mixer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/einstein