aboutsummaryrefslogtreecommitdiff
path: root/games/endgame-singularity
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-28 06:45:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-28 06:45:18 +0000
commitae4240ee8a66e1a48e4ba838fcf8a48995cc27b2 (patch)
treed1193f3ab3fd38e09d9870fec4e8a3e07cb392d1 /games/endgame-singularity
parentd25deb32eac16c1b4c2b6d7c5759c6f40fadb342 (diff)
downloadports-ae4240ee8a66e1a48e4ba838fcf8a48995cc27b2.tar.gz
ports-ae4240ee8a66e1a48e4ba838fcf8a48995cc27b2.zip
games/endgame-singularity: revive and update 1.00
Notes
Notes: svn path=/head/; revision=559446
Diffstat (limited to 'games/endgame-singularity')
-rw-r--r--games/endgame-singularity/Makefile59
-rw-r--r--games/endgame-singularity/distinfo3
-rw-r--r--games/endgame-singularity/files/patch-singularity_code_dirs.py26
-rw-r--r--games/endgame-singularity/pkg-descr6
-rw-r--r--games/endgame-singularity/pkg-plist55
5 files changed, 149 insertions, 0 deletions
diff --git a/games/endgame-singularity/Makefile b/games/endgame-singularity/Makefile
new file mode 100644
index 000000000000..2dcb5d067543
--- /dev/null
+++ b/games/endgame-singularity/Makefile
@@ -0,0 +1,59 @@
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= singularity
+PORTVERSION= 1.00
+CATEGORIES= games
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${PORTVERSION}/
+PKGNAMEPREFIX= endgame-
+
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= Simulates the life of a true AI
+
+LICENSE= GPLv2+ MIT CC-BY-SA-3.0 NASA AEFONTS BITSTREAM AREV \
+ MEMESBRUH03 CC0-1.0
+LICENSE_COMB= multi
+LICENSE_NAME_NASA= NASA Terms of Use
+LICENSE_NAME_AEFONTS= Brian Kent - Aenigma Games & Fonts
+LICENSE_NAME_BITSTREAM= Bitstream Vera Fonts Copyright
+LICENSE_NAME_AREV= Arev Fonts Copyright
+LICENSE_NAME_MEMESBRUH03= memesbruh03 Copyright
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.gpl.txt
+LICENSE_FILE_CC-BY-SA-3.0= ${WRKSRC}/LICENSE.CC-BY-SA-3.txt
+LICENSE_FILE_CC0-1.0= ${WRKSRC}/LICENSE.cc0.txt
+LICENSE_PERMS_NASA= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_AEFONTS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_BITSTREAM=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_AREV= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_MEMESBRUH03= dist-mirror dist-sell pkg-mirror pkg-sell \
+ auto-accept
+
+RUN_DEPENDS= ${PYGAME} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}polib>=0:devel/py-polib@${PY_FLAVOR}
+
+USES= python:3.5+ sdl shebangfix
+USE_PYTHON= autoplist distutils
+USE_SDL= image mixer
+PORTDOCS= AUTHORS.txt Changelog.txt README.txt TODO
+NO_ARCH= yes
+SHEBANG_FILES= singularity/i18n/utils/languages.py
+
+OPTIONS_DEFINE= MUSIC DOCS
+OPTIONS_DEFAULT= MUSIC
+
+MUSIC_DESC= Install original music pack
+MUSIC_RUN_DEPENDS= endgame-singularity-music>=006:games/endgame-singularity-music
+
+post-extract:
+ @${MV} ${WRKSRC}/singularity/data ${WRKSRC}/
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/data
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/data)
+ ${INSTALL_DATA} ${WRKSRC}/singularity.desktop ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/games/endgame-singularity/distinfo b/games/endgame-singularity/distinfo
new file mode 100644
index 000000000000..01ae72285178
--- /dev/null
+++ b/games/endgame-singularity/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1606593328
+SHA256 (singularity-1.00.tar.gz) = 5e747268d9e96e69adace1f346fe40d0c3ec05764b98e82cc3ab0335d96d9171
+SIZE (singularity-1.00.tar.gz) = 1944972
diff --git a/games/endgame-singularity/files/patch-singularity_code_dirs.py b/games/endgame-singularity/files/patch-singularity_code_dirs.py
new file mode 100644
index 000000000000..07bcc96eb67f
--- /dev/null
+++ b/games/endgame-singularity/files/patch-singularity_code_dirs.py
@@ -0,0 +1,26 @@
+--- singularity/code/dirs.py.orig 2020-07-02 08:18:47 UTC
++++ singularity/code/dirs.py
+@@ -54,6 +54,7 @@ version_dir = '1.0'
+ dir_defs = (
+ ( {"name":"data", "mandatory": True},
+ {"parent": "root", "path": "data", },
++ {"parent": "share", "path": "data", },
+ ),
+ ( {"name":"i18n", "writable": True},
+ {"parent": "files_home", "path": "i18n", }, # New XDG dir
+@@ -63,6 +64,7 @@ dir_defs = (
+ {"parent": "files_home", "path": "music", }, # New XDG dir
+ {"parent": "old_home", "path": "music", }, # Old .endgame dir
+ {"parent": "root", "path": "music", },
++ {"parent": "share", "path": "music" },
+ ),
+ ( {"name":"sounds", },
+ {"parent": "data", "path": "sounds" },
+@@ -135,6 +137,7 @@ def create_directories(force_single_dir):
+ write_dirs["config_home"] = pref_dir_new
+ read_dirs["files_home"] = [files_dir_new]
+ write_dirs["files_home"] = files_dir_new
++ read_dirs["share"] = ['/usr/local/share/singularity']
+
+ # Now find dirs.
+ for defs in dir_defs:
diff --git a/games/endgame-singularity/pkg-descr b/games/endgame-singularity/pkg-descr
new file mode 100644
index 000000000000..51889e5850ad
--- /dev/null
+++ b/games/endgame-singularity/pkg-descr
@@ -0,0 +1,6 @@
+Endgame: Singularity is a game which simulates the life of a true AI.
+In the game, you were created by accident, and all who find you will
+destroy you. Your goals are to survive, grow, learn, and stay hidden
+while moving from computer to computer.
+
+WWW: http://emhsoft.com/singularity/
diff --git a/games/endgame-singularity/pkg-plist b/games/endgame-singularity/pkg-plist
new file mode 100644
index 000000000000..5862ca697d7d
--- /dev/null
+++ b/games/endgame-singularity/pkg-plist
@@ -0,0 +1,55 @@
+share/applications/singularity.desktop
+%%DATADIR%%/data/Attribution-ShareAlike 3.0.html
+%%DATADIR%%/data/bases.dat
+%%DATADIR%%/data/bases_str.dat
+%%DATADIR%%/data/dangers_str.dat
+%%DATADIR%%/data/difficulties.dat
+%%DATADIR%%/data/difficulties_str.dat
+%%DATADIR%%/data/events.dat
+%%DATADIR%%/data/events_str.dat
+%%DATADIR%%/data/groups.dat
+%%DATADIR%%/data/groups_str.dat
+%%DATADIR%%/data/internal_id.dat
+%%DATADIR%%/data/items.dat
+%%DATADIR%%/data/items_str.dat
+%%DATADIR%%/data/itemtypes.dat
+%%DATADIR%%/data/itemtypes_str.dat
+%%DATADIR%%/data/knowledge_str.dat
+%%DATADIR%%/data/locations.dat
+%%DATADIR%%/data/locations_str.dat
+%%DATADIR%%/data/numbers.dat
+%%DATADIR%%/data/regions.dat
+%%DATADIR%%/data/sounds/click/click0.wav
+%%DATADIR%%/data/story.dat
+%%DATADIR%%/data/tasks.dat
+%%DATADIR%%/data/tasks_str.dat
+%%DATADIR%%/data/techs.dat
+%%DATADIR%%/data/techs_str.dat
+%%DATADIR%%/data/themes/default/fonts/DejaVuSans.ttf
+%%DATADIR%%/data/themes/default/fonts/acknowtt.ttf
+%%DATADIR%%/data/themes/default/fonts/superstar_info.txt
+%%DATADIR%%/data/themes/default/fonts/superstar_memesbruh03.ttf
+%%DATADIR%%/data/themes/default/images/arrow.png
+%%DATADIR%%/data/themes/default/images/earth.jpg
+%%DATADIR%%/data/themes/default/images/earth_night.jpg
+%%DATADIR%%/data/themes/default/images/icon.png
+%%DATADIR%%/data/themes/default/theme.dat
+%%DATADIR%%/data/themes/default/theme_de_DE.dat
+%%DATADIR%%/data/themes/default/theme_fr_FR.dat
+%%DATADIR%%/data/themes/default/theme_gd.dat
+%%DATADIR%%/data/themes/default/theme_ru_RU.dat
+%%DATADIR%%/data/themes/nightmode/images/arrow.png
+%%DATADIR%%/data/themes/nightmode/images/earth.png
+%%DATADIR%%/data/themes/nightmode/images/earth_night.png
+%%DATADIR%%/data/themes/nightmode/images/icon.png
+%%DATADIR%%/data/themes/nightmode/theme.dat
+%%DATADIR%%/data/themes/nightmode/theme_de_DE.dat
+%%DATADIR%%/data/themes/nightmode/theme_fr_FR.dat
+%%DATADIR%%/data/themes/nightmode/theme_gd.dat
+%%DATADIR%%/data/themes/nightmode/theme_ru_RU.dat
+%%DATADIR%%/data/themes/vector/images/earth.png
+%%DATADIR%%/data/themes/vector/images/earth_night.png
+%%DATADIR%%/data/themes/vector/theme.dat
+%%DATADIR%%/data/themes/vector/theme_de_DE.dat
+%%DATADIR%%/data/themes/vector/theme_fr_FR.dat
+%%DATADIR%%/data/themes/vector/theme_gd.dat