aboutsummaryrefslogtreecommitdiff
path: root/games/endless-sky
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 11:43:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 11:43:46 +0000
commitc44dbdddff3baa74c3501074c98f31eaf17e5242 (patch)
treed1ba4f0ccc3137351e22440c790a02c2fa9f323c /games/endless-sky
parent4299b1130a7fbe85430758a93541da868b44f82b (diff)
downloadports-c44dbdddff3baa74c3501074c98f31eaf17e5242.tar.gz
ports-c44dbdddff3baa74c3501074c98f31eaf17e5242.zip
- Update to 0.9.2
Notes
Notes: svn path=/head/; revision=421686
Diffstat (limited to 'games/endless-sky')
-rw-r--r--games/endless-sky/Makefile2
-rw-r--r--games/endless-sky/distinfo5
-rw-r--r--games/endless-sky/files/patch-SConstruct44
3 files changed, 26 insertions, 25 deletions
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
index b99cedbda8a2..cf22f547e019 100644
--- a/games/endless-sky/Makefile
+++ b/games/endless-sky/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= endless-sky
-PORTVERSION= 0.8.11
+PORTVERSION= 0.9.2
DISTVERSIONPREFIX= v
CATEGORIES= games
diff --git a/games/endless-sky/distinfo b/games/endless-sky/distinfo
index c31ad5c5e14e..4841e88cfea5 100644
--- a/games/endless-sky/distinfo
+++ b/games/endless-sky/distinfo
@@ -1,2 +1,3 @@
-SHA256 (endless-sky-endless-sky-v0.8.11_GH0.tar.gz) = 8c399194b5d118274f43685b9992419538e5e6c6161621e5b06aef9ca74c4718
-SIZE (endless-sky-endless-sky-v0.8.11_GH0.tar.gz) = 42620910
+TIMESTAMP = 1473431842
+SHA256 (endless-sky-endless-sky-v0.9.2_GH0.tar.gz) = aebf56be47448e8c29fd298b4e7124afc19c1078c9b5972f1f599e9957d79822
+SIZE (endless-sky-endless-sky-v0.9.2_GH0.tar.gz) = 54218591
diff --git a/games/endless-sky/files/patch-SConstruct b/games/endless-sky/files/patch-SConstruct
index 0db26d26c813..75f4699a00b3 100644
--- a/games/endless-sky/files/patch-SConstruct
+++ b/games/endless-sky/files/patch-SConstruct
@@ -1,24 +1,24 @@
---- SConstruct.orig 2015-10-06 21:52:04 UTC
+--- SConstruct.orig 2016-06-24 12:15:47 UTC
+++ SConstruct
-@@ -14,7 +14,7 @@ if 'SCHROOT_CHROOT_NAME' in os.environ a
-
- # Required build flags. If you want to use SSE optimization, you can turn on
- # -msse3 or (if just building for your own computer) -march=native.
--env.Append(CCFLAGS = ["-std=c++0x", "-O3", "-Wall"])
-+env.Append(CCFLAGS = ["-std=c++0x", "-Wall"])
- env.Append(LIBS = [
- "SDL2",
- "png",
-@@ -28,7 +28,7 @@ env.Append(LIBS = [
- # Work with clang's static analyzer:
- env["CC"] = os.getenv("CC") or env["CC"]
- env["CXX"] = os.getenv("CXX") or env["CXX"]
--env["ENV"].update(x for x in os.environ.items() if x[0].startswith("CCC_"))
-+env["ENV"].update(x for x in os.environ.items())
-
- opts = Variables()
- opts.Add(PathVariable("PREFIX", "Directory to install under", "/usr/local", PathVariable.PathIsDirCreate))
-@@ -43,7 +43,7 @@ sky = env.Program("endless-sky", Glob("b
+@@ -1,7 +1,7 @@
+ import os
+
+ # Load any environment variables that alter the build.
+-env = Environment()
++env = Environment(ENV = os.environ)
+ if 'CCFLAGS' in os.environ:
+ env.Append(CCFLAGS = os.environ['CCFLAGS'])
+ if 'CXXFLAGS' in os.environ:
+@@ -24,7 +24,7 @@ Help(opts.GenerateHelpText(env))
+
+ flags = ["-std=c++11", "-Wall"]
+ if env["mode"] != "debug":
+- flags += ["-O3"]
++ pass
+ if env["mode"] == "debug":
+ flags += ["-g"]
+ if env["mode"] == "profile":
+@@ -55,7 +55,7 @@ sky = env.Program("endless-sky", Glob("b
# Install the binary:
@@ -27,7 +27,7 @@
# Install the desktop file:
env.Install("$DESTDIR$PREFIX/share/applications", "endless-sky.desktop")
-@@ -68,7 +68,7 @@ if env.get("PREFIX").startswith("/usr/")
+@@ -80,7 +80,7 @@ if env.get("PREFIX").startswith("/usr/")
# Install the man page.
env.Command(
@@ -36,7 +36,7 @@
"endless-sky.6",
"gzip -c $SOURCE > $TARGET")
-@@ -81,11 +81,11 @@ def RecursiveInstall(env, target, source
+@@ -93,11 +93,11 @@ def RecursiveInstall(env, target, source
RecursiveInstall(env, os.path.join(target, name), node.abspath)
else:
env.Install(target, node)