aboutsummaryrefslogtreecommitdiff
path: root/games/enigma
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/enigma
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/enigma')
-rw-r--r--games/enigma/Makefile7
-rw-r--r--games/enigma/files/patch-src_enigma-core_IMG_SavePNG.c33
2 files changed, 37 insertions, 3 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 675c9c017103..a9f76c103d83 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -7,7 +7,7 @@
PORTNAME= enigma
PORTVERSION= 1.01
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= BERLIOS/enigma-game
DISTNAME= ${PORTNAME}-${PORTVERSION}-64bit
@@ -15,7 +15,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-64bit
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
+ png15:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${LOCALBASE}/lib/libenet.a:${PORTSDIR}/net/enet
USE_GMAKE= yes
@@ -26,7 +27,7 @@ USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-cxxlua \
--with-libintl-prefix="${LOCALBASE}"
-CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 -I${LUA_INCDIR}
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
MAKE_JOBS_SAFE= yes
diff --git a/games/enigma/files/patch-src_enigma-core_IMG_SavePNG.c b/games/enigma/files/patch-src_enigma-core_IMG_SavePNG.c
new file mode 100644
index 000000000000..925b9655d5e9
--- /dev/null
+++ b/games/enigma/files/patch-src_enigma-core_IMG_SavePNG.c
@@ -0,0 +1,33 @@
+--- lib-src/enigma-core/IMG_SavePNG.c.orig 2007-09-08 14:20:05.000000000 +0200
++++ lib-src/enigma-core/IMG_SavePNG.c 2012-05-11 17:55:39.000000000 +0200
+@@ -1,13 +1,14 @@
+ #include "SDL.h"
+ #include "IMG_SavePNG.h"
+ #include "png.h"
++#include "pngpriv.h"
+ #include <stdlib.h>
+ #include <setjmp.h>
+
+ #define IMG_SetError(a) SDL_SetError(a)
+
+ /* Save a PNG type image to an SDL datasource */
+-static void png_write_data(png_structp ctx, png_bytep area, png_size_t size)
++static void local_png_write_data(png_structp ctx, png_bytep area, png_size_t size)
+ {
+ SDL_RWops *src;
+
+@@ -84,12 +85,12 @@
+ png_bytep *row_pointers = 0;
+
+ /* Set error handling. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_ptr->longjmp_buffer)) {
+ IMG_SetError("Error writing the PNG file");
+ }
+ else {
+ int colortype;
+- png_set_write_fn(png_ptr, src, png_write_data, png_io_flush);
++ png_set_write_fn(png_ptr, src, local_png_write_data, png_io_flush);
+ /* Set the image information here. Width and height are up to 2^31,
+ * bit_depth is one of 1, 2, 4, 8, or 16, but valid values also depend on
+ * the color_type selected. color_type is one of PNG_COLOR_TYPE_GRAY,