aboutsummaryrefslogtreecommitdiff
path: root/games/epiar
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-17 03:25:10 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-17 03:25:10 +0000
commitfeb844a02bf6290e37618862119a2059f34d3746 (patch)
treedc8638cb16e91c3e1102cc0c59bc9ebdd432f8eb /games/epiar
parent5233271cefa1abc007720fc62987cf291764338b (diff)
downloadports-feb844a02bf6290e37618862119a2059f34d3746.tar.gz
ports-feb844a02bf6290e37618862119a2059f34d3746.zip
Notes
Diffstat (limited to 'games/epiar')
-rw-r--r--games/epiar/Makefile17
-rw-r--r--games/epiar/distinfo4
-rw-r--r--games/epiar/pkg-descr1
-rw-r--r--games/epiar/pkg-plist15
4 files changed, 21 insertions, 16 deletions
diff --git a/games/epiar/Makefile b/games/epiar/Makefile
index 0af449be4332..1f72792b09cb 100644
--- a/games/epiar/Makefile
+++ b/games/epiar/Makefile
@@ -1,10 +1,10 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= epiar
-PORTVERSION= 0.5.0
+PORTVERSION= 0.5.1
CATEGORIES= games
-MASTER_SITES= http://epiar.net/files/epiar/releases/${PORTVERSION}/
+MASTER_SITES= http://epiar.net/files/epiar/releases/0.5/
MAINTAINER= nemysis@gmx.ch
COMMENT= Space trading/exploring sim with RPG elements
@@ -20,30 +20,33 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
xml2:${PORTSDIR}/textproc/libxml2 \
physfs:${PORTSDIR}/devel/physfs
-PORTSCOUT= skipv:0.5.1
-
USE_BZIP2= yes
USE_SDL= image mixer sdl
USE_GL= glu
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal
USE_GMAKE= yes
+USE_GNOME= desktopfileutils
USE_PKGCONFIG= build
+MAKE_JOBS_SAFE= yes
PORTDOCS= AUTHORS ChangeLog README
pre-configure:
+ @${REINPLACE_CMD} -e 's|9.22|2.4|' ${WRKSRC}/configure.in
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
.include <bsd.port.options.mk>
post-install:
- ${MKDIR} ${PREFIX}/share/applications
+ @${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+ @-update-desktop-database -q
+
.include <bsd.port.mk>
diff --git a/games/epiar/distinfo b/games/epiar/distinfo
index 09def86e5b2f..9ec004015f8f 100644
--- a/games/epiar/distinfo
+++ b/games/epiar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (epiar-0.5.0.tar.bz2) = 20e4834b7397af83a7be79c76c158c534ffd9693f17b897c272797a69b59ed47
-SIZE (epiar-0.5.0.tar.bz2) = 26584570
+SHA256 (epiar-0.5.1.tar.bz2) = d2ef0dc7cf841a33258683a98b24f8a6c27dc53458190372097827fcf352b072
+SIZE (epiar-0.5.1.tar.bz2) = 26291752
diff --git a/games/epiar/pkg-descr b/games/epiar/pkg-descr
index a919e169a1c6..df07008a2531 100644
--- a/games/epiar/pkg-descr
+++ b/games/epiar/pkg-descr
@@ -15,3 +15,4 @@ Other notable games of this genre include:
- Solar Winds
WWW: http://epiar.net/
+WWW: https://github.com/knowknowledge/Epiar/
diff --git a/games/epiar/pkg-plist b/games/epiar/pkg-plist
index f3416eaa306d..929e36ea68b1 100644
--- a/games/epiar/pkg-plist
+++ b/games/epiar/pkg-plist
@@ -23,17 +23,16 @@ share/applications/epiar.desktop
%%DATADIR%%/Resources/Audio/Interface/28853__junggle__btn043.ogg
%%DATADIR%%/Resources/Audio/Music/beyond_the_network.it
%%DATADIR%%/Resources/Audio/Music/cyberm00n.mod
-%%DATADIR%%/Resources/Audio/Weapons/18397__inferno__smalllas.ogg
-%%DATADIR%%/Resources/Audio/Weapons/32954__HardPCM__Chip054.wav.ogg
-%%DATADIR%%/Resources/Audio/Weapons/36847__EcoDTR__LaserRocket2.ogg
-%%DATADIR%%/Resources/Audio/Weapons/goldbeam.ogg
-%%DATADIR%%/Resources/Audio/Weapons/laser.ogg
-%%DATADIR%%/Resources/Fonts/FreeMono.ttf
+%%DATADIR%%/Resources/Audio/Weapons/flaunch.ogg
+%%DATADIR%%/Resources/Audio/Weapons/iceball.ogg
+%%DATADIR%%/Resources/Audio/Weapons/rlaunch.ogg
+%%DATADIR%%/Resources/Audio/Weapons/slimeball.ogg
+%%DATADIR%%/Resources/Fonts/Alfphabet-IV.ttf
+%%DATADIR%%/Resources/Fonts/ConsolaMono.ttf
%%DATADIR%%/Resources/Fonts/FreeSans.ttf
%%DATADIR%%/Resources/Fonts/FreeSerif.ttf
%%DATADIR%%/Resources/Fonts/usuziv2.ttf
%%DATADIR%%/Resources/Fonts/usuzv2i.ttf
-%%DATADIR%%/Resources/Fonts/visitor1.ttf
%%DATADIR%%/Resources/Fonts/visitor2.ttf
%%DATADIR%%/Resources/Graphics/Epiar_Icon.png
%%DATADIR%%/Resources/Graphics/Epiar_Icon2.png
@@ -244,3 +243,5 @@ share/pixmaps/epiar.png
@dirrm %%DATADIR%%/Resources
@dirrm %%DATADIR%%
@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database -q || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database -q || /usr/bin/true