aboutsummaryrefslogtreecommitdiff
path: root/games/etracer
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-02-10 11:42:31 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-02-10 11:42:31 +0000
commite2b51bc6e0675cfb18d4bfba629786d262b56aaf (patch)
tree8b27a7410731d4ba0a4e1625b4c207ea78a1b2ed /games/etracer
parent0fab8da464899403d6e2e913ea24dc3f22002b3d (diff)
- switch to USE_TCL infrastructure
- add support for tcl84 and tcl85 - bump PORTREVISION PR: ports/130190 Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=227980
Diffstat (limited to 'games/etracer')
-rw-r--r--games/etracer/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/games/etracer/Makefile b/games/etracer/Makefile
index 4ee2b16c6b98..a74add3c28f2 100644
--- a/games/etracer/Makefile
+++ b/games/etracer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= etracer
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/extremetuxracer
DISTNAME= extremetuxracer-${PORTVERSION}
@@ -15,17 +15,20 @@ DISTNAME= extremetuxracer-${PORTVERSION}
MAINTAINER= peter_dunning@dsl.pipex.com
COMMENT= The latest and greatest fork of the classic Tux Racer
-LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
- png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= mixer sdl
USE_GL= gl glu glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.5 \
- --with-tcl-inc=${PREFIX}/include/tcl8.5 \
+
+USE_TCL= 84+
+
+.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --with-tcl="${TCL_LIBDIR}" \
+ --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-gl-libs="${LOCALBASE}/lib" \
--with-gl-inc="${LOCALBASE}/include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>