aboutsummaryrefslogtreecommitdiff
path: root/games/excido
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-01 13:18:26 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-01 13:18:26 +0000
commitf888cd60a13aaa3694c7930b9a96bb93f515cec5 (patch)
treed7f1f798e3210f42850bf17ba95bbae7fa06728f /games/excido
parentaa4ca9264d60a982fc942d207e2a3de0d2e6581b (diff)
downloadports-f888cd60a13aaa3694c7930b9a96bb93f515cec5.tar.gz
ports-f888cd60a13aaa3694c7930b9a96bb93f515cec5.zip
- Add stage support
- Convert LIB_DEPENDS to new syntax - Convert USE_GMAKE to USES
Notes
Notes: svn path=/head/; revision=332367
Diffstat (limited to 'games/excido')
-rw-r--r--games/excido/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/games/excido/Makefile b/games/excido/Makefile
index a6b1f67efff4..1d7942b79645 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -15,7 +15,7 @@ COMMENT= Portable fast-paced 3D shooter
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -23,13 +23,15 @@ USE_BZIP2= yes
USE_GL= yes
USE_SDL= image sdl ttf
USE_OPENAL= al alut
-USE_GMAKE= yes
-
-NO_STAGE= yes
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+USES= gmake
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/excido ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/data ; ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>