aboutsummaryrefslogtreecommitdiff
path: root/games/exult
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2022-09-03 12:17:07 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-09-03 14:26:45 +0000
commit9d4bc59908d56de5fe4c5165f483c2d794ca9779 (patch)
tree80ae6b9460d57ff394b9b2720fa4bec55c0a51dd /games/exult
parent3f13bdd463630c08626ee1eae13183651b03ad71 (diff)
downloadports-9d4bc59908d56de5fe4c5165f483c2d794ca9779.tar.gz
ports-9d4bc59908d56de5fe4c5165f483c2d794ca9779.zip
Diffstat (limited to 'games/exult')
-rw-r--r--games/exult/Makefile5
-rw-r--r--games/exult/files/patch-configure.ac11
-rw-r--r--games/exult/files/patch-mapedit_Makefile.am4
-rw-r--r--games/exult/files/patch-tools_Makefile.am4
-rw-r--r--games/exult/files/patch-version.cc11
5 files changed, 29 insertions, 6 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 14be42bdd8f6..7b581bdc9a17 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -1,5 +1,6 @@
PORTNAME= exult
DISTVERSION?= 1.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= games
@@ -28,8 +29,8 @@ CONFIGURE_ARGS= --disable-static \
--with-icondir=${PREFIX}/share/pixmaps
CONFLICTS_INSTALL= exult-devel
-SUB_FILES= pkg-message
-PLIST?= ${.CURDIR}/pkg-plist
+SUB_FILES= pkg-message
+PLIST?= ${.CURDIR}/pkg-plist
.if !defined(MASTERDIR)
MASTER_SITES= http://prdownloads.sourceforge.net/exult/
diff --git a/games/exult/files/patch-configure.ac b/games/exult/files/patch-configure.ac
new file mode 100644
index 000000000000..bda440166ff1
--- /dev/null
+++ b/games/exult/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2022-09-03 11:46:03 UTC
++++ configure.ac
+@@ -79,7 +79,7 @@ case "$host_os" in
+ ;;
+ freebsd* )
+ WINDOWING_SYSTEM="-DXWIN"
+- AC_DEFINE(NETBSD, 1, [Using NetBSD])
++ AC_DEFINE(FREEBSD, 1, [Using FreeBSD])
+ AC_MSG_RESULT([X11 (FreeBSD)])
+ CXXFLAGS="$CXXFLAGS -I/usr/local/include"
+ ;;
diff --git a/games/exult/files/patch-mapedit_Makefile.am b/games/exult/files/patch-mapedit_Makefile.am
index 41d91341084f..119c02a9df74 100644
--- a/games/exult/files/patch-mapedit_Makefile.am
+++ b/games/exult/files/patch-mapedit_Makefile.am
@@ -1,6 +1,6 @@
---- mapedit/Makefile.am.orig 2016-05-14 01:04:00 UTC
+--- mapedit/Makefile.am.orig 2022-04-12 16:34:45 UTC
+++ mapedit/Makefile.am
-@@ -92,8 +92,8 @@ EXTRA_DIST= \
+@@ -101,8 +101,8 @@ install-exec-local:
if GIMP_PLUGIN
install-exec-local:
diff --git a/games/exult/files/patch-tools_Makefile.am b/games/exult/files/patch-tools_Makefile.am
index 3ee110dcfe29..2416cc2caa8b 100644
--- a/games/exult/files/patch-tools_Makefile.am
+++ b/games/exult/files/patch-tools_Makefile.am
@@ -1,4 +1,4 @@
---- tools/Makefile.am.orig 2016-05-14 01:04:00 UTC
+--- tools/Makefile.am.orig 2022-04-12 16:34:45 UTC
+++ tools/Makefile.am
@@ -56,11 +56,11 @@ if BUILD_GTHUMB
## Does not work:
@@ -14,7 +14,7 @@
# Rule to make the service file with bindir expanded
$(thumbnailer_DATA): $(thumbnailer_in_files)
-@@ -99,10 +99,10 @@ cmanip_LDADD = \
+@@ -105,10 +105,10 @@ install-data-hook:
if BUILD_GTHUMB
install-data-hook:
diff --git a/games/exult/files/patch-version.cc b/games/exult/files/patch-version.cc
new file mode 100644
index 000000000000..c48ff501c171
--- /dev/null
+++ b/games/exult/files/patch-version.cc
@@ -0,0 +1,11 @@
+--- version.cc.orig 2022-09-03 11:51:13 UTC
++++ version.cc
+@@ -210,6 +210,8 @@ void getVersionInfo(std::ostream &out) {
+
+ out << " Version " << info.dwMajorVersion << "." << info.dwMinorVersion << " Build " << LOWORD(info.dwBuildNumber & 0xFFFF);
+ }
++#elif (defined(FREEBSD))
++ out << "FreeBSD";
+ #elif (defined(MACOSX))
+ out << "Mac OS X";
+ #elif (defined(__IPHONEOS__))