aboutsummaryrefslogtreecommitdiff
path: root/games/falconseye
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-13 17:11:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-13 17:11:21 +0000
commit1cc13b8fa26b1a65ba6ccaa3e648290204f5fdaa (patch)
tree393b391690754f9b636a2e1e9ac4f390b1b6b599 /games/falconseye
parent2cac5c0993d9e354e7d0c13412c09d27527172dd (diff)
downloadports-1cc13b8fa26b1a65ba6ccaa3e648290204f5fdaa.tar.gz
ports-1cc13b8fa26b1a65ba6ccaa3e648290204f5fdaa.zip
Add staging support
Notes
Notes: svn path=/head/; revision=351231
Diffstat (limited to 'games/falconseye')
-rw-r--r--games/falconseye/Makefile11
-rw-r--r--games/falconseye/files/patch-sys_unix_Makefile_top36
-rw-r--r--games/falconseye/pkg-plist6
3 files changed, 19 insertions, 34 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 417a4aa5a10b..0e06a2e7bc70 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -25,7 +25,6 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11
NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
${WRKSRC}/include/jtp_gen.h ${WRKSRC}/win/jtp/jtp_dirx.c \
@@ -41,10 +40,10 @@ post-build:
@cd ${WRKSRC}/doc && ${PERL} -p ${FILESDIR}/substitute <recover.6 >frecover.6
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/util/recover ${PREFIX}/bin/frecover
- @cd ${WRKSRC}/doc && \
- ${INSTALL_MAN} recover.6 ${PREFIX}/man/man6/frecover.6
- @cd ${WRKSRC}/doc && \
- ${INSTALL_MAN} nethack.6 ${PREFIX}/man/man6/falconseye.6
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/recover ${STAGEDIR}${PREFIX}/bin/frecover
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} recover.6 \
+ ${STAGEDIR}${PREFIX}/man/man6/frecover.6
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} nethack.6 \
+ ${STAGEDIR}${PREFIX}/man/man6/falconseye.6
.include <bsd.port.mk>
diff --git a/games/falconseye/files/patch-sys_unix_Makefile_top b/games/falconseye/files/patch-sys_unix_Makefile_top
index 86ca4d060f74..1a1585904fc8 100644
--- a/games/falconseye/files/patch-sys_unix_Makefile_top
+++ b/games/falconseye/files/patch-sys_unix_Makefile_top
@@ -1,6 +1,6 @@
---- sys/unix/Makefile.top.orig Sun Jun 24 18:57:24 2001
-+++ sys/unix/Makefile.top Fri Aug 24 03:27:56 2001
-@@ -15,18 +15,17 @@
+--- sys/unix/Makefile.top.orig 2001-06-24 18:57:24.000000000 +0200
++++ sys/unix/Makefile.top 2014-04-13 18:56:38.000000000 +0200
+@@ -15,11 +15,10 @@
# make NetHack
#PREFIX = /usr
@@ -15,16 +15,6 @@
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
--GAMEPERM = 04755
--FILEPERM = 0644
-+GAMEPERM = 02755
-+FILEPERM = 0664
- EXEPERM = 0755
--DIRPERM = 0755
-+DIRPERM = 0775
-
- # GAMEDIR also appears in config.h as "HACKDIR".
- # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
@@ -36,12 +35,13 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
@@ -42,17 +32,15 @@
# VARDATND = x11tiles pet_mark.xbm
# VARDATND = x11tiles pet_mark.xbm rip.xpm
# for Atari/Gem
-@@ -67,8 +67,8 @@
- # will only work if setuid (or setgid) behavior is not desired or required.
- # CHOWN = chown
- # CHGRP = chgrp
--CHOWN = true
--CHGRP = true
-+CHOWN = chown
-+CHGRP = chgrp
-
- # ----------------------------------------------
- # Extra configuration for NetHack - Falcon's Eye
+@@ -78,7 +78,7 @@
+ # in order to e.g. access the Xlib server. In particular, we need to
+ # setgid instead of setuid. Therefore we must also allow group writing
+ # for the files and directories.
+-GAMEPERM = 02755
++GAMEPERM = 02555
+ FILEPERM = 0664
+ EXEPERM = 0755
+ DIRPERM = 0775
@@ -119,12 +119,15 @@
$(GAME):
( cd src ; $(MAKE) )
diff --git a/games/falconseye/pkg-plist b/games/falconseye/pkg-plist
index 904dae4cb0fa..b11d0ac360c0 100644
--- a/games/falconseye/pkg-plist
+++ b/games/falconseye/pkg-plist
@@ -256,11 +256,9 @@ share/falconseyedir/wizard1.lev
share/falconseyedir/wizard2.lev
share/falconseyedir/wizard3.lev
share/falconseyedir/wizhelp
-man/man6/falconseye.6
-man/man6/frecover.6
-@mode 2555
+man/man6/falconseye.6.gz
+man/man6/frecover.6.gz
share/falconseyedir/falconseye
-@exec chmod 775 %B
@exec install -g games -m 0664 /dev/null %B/logfile
@exec install -g games -m 0664 /dev/null %B/perm
@exec install -g games -m 0664 /dev/null %B/record