aboutsummaryrefslogtreecommitdiff
path: root/games/fbg2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:42:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:42:31 +0000
commit9ba58143d17033e127be7c211e8e8735e5c28cc7 (patch)
tree41a4df5514b06224c84250cc0d791e6b3ac26233 /games/fbg2
parente928906ee4b5e730fa968e07efcd6320407ac36f (diff)
downloadports-9ba58143d17033e127be7c211e8e8735e5c28cc7.tar.gz
ports-9ba58143d17033e127be7c211e8e8735e5c28cc7.zip
Falling Block Game is a free, open source block stacking game available for
Windows and Linux. The object of the game is to move and rotate pieces in order to fill in complete rows. The more rows you clear at once, the more points you score! WWW: http://fbg.sourceforge.net/ PR: ports/168086 Submitted by: nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=296884
Diffstat (limited to 'games/fbg2')
-rw-r--r--games/fbg2/Makefile49
-rw-r--r--games/fbg2/distinfo2
-rw-r--r--games/fbg2/pkg-descr6
3 files changed, 57 insertions, 0 deletions
diff --git a/games/fbg2/Makefile b/games/fbg2/Makefile
new file mode 100644
index 000000000000..1d2c00da0115
--- /dev/null
+++ b/games/fbg2/Makefile
@@ -0,0 +1,49 @@
+# New Ports collection makefile for: Falling Block Game
+# Date created: 2012-05-18
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbg2
+PORTVERSION= 0.4
+CATEGORIES= games
+MASTER_SITES= SF/fbg/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Classic block-stacking arcade game
+
+LICENSE= GPLv2 CCbyNCSA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
+LICENSE_FILE= ${WRKSRC}/License.txt
+LICENSE_FILE_CCbyNCSA3=${WRKSRC}/License.txt
+LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+
+LIB_DEPENDS= radius:${PORTSDIR}/graphics/radius-engine \
+ lua-5.1:${PORTSDIR}/lang/lua \
+ png:${PORTSDIR}/graphics/png \
+ physfs.1:${PORTSDIR}/devel/physfs
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
+USE_SDL= sdl sound
+USE_GL= glu
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/applications
+
+PORTDATA= *
+PORTDOCS= ChangeLog
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/fbg2/distinfo b/games/fbg2/distinfo
new file mode 100644
index 000000000000..44421c2b99aa
--- /dev/null
+++ b/games/fbg2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fbg2-0.4.tar.gz) = 028c2f93866a178585d6374b6647ee3cb18df1d41b5c4b89b2106c166f00e41c
+SIZE (fbg2-0.4.tar.gz) = 3998693
diff --git a/games/fbg2/pkg-descr b/games/fbg2/pkg-descr
new file mode 100644
index 000000000000..92914e552379
--- /dev/null
+++ b/games/fbg2/pkg-descr
@@ -0,0 +1,6 @@
+Falling Block Game is a free, open source block stacking game available for
+Windows and Linux. The object of the game is to move and rotate pieces in order
+to fill in complete rows. The more rows you clear at once,
+the more points you score!
+
+WWW: http://fbg.sourceforge.net/