aboutsummaryrefslogtreecommitdiff
path: root/games/fgfs-base
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-06 06:20:22 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-06 06:20:22 +0000
commitf3171de7e6077f2297972e5effe08badee1e36f3 (patch)
tree913ef58fa0265a980c478b7264d71951bec76466 /games/fgfs-base
parent22a1ed809c6346fd2acc2e522d98aa1b8f8aa92c (diff)
downloadports-f3171de7e6077f2297972e5effe08badee1e36f3.tar.gz
ports-f3171de7e6077f2297972e5effe08badee1e36f3.zip
Notes
Diffstat (limited to 'games/fgfs-base')
-rw-r--r--games/fgfs-base/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
index 4409885d99b2..a70555288268 100644
--- a/games/fgfs-base/Makefile
+++ b/games/fgfs-base/Makefile
@@ -39,11 +39,13 @@ pre-configure:
.else
PLIST= ${MASTERDIR}/pkg-plist.notools
ADDPATCHES= ${MASTERDIR}/patches.tools/disable-tools
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER=213
.endif
USE_NEWGCC= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lGLU -lGL -lglut ${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--bindir=${PREFIX}/FlightGear/bin
USE_GMAKE= yes
@@ -54,6 +56,8 @@ pre-patch:
done )
post-configure:
+ @find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
+ "s@#include.*<malloc.h>@#include <stdlib.h>@g"
@(cd ${WRKSRC};touch Makefile.in */Makefile.in */*/Makefile.in \
*/*/*/Makefile.in; \
./config.status)