aboutsummaryrefslogtreecommitdiff
path: root/games/fillets-ng
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-25 22:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-25 22:46:51 +0000
commitd27718733dea4f7ecb0df46665ecddf8e4b3b136 (patch)
tree3826060947cc1ab7eaf6f683e8d164a6000f3122 /games/fillets-ng
parent6cf8700f3378a5fc98ae3b92fd35fffcce37a28c (diff)
downloadports-d27718733dea4f7ecb0df46665ecddf8e4b3b136.tar.gz
ports-d27718733dea4f7ecb0df46665ecddf8e4b3b136.zip
- Update to 0.9.3
Notes
Notes: svn path=/head/; revision=255090
Diffstat (limited to 'games/fillets-ng')
-rw-r--r--games/fillets-ng/Makefile5
-rw-r--r--games/fillets-ng/distinfo12
-rw-r--r--games/fillets-ng/files/patch-src_effect_Font.cpp20
3 files changed, 8 insertions, 29 deletions
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index 499536b07b1b..e176eefa3b70 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fillets-ng
-PORTVERSION= 0.9.2
-PORTREVISION= 3
+PORTVERSION= 0.9.3
CATEGORIES= games
MASTER_SITES= SF/fillets/Fish%20Fillets%20-%20Next%20Generation/${PORTVERSION}:source \
SF/fillets/Fish%20Fillets%20-%20Next%20Generation/${DATAVERSION}:data
@@ -26,7 +25,7 @@ CONFIGURE_ARGS= --datadir="${DATADIR}" --with-lua="${LOCALBASE}"
MAKE_JOBS_SAFE= yes
PORTDOCS= *
-DATAVERSION= 0.9.0
+DATAVERSION= 0.9.2
ONLY_FOR_ARCHS= i386 amd64
diff --git a/games/fillets-ng/distinfo b/games/fillets-ng/distinfo
index 29f1ba77c57c..91a67029510b 100644
--- a/games/fillets-ng/distinfo
+++ b/games/fillets-ng/distinfo
@@ -1,6 +1,6 @@
-MD5 (fillets-ng-0.9.2.tar.gz) = 24578ad842a242439b893ad949556c28
-SHA256 (fillets-ng-0.9.2.tar.gz) = 8e9c3a5104bd435eb2db4e78fd966f97d301266e0a9bfb79395e8db5804aacd4
-SIZE (fillets-ng-0.9.2.tar.gz) = 367136
-MD5 (fillets-ng-data-0.9.0.tar.gz) = 5d733a990212a4b038d1ee76f700c54e
-SHA256 (fillets-ng-data-0.9.0.tar.gz) = c40a907e1ac1db09fc120f8373adbfe363f6e5c7c91bc9d669f218c70ae4a42b
-SIZE (fillets-ng-data-0.9.0.tar.gz) = 113063946
+MD5 (fillets-ng-0.9.3.tar.gz) = 292555608dd0f24d7bb3a072ab0f7ea5
+SHA256 (fillets-ng-0.9.3.tar.gz) = 213fec9f7c223ee76922d1cc4991d55d9f78f2dc2cf3201f37fdccb147db184f
+SIZE (fillets-ng-0.9.3.tar.gz) = 381008
+MD5 (fillets-ng-data-0.9.2.tar.gz) = 00ea835425e5b1ca9fc3f110b40ff581
+SHA256 (fillets-ng-data-0.9.2.tar.gz) = d6da53e0fb1dda40276a2c1a92905b9e4028726fc45c2293c2800d37cd082e53
+SIZE (fillets-ng-data-0.9.2.tar.gz) = 113066821
diff --git a/games/fillets-ng/files/patch-src_effect_Font.cpp b/games/fillets-ng/files/patch-src_effect_Font.cpp
deleted file mode 100644
index 637a4642ea35..000000000000
--- a/games/fillets-ng/files/patch-src_effect_Font.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/effect/Font.cpp.orig 2009-08-23 13:13:38.000000000 -0400
-+++ src/effect/Font.cpp 2009-08-23 13:14:57.000000000 -0400
-@@ -26,7 +26,7 @@ Font::biditize(const std::string &text)
- FriBidiChar *logicalString = new FriBidiChar[text.length() + 1];
- FriBidiChar *visualString = new FriBidiChar[text.length() + 1];
-
-- int ucsLength = fribidi_utf8_to_unicode(const_cast<char*>(text.c_str()),
-+ int ucsLength = fribidi_charset_to_unicode(FRIBIDI_CHAR_SET_UTF8, const_cast<char*>(text.c_str()),
- text.length(), logicalString);
- fribidi_boolean ok = fribidi_log2vis(logicalString, ucsLength, &base,
- visualString, NULL, NULL, NULL);
-@@ -37,7 +37,7 @@ Font::biditize(const std::string &text)
- }
-
- char *buffer = new char[text.length() + 1];
-- int length = fribidi_unicode_to_utf8(visualString, ucsLength, buffer);
-+ int length = fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8, visualString, ucsLength, buffer);
- std::string result = std::string(buffer, length);
- delete[] buffer;
- delete[] visualString;