aboutsummaryrefslogtreecommitdiff
path: root/games/filters/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-28 12:13:18 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-28 12:13:18 +0000
commitd84f1558325387ae1408e27497719878e4f15b3d (patch)
treec57c8ea473c6d6ff4fb451c3e597be05648ef70f /games/filters/Makefile
parent8f278ee21c4bed0cc9442a8d3d10235e78e7a183 (diff)
Notes
Diffstat (limited to 'games/filters/Makefile')
-rw-r--r--games/filters/Makefile36
1 files changed, 4 insertions, 32 deletions
diff --git a/games/filters/Makefile b/games/filters/Makefile
index 619edce6ab58..3e72e0a99b60 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -27,44 +27,16 @@ CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify \
SHEBANG_FILES= ${PERLFILTERS}
-MAN1= filters.1
-MLINKS= filters.1 b1ff.1 \
- filters.1 censor.1 \
- filters.1 chef.1 \
- filters.1 eleet.1 \
- filters.1 fudd.1 \
- filters.1 jibberish.1 \
- filters.1 kenny.1 \
- filters.1 pirate.1 \
- filters.1 rasterman.1 \
- filters.1 spammer.1 \
- filters.1 studly.1 \
- filters.1 uniencode.1 \
- filters.1 upside-down.1 \
- filters.1 jethro.1 \
- filters.1 kraut.1 \
- filters.1 cockney.1 \
- filters.1 jive.1 \
- filters.1 nyc.1 \
- filters.1 ken.1 \
- filters.1 ky00te.1 \
- filters.1 newspeak.1 \
- filters.1 nethackify.1 \
- filters.1 fanboy.1 \
- filters.1 scottish.1 \
- filters.1 scramble.1
-
-NO_STAGE= yes
post-extract:
- @${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${MAN1}
+ @${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${PORTNAME}.1
do-install:
.for f in ${CFILTERS}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
.for f in ${PERLFILTERS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>