aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-03 17:15:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-03 17:15:25 +0000
commit97d9539bf5c713eca7290e18aef8458d69c95c1a (patch)
tree60baa01155ae145ba4226c886037cd22a2dbb78d /games/flightgear
parentb8aad619fdb220318a21abec83a1132005bb72df (diff)
downloadports-97d9539bf5c713eca7290e18aef8458d69c95c1a.tar.gz
ports-97d9539bf5c713eca7290e18aef8458d69c95c1a.zip
Notes
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile1
-rw-r--r--games/flightgear/files/patch-src_Main_bootstrap.cxx20
2 files changed, 21 insertions, 0 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index eb3edcda140f..4396c0964def 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,6 +7,7 @@
PORTNAME= FlightGear
PORTVERSION= 0.9.8
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
ftp://ftp.de.flightgear.org/pub/fgfs/Source/
diff --git a/games/flightgear/files/patch-src_Main_bootstrap.cxx b/games/flightgear/files/patch-src_Main_bootstrap.cxx
new file mode 100644
index 000000000000..f805515f1eb0
--- /dev/null
+++ b/games/flightgear/files/patch-src_Main_bootstrap.cxx
@@ -0,0 +1,20 @@
+--- src/Main/bootstrap.cxx.orig Thu Sep 15 20:48:39 2005
++++ src/Main/bootstrap.cxx Thu Sep 15 20:51:05 2005
+@@ -28,6 +28,8 @@
+ #if defined(__linux__) && defined(__i386__)
+ # include <fpu_control.h>
+ # include <signal.h>
++#elif defined(__FreeBSD__)
++# include <signal.h>
+ #endif
+
+ #include <stdlib.h>
+@@ -144,6 +146,8 @@
+ // Enable floating-point exceptions for Linux/x86
+ #if defined(__linux__) && defined(__i386__)
+ initFPE();
++#elif defined(__FreeBSD__)
++ signal(SIGFPE, SIG_IGN);
+ #endif
+
+ #if defined(sgi)