aboutsummaryrefslogtreecommitdiff
path: root/games/flyhard
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-16 23:57:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-16 23:57:42 +0000
commit2679428680a1b890a752dedcdd62f26debbfb334 (patch)
tree8bb5da85242eb247a9fc214e4fc9e2c514fae99c /games/flyhard
parentca145175f439fee8c8b5b9f92cbb604445fc0d0a (diff)
downloadports-2679428680a1b890a752dedcdd62f26debbfb334.tar.gz
ports-2679428680a1b890a752dedcdd62f26debbfb334.zip
This is a game similar to Thrust - you pick things up with your
ship, carry them off, and drop them somewhere. Exactly why this needs to be done is not well explained. Features realistic(ish) physics: Explosions toss things around, some weapons knock enemies back, and of course gravity is a constant companion. Improved weapons are available to replace the pathetic peashooter that the player starts out with. WWW: http://www.markboyd.me.uk/games/flyhard/flyhard.html PR: ports/107929 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=182551
Diffstat (limited to 'games/flyhard')
-rw-r--r--games/flyhard/Makefile38
-rw-r--r--games/flyhard/distinfo3
-rw-r--r--games/flyhard/pkg-descr10
-rw-r--r--games/flyhard/pkg-plist116
4 files changed, 167 insertions, 0 deletions
diff --git a/games/flyhard/Makefile b/games/flyhard/Makefile
new file mode 100644
index 000000000000..a3e072806d3d
--- /dev/null
+++ b/games/flyhard/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: flyhard
+# Date created: 15 Jan 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flyhard
+PORTVERSION= 0.3
+CATEGORIES= games
+MASTER_SITES= http://www.markboyd.me.uk/games/flyhard/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Game resembling Thrust, but with lots of shooting and puzzles
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer
+USE_GCC= 3.4+
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+PORTDOCS= README
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/flyhard/distinfo b/games/flyhard/distinfo
new file mode 100644
index 000000000000..2ef1c1c0c282
--- /dev/null
+++ b/games/flyhard/distinfo
@@ -0,0 +1,3 @@
+MD5 (flyhard-0.3.tar.gz) = 97a94d94b3f59d5dc56fa17a02fd1663
+SHA256 (flyhard-0.3.tar.gz) = 7cfcb41e006c34176e8dfec1362fd3ec572c25b5da20764a84c592ca99b4f5e5
+SIZE (flyhard-0.3.tar.gz) = 347139
diff --git a/games/flyhard/pkg-descr b/games/flyhard/pkg-descr
new file mode 100644
index 000000000000..6b902cacc587
--- /dev/null
+++ b/games/flyhard/pkg-descr
@@ -0,0 +1,10 @@
+This is a game similar to Thrust - you pick things up with your
+ship, carry them off, and drop them somewhere. Exactly why this
+needs to be done is not well explained.
+
+Features realistic(ish) physics: Explosions toss things around,
+some weapons knock enemies back, and of course gravity is a constant
+companion. Improved weapons are available to replace the pathetic
+peashooter that the player starts out with.
+
+WWW: http://www.markboyd.me.uk/games/flyhard/flyhard.html
diff --git a/games/flyhard/pkg-plist b/games/flyhard/pkg-plist
new file mode 100644
index 000000000000..b604acca2903
--- /dev/null
+++ b/games/flyhard/pkg-plist
@@ -0,0 +1,116 @@
+bin/flyhard
+%%DATADIR%%/images/baby_graldor.png
+%%DATADIR%%/images/ball.png
+%%DATADIR%%/images/block.png
+%%DATADIR%%/images/blockdiag_bl.png
+%%DATADIR%%/images/blockdiag_br.png
+%%DATADIR%%/images/blockdiag_tl.png
+%%DATADIR%%/images/blockdiag_tr.png
+%%DATADIR%%/images/blockexplo0.png
+%%DATADIR%%/images/blockexplo1.png
+%%DATADIR%%/images/blockexplo2.png
+%%DATADIR%%/images/blockexplo3.png
+%%DATADIR%%/images/bobbler.png
+%%DATADIR%%/images/buttond1.png
+%%DATADIR%%/images/buttond2.png
+%%DATADIR%%/images/buttond3.png
+%%DATADIR%%/images/buttonl1.png
+%%DATADIR%%/images/buttonl2.png
+%%DATADIR%%/images/buttonl3.png
+%%DATADIR%%/images/buttonr1.png
+%%DATADIR%%/images/buttonr2.png
+%%DATADIR%%/images/buttonr3.png
+%%DATADIR%%/images/buttonu1.png
+%%DATADIR%%/images/buttonu2.png
+%%DATADIR%%/images/buttonu3.png
+%%DATADIR%%/images/coin.png
+%%DATADIR%%/images/engine_point.png
+%%DATADIR%%/images/font.png
+%%DATADIR%%/images/graldor0.png
+%%DATADIR%%/images/graldor1.png
+%%DATADIR%%/images/graldor2.png
+%%DATADIR%%/images/graldor3.png
+%%DATADIR%%/images/graldor4.png
+%%DATADIR%%/images/graldor5.png
+%%DATADIR%%/images/graldor6.png
+%%DATADIR%%/images/graldor7.png
+%%DATADIR%%/images/graldor8.png
+%%DATADIR%%/images/graldor9.png
+%%DATADIR%%/images/hgate1.png
+%%DATADIR%%/images/hgate2.png
+%%DATADIR%%/images/hgate3.png
+%%DATADIR%%/images/hgate4.png
+%%DATADIR%%/images/hgate5.png
+%%DATADIR%%/images/hgateclosed.png
+%%DATADIR%%/images/hgateopen.png
+%%DATADIR%%/images/invader1.png
+%%DATADIR%%/images/invader2.png
+%%DATADIR%%/images/miner.png
+%%DATADIR%%/images/peashooter.png
+%%DATADIR%%/images/pipe_+.png
+%%DATADIR%%/images/pipe_Td.png
+%%DATADIR%%/images/pipe_Tl.png
+%%DATADIR%%/images/pipe_Tr.png
+%%DATADIR%%/images/pipe_Tu.png
+%%DATADIR%%/images/pipe_ld.png
+%%DATADIR%%/images/pipe_lr.png
+%%DATADIR%%/images/pipe_lu.png
+%%DATADIR%%/images/pipe_rd.png
+%%DATADIR%%/images/pipe_ru.png
+%%DATADIR%%/images/pipe_ud.png
+%%DATADIR%%/images/plasmoid.png
+%%DATADIR%%/images/recking_ball.png
+%%DATADIR%%/images/rocket.png
+%%DATADIR%%/images/s_battery.png
+%%DATADIR%%/images/s_generator.png
+%%DATADIR%%/images/s_generator2.png
+%%DATADIR%%/images/s_implosion.png
+%%DATADIR%%/images/s_lead.png
+%%DATADIR%%/images/s_plasmoid.png
+%%DATADIR%%/images/s_rapishooter.png
+%%DATADIR%%/images/s_rbg.png
+%%DATADIR%%/images/s_rocket.png
+%%DATADIR%%/images/s_scatter.png
+%%DATADIR%%/images/s_shover.png
+%%DATADIR%%/images/s_sniper.png
+%%DATADIR%%/images/s_system_mount.png
+%%DATADIR%%/images/ship.png
+%%DATADIR%%/images/shop.png
+%%DATADIR%%/images/shot.png
+%%DATADIR%%/images/shover.png
+%%DATADIR%%/images/sink.png
+%%DATADIR%%/images/source.png
+%%DATADIR%%/images/t_shot.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/images/tractor.png
+%%DATADIR%%/images/turret_down.png
+%%DATADIR%%/images/turret_left.png
+%%DATADIR%%/images/turret_right.png
+%%DATADIR%%/images/turret_up.png
+%%DATADIR%%/images/ufo.png
+%%DATADIR%%/images/vgate1.png
+%%DATADIR%%/images/vgate2.png
+%%DATADIR%%/images/vgate3.png
+%%DATADIR%%/images/vgate4.png
+%%DATADIR%%/images/vgate5.png
+%%DATADIR%%/images/vgateclosed.png
+%%DATADIR%%/images/vgateopen.png
+%%DATADIR%%/images/wcircle50.png
+%%DATADIR%%/images/wcircle_100.png
+%%DATADIR%%/images/weapon_point.png
+%%DATADIR%%/images/wshot.png
+%%DATADIR%%/levels/levels.txt
+%%DATADIR%%/sounds/Makefile.am
+%%DATADIR%%/sounds/boom.wav
+%%DATADIR%%/sounds/bounce.wav
+%%DATADIR%%/sounds/cashregister.wav
+%%DATADIR%%/sounds/clang.wav
+%%DATADIR%%/sounds/kaboom.wav
+%%DATADIR%%/sounds/pop.wav
+%%DATADIR%%/sounds/shatter.wav
+%%DATADIR%%/sounds/whitebass25.wav
+%%DATADIR%%/sounds/whiteout25.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%