aboutsummaryrefslogtreecommitdiff
path: root/games/freeciv
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-02-16 06:04:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-02-16 06:04:37 +0000
commitfb4303de407b12e94580ab8d5c230524edd8630b (patch)
tree50a2d63db0eb9036072f00c00040a2a1b1051460 /games/freeciv
parent9792c5745be378a7ede74b1cd0c6ba16c85ea5ac (diff)
downloadports-fb4303de407b12e94580ab8d5c230524edd8630b.tar.gz
ports-fb4303de407b12e94580ab8d5c230524edd8630b.zip
games/freeciv: Pet portfmt
Notes
Notes: svn path=/head/; revision=526251
Diffstat (limited to 'games/freeciv')
-rw-r--r--games/freeciv/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index 8efce57e5f65..cae322554cf2 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -43,12 +43,14 @@ DB_DESC= Database support
UI_DESC= GUI clients
GTK2_USES= gnome sdl
-GTK2_USE= GNOME=gdkpixbuf2,glib20,gtk20,pango SDL=mixer2
+GTK2_USE= GNOME=gdkpixbuf2,glib20,gtk20,pango \
+ SDL=mixer2
GTK2_VARS= _FREECIV_CLIENT+=gtk2 \
_FREECIV_MP+=gtk2
GTK3_USES= gnome sdl
-GTK3_USE= GNOME=cairo,gdkpixbuf2,glib20,gtk30,pango SDL=mixer2
+GTK3_USE= GNOME=cairo,gdkpixbuf2,glib20,gtk30,pango \
+ SDL=mixer2
GTK3_VARS= _FREECIV_CLIENT+=gtk3 \
_FREECIV_MP+=gtk3
@@ -66,7 +68,8 @@ PGSQL_CONFIGURE_ON= --with-postgres-prefix=${LOCALBASE}
PGSQL_VARS= _FREECIV_DB+=postgres
QT5_USES= qt:5 sdl
-QT5_USE= QT=core,gui,widgets,buildtools_build SDL=mixer2
+QT5_USE= QT=core,gui,widgets,buildtools_build \
+ SDL=mixer2
QT5_CONFIGURE_ON= --with-qt5-includes=${LOCALBASE}/${QT_INCDIR_REL} \
--with-qt5-libs=${LOCALBASE}/${QT_LIBDIR_REL}
QT5_CONFIGURE_ENABLE= ruledit