aboutsummaryrefslogtreecommitdiff
path: root/games/freedink-dfarc
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2018-06-07 16:23:58 +0000
committerStephen Hurd <shurd@FreeBSD.org>2018-06-07 16:23:58 +0000
commit32bc9974c361a420fc48e2c1d06fbf7b7837e05e (patch)
tree117070850dfb74a83c8ae7bcb2afde7845fc3ecc /games/freedink-dfarc
parent70bda8c16d221af6cb3844528a448b363a9c471c (diff)
downloadports-32bc9974c361a420fc48e2c1d06fbf7b7837e05e.tar.gz
ports-32bc9974c361a420fc48e2c1d06fbf7b7837e05e.zip
Update to latest release.
Security: CVE-2018-0496
Notes
Notes: svn path=/head/; revision=471931
Diffstat (limited to 'games/freedink-dfarc')
-rw-r--r--games/freedink-dfarc/Makefile3
-rw-r--r--games/freedink-dfarc/distinfo5
-rw-r--r--games/freedink-dfarc/files/patch-po_Makefile.in.in19
-rw-r--r--games/freedink-dfarc/files/patch-src_Tar.cpp65
-rw-r--r--games/freedink-dfarc/pkg-plist1
5 files changed, 5 insertions, 88 deletions
diff --git a/games/freedink-dfarc/Makefile b/games/freedink-dfarc/Makefile
index 5d3534b44478..d9d14104d070 100644
--- a/games/freedink-dfarc/Makefile
+++ b/games/freedink-dfarc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= freedink-dfarc
-PORTVERSION= 3.12
-PORTREVISION= 2
+PORTVERSION= 3.14
CATEGORIES= games
MASTER_SITES= GNU/freedink
DISTNAME= dfarc-${PORTVERSION}
diff --git a/games/freedink-dfarc/distinfo b/games/freedink-dfarc/distinfo
index 07971c4e5259..86f92340f8c8 100644
--- a/games/freedink-dfarc/distinfo
+++ b/games/freedink-dfarc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dfarc-3.12.tar.gz) = 222a84cc91967abce4d86fb4ed8ba43455b818aecdb8487b0fe52d76ade29a83
-SIZE (dfarc-3.12.tar.gz) = 329925
+TIMESTAMP = 1528381125
+SHA256 (dfarc-3.14.tar.gz) = a51124ecd11eeca0f1d16732ef58ee690e2fa2db06cc0ec2a5b61b41f8b0e8fa
+SIZE (dfarc-3.14.tar.gz) = 336910
diff --git a/games/freedink-dfarc/files/patch-po_Makefile.in.in b/games/freedink-dfarc/files/patch-po_Makefile.in.in
deleted file mode 100644
index ee14768bcd00..000000000000
--- a/games/freedink-dfarc/files/patch-po_Makefile.in.in
+++ /dev/null
@@ -1,19 +0,0 @@
-*** po/Makefile.in.in.orig Tue Sep 30 19:11:33 2008
---- po/Makefile.in.in Tue Sep 30 19:11:48 2008
-***************
-*** 34,40 ****
- datarootdir = @datarootdir@
- libdir = @libdir@
- DATADIRNAME = @DATADIRNAME@
-! itlocaledir = $(prefix)/$(DATADIRNAME)/locale
- subdir = po
- install_sh = @install_sh@
- # Automake >= 1.8 provides @mkdir_p@.
---- 34,40 ----
- datarootdir = @datarootdir@
- libdir = @libdir@
- DATADIRNAME = @DATADIRNAME@
-! itlocaledir = $(datarootdir)/locale
- subdir = po
- install_sh = @install_sh@
- # Automake >= 1.8 provides @mkdir_p@.
diff --git a/games/freedink-dfarc/files/patch-src_Tar.cpp b/games/freedink-dfarc/files/patch-src_Tar.cpp
deleted file mode 100644
index 1a3038d849c9..000000000000
--- a/games/freedink-dfarc/files/patch-src_Tar.cpp
+++ /dev/null
@@ -1,65 +0,0 @@
---- src/Tar.cpp.orig 2015-01-24 23:59:53.000000000 -0800
-+++ src/Tar.cpp 2015-01-25 00:51:23.000000000 -0800
-@@ -33,7 +33,7 @@
- #include <wx/filename.h>
-
- #include <math.h>
--#include <ext/stdio_filebuf.h>
-+#include <fstream>
- #include <sstream>
- #include <sys/types.h>
-
-@@ -477,9 +477,9 @@
-
-
- // Open the file here so it doesn't error after changing.
-- wxFile wx_In(mFilePath, wxFile::read);
-+ std::ifstream f_In (mFilePath, std::ifstream::in | std::ifstream::binary);
-
-- if(!wx_In.IsOpened())
-+ if(!f_In.is_open())
- {
- lError = 1;
- wxLogFatalError(_("Error: File '%s' not found! Cannot extract data."), mFilePath.c_str());
-@@ -499,13 +499,11 @@
- ::wxSetWorkingDirectory(destdir);
-
- // Put the data in the directories.
-- __gnu_cxx::stdio_filebuf<char> filebuf(wx_In.fd(), std::ios::in);
-- std::istream f_In(&filebuf);
- if (ExtractData(f_In, destdir, aProgressDialog) != 0)
- {
- lError = 1;
- }
-- wx_In.Close();
-+ f_In.close();
-
-
- // We're done. Move back.
-@@ -571,15 +569,13 @@
- if (lLastCharacter != '\\' && lLastCharacter != '/')
- {
- // Open the file.
-- wxFile wx_Out(lCurrentFilePath, wxFile::write);
-- if (!wx_Out.IsOpened())
-+ std::ofstream lStreamOut(lCurrentFilePath, std::ifstream::out | std::ifstream::binary);
-+ if (!lStreamOut.is_open())
- {
- wxLogError(_("Error: Improperly archived file '%s'. Skipping."), lCurrentFilePath);
- lError = 1;
- continue;
- }
-- __gnu_cxx::stdio_filebuf<char> filebuf(wx_Out.fd(), std::ios::out);
-- std::ostream lStreamOut(&filebuf);
-
- aTarStreamIn.seekg(lCurrentTarRecord.iFilePosBegin, std::ios::beg);
- long remaining = lCurrentTarRecord.iFileSize;
-@@ -595,7 +591,7 @@
-
- // Close up.
- lStreamOut.flush();
-- wx_Out.Close();
-+ lStreamOut.close();
- }
-
- // Update progress
diff --git a/games/freedink-dfarc/pkg-plist b/games/freedink-dfarc/pkg-plist
index bdca80737652..759b03318dd8 100644
--- a/games/freedink-dfarc/pkg-plist
+++ b/games/freedink-dfarc/pkg-plist
@@ -7,6 +7,7 @@ share/applications/freedink-dfarc.desktop
share/mime/packages/freedink-mime.xml
share/pixmaps/dfarc.png
share/locale/fr/LC_MESSAGES/dfarc.mo
+share/locale/fur/LC_MESSAGES/dfarc.mo
share/locale/pl/LC_MESSAGES/dfarc.mo
share/locale/fi/LC_MESSAGES/dfarc.mo
share/locale/da/LC_MESSAGES/dfarc.mo