aboutsummaryrefslogtreecommitdiff
path: root/games/freeminer
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 11:57:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 11:57:23 +0000
commit05d5b1f2afa19d02a4fcc139b3445f123328446f (patch)
tree2b8eb3030a4d4d9786a2c33f18959dd8f58514c2 /games/freeminer
parentf85a680a6741884fbacd5b12d66feb3fb07fb25e (diff)
downloadports-05d5b1f2afa19d02a4fcc139b3445f123328446f.tar.gz
ports-05d5b1f2afa19d02a4fcc139b3445f123328446f.zip
games/freeminer: enable luajit on powerpc64
Builds fine when using luajit-openresty.
Notes
Notes: svn path=/head/; revision=549684
Diffstat (limited to 'games/freeminer')
-rw-r--r--games/freeminer/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/freeminer/Makefile b/games/freeminer/Makefile
index 6c85e6eec83a..6f645a709235 100644
--- a/games/freeminer/Makefile
+++ b/games/freeminer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= freeminer
PORTVERSION= 0.4.10.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
@@ -31,7 +31,6 @@ PORTDOCS= *
OPTIONS_DEFINE= CLIENT SERVER CURL SOUND FREETYPE LEVELDB LUAJIT NLS DOCS EXAMPLES
OPTIONS_DEFAULT=CLIENT SERVER CURL SOUND FREETYPE LEVELDB LUAJIT
-OPTIONS_EXCLUDE_powerpc64= LUAJIT
OPTIONS_SUB= yes
CLIENT_DESC= Build client
@@ -69,6 +68,10 @@ LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
.include <bsd.port.options.mk>
+.if ${ARCH} == powerpc64
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
+.endif
+
.if ${PORT_OPTIONS:MCLIENT} && ${PORT_OPTIONS:MSOUND}
USES+= openal
LIB_DEPENDS+= libvorbis.so:audio/libvorbis