aboutsummaryrefslogtreecommitdiff
path: root/games/freetennis
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-13 20:41:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-13 20:41:05 +0000
commitf40318a0ea4d9d58527a814ba4644f8388dc37fa (patch)
tree7aba9ebcf5246fe570c81259dd7c5f48f2fe4160 /games/freetennis
parentaadbbdf13950411ba26cb5a715e4cb35e0d4ff1c (diff)
downloadports-f40318a0ea4d9d58527a814ba4644f8388dc37fa.tar.gz
ports-f40318a0ea4d9d58527a814ba4644f8388dc37fa.zip
- Add staging support
- Convert to USES=tar:bzip2 - Use PORDATA for plist
Notes
Notes: svn path=/head/; revision=351239
Diffstat (limited to 'games/freetennis')
-rw-r--r--games/freetennis/Makefile22
1 files changed, 4 insertions, 18 deletions
diff --git a/games/freetennis/Makefile b/games/freetennis/Makefile
index cfc93c75d55a..59a60e214161 100644
--- a/games/freetennis/Makefile
+++ b/games/freetennis/Makefile
@@ -19,13 +19,11 @@ OCAML_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/lablgtk2/gtk.ml:${PORTSDIR}/x11-t
${LOCALBASE}/lib/ocaml/lablGL/gl.ml:${PORTSDIR}/graphics/ocaml-lablgl \
${LOCALBASE}/lib/ocaml/site-lib/sdl/sdl.mli:${PORTSDIR}/devel/ocaml-sdl
-USE_BZIP2= yes
+USES= tar:bzip2
-PLIST= ${WRKDIR}/pkg-plist
PLIST_FILES= bin/freetennis
-PLIST_DIRS= %%DATADIR%%
+PORTDATA= *
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|sfxDir = "sfx"|sfxDir = "${DATADIR}/sfx"|; \
s|gfxDir = "graphics"|gfxDir = "${DATADIR}/graphics"|' \
@@ -33,20 +31,8 @@ post-patch:
@${REINPLACE_CMD} -Ee 's@(\+)(lablgtk2)@\1site-lib/\2@' \
${WRKSRC}/Makefile
-pre-install:
- @${RM} -f ${PLIST}
- @cd ${WRKSRC} && \
- ${FIND} graphics sfx -type f | ${SORT} \
- | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} graphics sfx -type d | ${SORT} -r \
- | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/freetennis ${PREFIX}/bin
- cd ${WRKSRC} && \
- ${FIND} graphics sfx -type d -exec \
- ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} graphics sfx -type f -exec \
- ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+ ${INSTALL_PROGRAM} ${WRKSRC}/freetennis ${STAGEDIR}${PREFIX}/bin
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics sfx" ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>