aboutsummaryrefslogtreecommitdiff
path: root/games/fretsonfire
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /games/fretsonfire
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Convert the tree to use PY_PILLOW
With hat: portmgr Originally submitted by: kai
Notes
Notes: svn path=/head/; revision=529063
Diffstat (limited to 'games/fretsonfire')
-rw-r--r--games/fretsonfire/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/games/fretsonfire/Makefile b/games/fretsonfire/Makefile
index 2ea875a4df57..69f3f9054c60 100644
--- a/games/fretsonfire/Makefile
+++ b/games/fretsonfire/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
RUN_DEPENDS= ${PYNUMPY} \
${PYGAME} \
+ ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${LOCALBASE}/share/${PORTNAME}/default.ttf:games/fretsonfire-data
@@ -37,14 +38,6 @@ OPTIONS_DEFINE= DOCS
PORTNAME_UCASE= FretsOnFire
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
do-install:
@${MKDIR} ${STAGEDIR}${FOF_DIR}/${PORTNAME_UCASE}
@cd ${WRKSRC}/src && \
@@ -60,4 +53,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/README
${INSTALL_DATA} ${WRKSRC}/install.txt ${STAGEDIR}${DOCSDIR}/INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>